1 2 3 4 5 Previous Next 61 Replies Latest reply: Dec 13, 2007 7:18 PM by HOS Go to original post
  • 15. Re: Aperture 1.5.6  Crashing with Leopard
    AngeloM Level 1 Level 1 (0 points)
    Could it be that Aperture is not LAN friendly?
    I tried to use a LAN external HD to backup my images and it would not work.
  • 16. Re: Aperture 1.5.6  Crashing with Leopard
    DimagineD Level 1 Level 1 (0 points)
    Same thing here... Just yesterday I purchased my iMac and Apeture, This is the first time I use Leopard and Aperture. How frustrating. It crashes all the time... Realy ALL THE TIME. I haven't enabled Time Machine, I did do the optional install for x11 so I can use GIMP, but never installed GIMP, This machine is brand new with nothing on it, no pictures or music or 3rd paty software and I just purchased Aperture. As soon as the apertue install was done I bagan to use it but it froze on me after I used the magnifier. I saw there was an unpate to 1.5.6 so I updated it, but it still freezes as before. I'm going to put my iMac back to Tiger... I'm just glad my iMac came with Tiger and had Leopard as a DVD install. I've never done an OS rollback I wonder if that will work. But from what I hear running Aperature on Tiger works fine so thats what I'm going to do.
  • 17. Re: Aperture 1.5.6  Crashing with Leopard
    jband Level 1 Level 1 (0 points)
    I upgraded to 1.5.6 first; not that it made any difference...I have tried:
    1. install of leopard as an upgrade & then uninstall & reinstall aperture.
    2. reinstalling leopard by archiving & install (after back up with time machine) with same result
    & then uninstalling & reinstall of aperture
    3 finally, with aperture uninstalled, got rid of aperture library; then I wiped my HD clean & then reinstalled Leopard & recovered everything from my external HD. I'm going to reinstall aperture tonight & I'll let you know what happens. Butt I got a feeling it's still going to crash. I think I'll go back to Tiger. ...Nothing's ever as good as the hype...
  • 18. Re: Aperture 1.5.6  Crashing with Leopard
    JPH58 Level 1 Level 1 (0 points)
    Aperture 1.5 crashed with Tiger several times an hour doing pretty much anything. Most were lock-ups - sometimes the entire machine with the black screen requiring hard reboot. Updated to 1.5.6 and Leopard and it crashes just the same. I sent about 12 crash logs to Apple the PM working with Aperture for about 2 hours. I have talked to them many times - no answers. I rebuild and validate projects regularly - seems to help a little. I can't see continuing to use this product under these conditions. I was really hopeful about the updates- clearly no better. Does Apple ever contact you after receiving 50-100 crash reports to help? I also tried to work with support but did not want to pay the couple hundred bucks for a single issue. Apple Help!!!
  • 19. Re: Aperture 1.5.6  Crashing with Leopard
    5Macs Level 1 Level 1 (25 points)
    I was using Aperture just fine in Leopard until I starting taking RAW photos (with my Canon 40D).
  • 20. Re: Aperture 1.5.6  Crashing with Leopard
    Christian52 Level 1 Level 1 (10 points)
    Add me to the list. I'm experiencing the same problem, but only when I select a project that contains Canon RAW (40D) images. It started during an import of those images, but, oddly, after I imported a bunch of RAWs successfully and even saw them display...

    Does anyone have a suggestion for how to delete a project when selecting it causes a crash?
  • 21. Re: Aperture 1.5.6  Crashing with Leopard
    5Macs Level 1 Level 1 (25 points)
    Yes, you described my problem exactly (crashing with RAW images from Canon 40D). Now, that I know what the problem is, I can't delete the RAW photos that got partially imported. Every time I click on the Project that contains them it shows the RAW image briefly and then crashes. If I don't click on the Project with the RAW images I'm OK. So, I guess we have to wait for an Apple update. Kind of frustrating since I thought buying Leopard combined with the Aperture 1.5.6 update would take care of it. This problem was known a long time before the release of Leopard, so I'm disappointed also with Apple's response. I bought Aperture because I thought it was a "professional" software program for serious photographers. At least iPhoto imported my pictures and told me which ones (RAW) that it could not, so now I am back to using iPhoto so I can at least view my last roll.
  • 22. Re: Aperture 1.5.6  Crashing with Leopard
    SierraDragon Level 4 Level 4 (2,695 points)
    MacFixit reports:

    "Time Machine causing Aperture to crash: solution

    Apple has posted a note warning that Leopard's Time Machine can mess up the Aperture database. The resulting symptom is that Aperture will fail to open. To solve the problem, use the Time Machine system preferences to exclude from Time Machine backups the folder containing the Aperture library (by default, it's inside your Pictures folder). If the problem has already occurred so that Time Machine has already damaged the Aperture library, you will need to rebuild it (hold down Command-Option as Aperture starts up and click Rebuild Now in the resulting dialog).

    The question remains: what could be wrong with Time Machine's behavior such that it can have a bad effect on Aperture's library? Reader Tom suggests that Time Machine "may do an update on a changed file before or after the Aperture metadata has been updated"; but this seems a little unsatisfactory as an explanation, especially since Time Machine is (or should be) merely copying files, so how can it have an effect on those files? As usual, Apple is not vouchsafing any details."

    -Allen Wicks
  • 23. Re: Aperture 1.5.6  Crashing with Leopard
    Pixelstate Level 1 Level 1 (10 points)
    Since updating to Leopard Aperture crashes regularly for me also. Canon 5D.
    I use TimeMachine but had set it to ignore my HD where the library is located.
    Only seems to crash when in full screen mode...
  • 24. Re: Aperture 1.5.6  Crashing with Leopard
    jpgrove Level 1 Level 1 (60 points)
    I have also had crashes under leopard and aperture, i have also had it hang. The crashes are random but they dont seem that frequent for me to worry. But it would seem that a great many users are having teething problems, i would imagine a great many of these will be fixed in coming weeks with a resulting point release.
  • 25. Re: Aperture 1.5.6  Crashing with Leopard
    KevCheng Level 1 Level 1 (0 points)
    My Aperture started crashing a few nights ago after I came home from a short night shoot and tried to import the files. I'm using a Fuji S5.

    Aperture would launch and crash in 10, 20 seconds. About half the time I can manage to open up the task list and see that it's generating previews. After a while it became apparent that when it hits a certain file I've been trying to import, I'd get a beach ball and a second later Aperture would unexpectedly quit. I've tried rebuilding the library half a dozen times with no improvement.

    Tonight I tried to import the whole batch into iPhoto, which also crashed. Then I went through and opened each file in preview and noticed that one file in particular would crash everything -- preview and iPhoto. I remove that file from my iphoto "recovered import" directory and now iPhoto no longer crashes -- but I have not been able to tell Aperture to stop importing it. I've gone into the Aperture Library package and removed the file, aperture still tries to generate the preview and crash

    Any ideas on how to stop Aperture from generating previews completely? (Holding down Shift doesn't seem to work.)

    Kevin
  • 26. Re: Aperture 1.5.6  Crashing with Leopard
    dbmadsen Level 1 Level 1 (0 points)
    I am having the same crashing problem but I am NOT using Time Machine. I have not set it up. My conclusion: either time machine can interfere even without being set up OR there is another problem in addition to the time machine problem.
  • 27. Re: Aperture 1.5.6  Crashing with Leopard
    KevCheng Level 1 Level 1 (0 points)
    No time machine here either.

    I've done some testing of the raw files and have found that some files will crash Preview if I open them and zoom to 100% (command+0.) It seems that this problem could be an OS-wide RAW file conversion issue. (I'm shooting with a Fuji S5)

    I've weeded the troublemaking files out of Aperture Library and imported the (good) files again, but somehow Aperture is still very unstable. Even though now it doesn't crash 10 seconds after program launch, once I start moving around and looking at raw files, Aperture will usually crash.

    More to come in this epic drama.
  • 28. Re: Aperture 1.5.6  Crashing with Leopard
    Rotlex Level 1 Level 1 (35 points)
    Adding a note, and subscribing here. Brand new 2.8 iMac, Leopard, all things up to date. Aperture running for EXCEPT for image exports. Crashes every single time This is NOT good as I don't use Aperture to print!

    TIme machine on, but NOT set to backup Aperture library as per Apple's own instructions.
  • 29. Re: Aperture 1.5.6  Crashing with Leopard
    alicanlondon Level 1 Level 1 (90 points)
    I am using the demo version on Leopard clean install. I can't get past the welcome screen. Have entered the trial serial number. When I fire up aperture I get the welcome screen, click 'start using aperture' and it crashes.

    Although I'm not using time machine, I have excluded the Aperture library from it and rebuilt the library but no luck.