1 15 16 17 18 19 Previous Next 280 Replies Latest reply: Jan 17, 2012 6:01 AM by Cindy SH Go to original post
  • 270. Re: New MacBook Pro & Leopard - Airport Connection problems
    aderman13005 Level 1 Level 1 (0 points)
    Just bought a MacBook Pro and am trying to connect to the internet through our wireless router. Our other laptops (pc) have no problem connecting. We have Comcast cable. When we try to connect with Airport it says "no IP address". It finds our Linksys router but cannot connect. It wants WEP password. How do I find the password???
  • 271. Possible work around!
    poldiderjungdrache Level 1 Level 1 (0 points)
    Hi guys!
    I also got a new MBP (Leopard pre installed, so I cannot comment on Tiger performance) last October which used to connect fine to my g-wireless network at home. However, I also experienced timeout issues when connecting my laptop to wireless networks at friends places. Those issues always went away when you tried to connect a couple of times or after a reboot and my impression was that if you managed to connect once the issue would never reappear (probably that means as long as the access data is stored in the preferred networks control panel, but I never tested that. Just a hunch). I then bought a new wireless router (AVM Fritz!Box, for those who are interested, but they are, to my knowledge, only sold in Germany) and I went through all the mentioned errors. I had timeout errors, I had sudden loss of connection, heck it even told me that the passphrase would be wrong, which clearly wasn't the case. I switched back to g-mode, which helped a lot, but it still bothered me that I had paid money for a n router and I couldn't use it.

    So I started to investigate. At first I remembered an episode where I tried to connect to a friende wireless network and I didn't work. Initialy I thought she had given me the wrong passphrase so we locked onto the routers configuration interface to look for the password. We never actually found out if the passphrase was wrong or not, because in the router interface the password was displayed in hex encoding. Copying and pasting that hex string suddenly made it work. Storing that passphrase in hex endoding makes perfect sense to the router because that is the way he remembers it and that is also the way the passphrase is used for authentication. So with that in mind I decided to give it a shot. I set my router back to n mode, converted my ASCII passphrase to a hex string, I used that hex string to log on to the network and voilá it works. So far I had it running for roughly 24 hours (pure running time) and I didn't have a single issue ever since!
    So I am not saying this is a solution in all cases. It might be pure coincedence or just related to the specific hardware configuration I am using, but if some people would give this a try and report back here, we might find out if this is a possible work around for the time being.

    For those of you who don't have a clue about ascii to hex conversion or don't have a clue about hex in general don't bother. I found a very nice web page (http://www.string-functions.com/string-hex.aspx) which does all the hard work. You copy your passphrase and paste it in the upper box of the web page, you click 'Convert!' and recieve the corresponding hex string in the lower box.

    Happy testing! And I am very interested in the feedback.

    Message was edited by: poldiderjungdrache

    Message was edited by: poldiderjungdrache
  • 272. Re: New MacBook Pro & Leopard - Airport Connection problems
    Jeff La Grua Level 1 Level 1 (0 points)
    I was having the EXACT same issues, and tried this fix, and it worked first time, right out of the gate. Thanks for the great scoop! I was banging my head against the wall trying to figure it out. Thanks again!!
  • 273. Re: Possible work around!
    Eric Smith8 Level 1 Level 1 (0 points)
    I'll try some of this stuff.
    I have 2 Mac MINI 1.83 with 10.5.6, both see my airport base station @ home and connect to the net just fine.
    When I take them to my inlaws house one mini sees the linksys router and connects fine the other does not even see the signal and can not do butkiss. I was told that it was because the newer 1.83 used a different antenae. I suspect it may be a draft spec problem. any suggestions.
  • 275. Re: New MacBook Pro & Leopard - Airport Connection problems
    Cindy SH Level 1 Level 1 (0 points)

    Well, i confronted wireless connection issues too.

    Sometimes, it works if i turn off and turn on my router, and then i restart MBP. But, this method does not work every time, just 90%. For 10%, i just give up :-(

    I bought this MBP five months before, I don't wanna change some settings, so i all the time just wait and i just give up if finally nothing can help.

  • 276. Re: New MacBook Pro & Leopard - Airport Connection problems
    iamcmag Level 1 Level 1 (0 points)

    I've also had recent problems that my MacBook Pro quite sporadically drops our home network, and then it does not show up in the network list. Re-entering the network data and trying to connect only throws a timeout error.

     

    For me it helped to change the setting for channel frequency in my router, this was previously set to 20 MHz only, and after changing it to 20/40 MHz Auto, things started working again.

     

    I hope that this might apply to someone elses problems as well.

  • 277. Re: New MacBook Pro & Leopard - Airport Connection problems
    Cindy SH Level 1 Level 1 (0 points)

    Sounds workable, thanks so much, i'll give it a try.

  • 278. Re: New MacBook Pro & Leopard - Airport Connection problems
    markyboy-UK Level 1 Level 1 (45 points)

    I've been struggling with this 'Connection Timeout' issue when trying to connect an old iBook (running OS X 10.5.8) to a WiFi network and after trying everything I just stumbled on a solution - be interested to hear if this works for anyone else still having the same issue?

     

    Open the Airport panel, either from the menubar or the Network tab in System Preferences, then select the 'Join Other Network' option and, in the panel that appears, enter the name of your network and the security details and password as usual.

     

    Now, before you press the 'Join' button, press and hold the ALT key on your keyboard - with the ALT key pressed click the 'Join' button. If you're lucky Airport will now find and connect to the network and the problem will be solved.

     

    This also seems to work if you press and hold the ALT key while clicking the 'Show Networks' button - networks that Airport refused to see before suddenly become visible again and can be selected in the list.

     

    I'm not sure what difference it makes, maybe the ALT key tells Airport to try harder, but it's worked for me and the fix has survived sleep and restarts - at least so far. 

     

    Hope it helps someone else!

  • 279. Re: New MacBook Pro & Leopard - Airport Connection problems
    markyboy-UK Level 1 Level 1 (45 points)

    Spoke too soon... It stopped working again and the alt key trick is only helping rarely (or maybe it's a coincidence)... 

  • 280. Re: New MacBook Pro & Leopard - Airport Connection problems
    Cindy SH Level 1 Level 1 (0 points)

    Thanks for your sharing anyway.

     

    I have kind of found a solution, if you heavily use your MacBook Pro, next day you can find the "Connection Timeout" issue is gone. I've tried this solution multiple times, and so far so good :-)

     

    But, the hassle is you have to "HEAVILY" use your MacBook Pro. I usually download a movie, so till now, I've downloaded lots of movies, but I rarely watch them :-(

     

    Hope it could work for everyone...

1 15 16 17 18 19 Previous Next