Previous 1 2 Next 26 Replies Latest reply: Feb 12, 2008 1:33 PM by Dedo
Dan Jahn Level 1 Level 1 (0 points)
I have Mail.app set to check 4 different POP accounts. Suddenly Mail.app apparently had difficulty checking two of the accounts, and the dreaded exclamation point in a circle icon has appeared next to those two accounts. Clicking on that icon brings up the dialog box "Unable to Receive Mail. There may be a problem with the mail server or network. Check the settings for account “account name” or try again. The server error encountered was: The server “mail.domainname.com” cannot be contacted on port 110." Along with a button to "Take All Accounts Online".

Clicking this button makes no change in the accounts.
Clicking on each account individually and attempting to get email does nothing.
Clicking on each account individually and attempting to take them online does nothing, because the popup menu actually offers an option to "take account OFFLINE", although the account is in fact offline and not working.

Webmail to those accounts works fine.
Entourage to those accounts on another computer works fine.

2GHz Intel Core Duo iMac, Mac OS X (10.5)
  • mikemakesphotos Level 1 Level 1 (30 points)
    I had a similar problem with all my pop accounts.

    I repaired permissions in disk utility and then restarted. Everything started working afterward.

    Message was edited by: mikemakesphotos
  • Dan Jahn Level 1 Level 1 (0 points)
    Still no resolution on this for me. Have tried a variety of things: switched the router; repaired permissions; fsck -fy; Boot off Leopard DVD, repair disk; etc, etc, no change.

    Once Mail.app decides it can not reach a given account name, it simply will not reach that account until some period of time passes, regardless whether you reboot, restart routers, switch networks, switch DNS servers, etc. Some period of time passes, and then Mail.app will suddenly reach the account. Although the entire time that Mail has these issues, Thunderbird, Entourage, webmail all work just fine on the account in question.

    I am currently throwing away Library pref files one by one trying to see if I can isolate a particular file that is storing this bogus info.
  • Dan Jahn Level 1 Level 1 (0 points)
    I give up. I am going to switch email programs today. I am unable to resolve this issue. For whatever it is worth, I am seeing it on three different computers, and the behavior is exactly the same. If someone from Apple sees this and can offer any suggestions at all as to how to override the time out imposed on an account, I would be thrilled. I really do not want to switch email programs, but Mail.app is the only exhibiting this issue.
  • Professor B Level 1 Level 1 (0 points)
    I am having virtually the same issue, but no port 11 error. IAMP accounts keep going offline. Sometimes they can be reactivated by "Taking the Account Online". But often Mac Mail must be restarted.

    But even worse I can not access any new mail. This is the situation on a least 3 Macs with 10.5 installed.

    Everything works fine with Entourage.

    Any suggestions?
  • Dan Jahn Level 1 Level 1 (0 points)
    I wish I had a suggestion for you! The port 110 error is intermittent. Mostly the problem just manifests as the account going offline, with no ability whatsoever to get it back online. I worked on this for about 5 days, trying everything I could think of, with no resolution other than the fact that a restart of the computer sometimes speeds up the time period in which the account comes back online by itself.
  • RobinMasters Level 1 Level 1 (0 points)
    Same problem here, nothing works to fix it.
  • Dan Jahn Level 1 Level 1 (0 points)
    Well, sadly, 10.5.1 does not fix this issue.
  • Richard Fielding Level 2 Level 2 (215 points)
    same problem here..

    the only way to bring mail back online is to re-start my computer, which is pretty annoying when you are working on something else.

    Details below:

    There may be a problem with the mail server or network. Check the settings for account “XXXXXXX@mac.com” or try again.

    The server error encountered was: The connection to the server “mail.mac.com” on port 143 timed out.
  • Dan Jahn Level 1 Level 1 (0 points)
    DNS cache corruption may point to the problem. So far I have three successful operations in a row ..
    1. problem starts happening
    2. execute this in Terminal: sudo dscacheutil -flushcache
    3. problem resolved immediately (but temporarily)

    At least avoids a complete restart.
  • Metal Hoof Level 1 Level 1 (0 points)
    Hi,

    I have the same problem here and what I found is that it depends on the Internet Provider AND the pop account. I've many pop accounts repartited on 3 different pop servers: A, F and Y. I'm also connecting alternatively from my home in France, my office in Ireland and a temporary location in Ireland as well. The 2 first locations are fine for all pop servers. The last one (NTL Ireland) is not able to collect mails for the 4 mailboxes related to the F provider.

    I found this web page: http://www.evileyez.org/thunderbird-pop-timeout-problem/ explaining that it may be a way to change the POP timeout value for Mozilla Thunderbird.

    I'm wondering if there is a way to do the same thing on Mac for Mail. I had a look on the Mail preferences but did not find anything useful.

    Any idea ?
  • Dave Cook Level 2 Level 2 (355 points)
    The DNS resolver in Leopard has been changed to first attempt SRV requests for lookups initiated by the getaddrinfo() function. If the users DNS server drops these requests the DNS lookup may take an extended period of time to complete (30 seconds to several minutes) as Leopard tries different domain requests and eventually falls back to making a record request. This can result in application freezes or timeouts. I believe it's possible that this could be causing our mail servers to go off-line.

    The fix for the DNS issue is easy:
    1- Go to System Preferences
    2- Click on Network
    3- Select Built In Ethernet and click Advanced
    4- Select the DNS tab and add 208.67.222.222 and 208.67.220.220 in place of any current DNS servers. Click OK

    I implemented this last fix night. Sending and receiving mail is MUCH faster, and my servers have not gone off-line yet. Fingers crossed.
  • luester Level 1 Level 1 (0 points)
    Congratulation - Dan you are the expert! Exactly the issue which solves it..

    but why this in leopard but not in tiger? where is the difference?

    luester
  • nashman Level 1 Level 1 (0 points)
    To clarify - While you instruct folks to go to Built In Ethernet and change some settings, that is only the case if you are actually using that port, the Built in Ethernet port, for your network connectivity!?!?!? Would not be the case if someone is using their Airport card. A more general instruction would be go to the advanced tab for whichever port you are accessing the net on, and then make said changes.

    I'm not trying to be a butt, just ensuring that some of our less experienced readers/users have minimal opportunity for confusion.

    Those DNS entries you suggest to enter - they are for OpenDNS, aren't they? Would there ever be a situation where a corporate IT shop would have a problem with users putting in OpenDNS servers in their settings?

    Greg
  • Dave Cook Level 2 Level 2 (355 points)
    I wouldn't recommend it in a corporate environment. I'm just sharing what seems to be working for me at home. What I did was actually plug the OpenDNS numbers directly into my wireless router, so that I don't have to mess with my other computers. It's a pretty cool product that they have, and it's free. If you sign up you can turn on some other features as well. Works for me.
Previous 1 2 Next