Previous 1 2 3 Next 37 Replies Latest reply: May 3, 2008 2:46 PM by newdymo400 Go to original post
  • Dunestrider Level 1 (65 points)
    I have my Dymo Twin Turbo hooked up my Airport Extreme, and I print through that. Whenever I want to print to it using Leopard, I have to restart the Airport.
  • SacMac Level 1 (95 points)
    I spoke to a customer service representative who said an update will be available in another month.
  • bladerunner888 Level 1 (0 points)
    I was having the same problem after my upgrade to 7.7 with my labelwriter 330 Turbo . Here's the fix ...

    Hit the "+" sign to add a printer. On the popup window select the "More Printers" icon. You will see the new driver for the Labelwriter 330 Turbo . Select and Add. A new Entry with the Image of the Labelwriter will be displayed. The Dymo software now recognizes the printer and works A-OK.

    I did reboot my computer as I could not locate the driver under the default icon and before I discovered the More Printers icon . So incase you do not see the printer a restart should help.

    Hope this helps.
  • AlienCamel.com Level 2 (440 points)
    Awesome find blaserunner888!
    Works for me too.
  • SacMac Level 1 (95 points)
    That's only the first part of the problem, adding the print driver. But the Dymo Label software still doesn't work. It asked to be re-installed when ever it's launched.
  • AlienCamel.com Level 2 (440 points)
    And does it work after you reinstall the software?
  • bikinijack Level 2 (185 points)
    My Dymo LabelWriter 400 works just fine (7.7) since the upgrade, never even reinstalled the software.

    My CanoScan Lide 60 works but with one little hitch. When I push the button to make a PDF on the scanner, it opens up, says it can't find the driver, then I click "ok," then click the scan button on my own and the scanner works fine.
  • pvmd Level 1 (0 points)
    Dymo posted a beta of the version that is supposed to work under Leopard. It installed fine and in my series of one attempts it seems to be working. It didn't even trash my address book.
  • heg Level 1 (35 points)
    I still cannot get Dymo Labelwriter Turbo to work as of today despite Dymo saying that DLS 7.7.1 beta is compatible with Leopard. The nice Dymo icon is in the printer list in System Preferences but the application whines that it can't find the drivers. Anyone else know something I can do? It's the same driver I tried installing in December without any luck and which I reinstalled this morning after receiving an email from Dymo saying that it's compatible now.
  • Chris Byrd Level 1 (85 points)
    I am having a similar problem, yet the symptoms are a little different. I didn't have a Dymo 400 labelwriter until after I upgraded to Leopard. After the upgrade I purchased the labelwriter, and did the install with version 7.7.1 of the DLS software. Just as advertised, the software installed, I was asked to plug in the printer, and then it showed up correctly in the print utility in system prefs.

    The problem is that I have tried to print from the DLS app, Work, and text edit. Each time I get an error on the queue screen for the printer. It states the printer encountered a "general printing error". That is all the information I have, and I can't find anything else to help me fix this mess. Just hoping someone else may have come across this issue.
  • MaxxD Level 1 (45 points)
    I was having this problem as well, and it would appear that the trick is in how you add the printer.

    Go to System Preferences
    Click "Print & Fax"
    Click "+" to Add a new printer

    Now here's the trick. *+Do NOT click the "DYMO DYM0007"+* (or whatever yours is) in the list here. Instead, click on the "More Printers" button in the toolbar. You should now have a sheet drop down with a selection box for Canon, Dymo DUO USB, Dymo LabelWriter, Epson, and some others...

    Select "Dymo LabelWriter" and after a few seconds, your LabelWriter should appear properly identified in the list (for example, mine is "LabelWriter 330"

    By adding the printer this way, the Dymo Label software should recognize your printer. If you add it from the first page, it's possible to print to it with other software, but the DLS software won't recognize it.

    Hope this solves the problem. It was a pretty frustrating one, and the included ReadMe file didn't help a bit.
  • C Fisk Level 1 (0 points)
    When I try to add the printer through the more printers option as suggested in the previous note, nothing shows up for me in the printer list. I did install Dymo 7.7.1.1, the printer is recognized, but I am also getting the general print error. Do you have any other suggestions?
  • Todd Larason Level 1 (0 points)
    I too am getting the "general print error" error in the queue.

    I'm running DLS 7.7.1.1 with a LabelWriter 400. Print & Fax setup says the driver version is 2.0.1.0. This is on Mac OS X 10.5.0. I've rebooted since installing the latest Dymo software & drivers.

    I don't have any other ideas at this point.
  • MaxxD Level 1 (45 points)
    Sounds like a deeper printing system problem, and may be related to previous Dymo installs or perhaps other printing configuration issues. Sometimes the incorrect permissions on the spool directory can cause this, such that the system can't write the jobs out.

    If you do have the LabelWriter in your printer list, click on it and select "Open Print Queue..." and then select +Printer:Log & History+ from the menu.

    If you +do not+ have the LabelWriter in the printer list, you will need to open Console manually (it is in the Utilities folder in Applications) and navigate to:

    *LOG FILES*
    /var/log
    cups
    error_log

    (This will show you the same thing that "Open Print Queue" shows you.)

    In either case, you will now be in Console, which will be open to an error log that shows lots of information that isn't likely to be helpful, but may show some information that is helpful. Scroll through the list and see if any of the message make sense or more clearly describe an error. Whenever you get any sort of "general error" kind of message, looking around these log files can sometimes reveal the true cause.

    In case you are technically inclined, you can search for any error messages you find in these logs on Linux and CUPS mailing lists -- just include the term "CUPS" (Common UNIX Printing System) in your search as this is the printing subsystem used on OS X and on many Linux systems. Anything in the CUPS logs should be relevant regardless of your operating system.

    If there was nothing revealing, there is a more drastic measure you can take...

    *+Resetting the Printing System+*

    This effectively wipes out all printer configurations, spools, jobs, preferences, and settings to give you a clean slate to work with. This will affect all the printers on your system, *+so if you have any important jobs or queues on other printers, don't do this+*.

    1) Open System Preferences
    2) Open Print & Fax
    3) Hold the control key and click on the printer list. You should get a menu with "Reset Printing System..." in it.
    4) Read the warning and consider the consequences, and click Okay to go on

    At this point, you should at least have a fresh starting point, so any odd settings or configurations from previous installs should not cause any trouble and you should at least have the chance at a fresh attempt.

    If it still doesn't work, try to locate anything suspicious looking in that error_log file and post it up here, and it might be possible to find a solution.
  • Marc Richard Level 1 (15 points)
    I have the same exact problem and have tried the technique described above after installing either version 7.1 or 7.1.1. The only entry in the log file reads:

    I [27/Feb/2008:10:35:03 -0500] [Job 10] Adding start banner page "none".
    I [27/Feb/2008:10:35:03 -0500] [Job 10] Adding job file of type application/pdf.
    I [27/Feb/2008:10:35:03 -0500] [Job 10] Adding end banner page "none".
    I [27/Feb/2008:10:35:03 -0500] [Job 10] Queued on "DYMOLabelWriter400" by "mrichard".
    I [27/Feb/2008:10:35:03 -0500] [Job 10] Started filter /System/Library/Printers/Libraries/PrintJobMgr/Contents/MacOS/PrintJobMgr (PID 539)
    W [27/Feb/2008:10:35:03 -0500] [Job 10] recoverable: General print error. Cancel print job and restart job later.

    Any suggestions? I have tried multiple installations and using alternate accounts, but no luck.