Previous 1 2 3 Next 138 Replies Latest reply: Oct 22, 2008 1:15 AM by Jonnygreen65
Tim Baker Level 2 Level 2 (280 points)
Ever since upgrading to Leopard, none of my emails will show up in a search.

How do I fix this?

MacBook Pro, MacBook, Mac mini, Mac OS X (10.4.10)
  • OS Lucinity Level 1 Level 1 (40 points)
    I had the same problem.

    A quit & re-open solved that.
  • Tim Baker Level 2 Level 2 (280 points)
    Not helping me as much. I found that rubuilding the mailboxes seems to re-index the messages, so maybe that will fix it. We shall see!
  • Tim Baker Level 2 Level 2 (280 points)
    That doesn't seem to be helping. Anyone have any ideas?
  • johne-dm Level 1 Level 1 (25 points)
    i'm having the same problem. if i click on the "subject" heading, i can search by subject along, but if i have "entire message" selected, then nothing shows up no matter how inclusive the search is.

    i tried the same search in spotlight and i get mail messages there, so that might be a temporary workaround.

    my configuration might be odd in that i have my mailboxes on another partition, then linked into the library. this has worked well for me in tiger, but i'm not sure if this odd configuration has anything to do with the problem.
  • Tim Baker Level 2 Level 2 (280 points)
    EXACT same thing here. Clicking on subject brings up different results (usually a lot more) than "entire message" which is the total opposite of what should happen!
  • JJ81 Level 1 Level 1 (5 points)
    Same problem here, but my messages won't show up in spotlight either. Clicking "subject" also brings up different emails, but no those I'm actually searching for. This is very annoying, I rely on mail search! Any ideas?
  • Tim Baker Level 2 Level 2 (280 points)
    Same thing happens for me. Spotlight and searching directly with mail.app is useless now. I NEED mail search!
  • JJ81 Level 1 Level 1 (5 points)
    anyone found a solution to this?
  • Tim Baker Level 2 Level 2 (280 points)
    Update: Typing the text below in Terminal fixed the problem:

    mdimport ~/Library/Mail
  • JJ81 Level 1 Level 1 (5 points)
    thanks, but it doesn't seem to have fixed the problem for me. is there something else i have to do? i just opened terminal, typed the command and pressed enter.
  • Tim Baker Level 2 Level 2 (280 points)
    Try:

    mdimport~/Library/Mail

    instead. (no space after the "t" and "`")

    It takes about 10 minutes. It kept giving me errors that x was not found and stuff like that, but once it finished, my Spotlight worked and I could search messages.
  • JJ81 Level 1 Level 1 (5 points)
    It says 'command not found'. Is this what happened for you?
  • Tim Baker Level 2 Level 2 (280 points)
    Didn't say that for me. I just started Terminal, typed

    *mdimport ~/Library/Mail*

    Hit "Enter"

    Let it run for about 10 minutes and when I re-started Mail, it worked.
  • JJ81 Level 1 Level 1 (5 points)
    That's strange. It won't work for me. This must be G5 Imac problem, as the search is working fine on my MacBook. Thanks for your help anyway.
Previous 1 2 3 Next