14 Replies Latest reply: Jan 11, 2008 12:50 PM by Gerbras
Hamish B. Level 1 Level 1 (10 points)
I have a USB Huawei modem through Three in Australia (3G / HSPDA).

I can't get the Mobile Connect app to install on 10.5 (had to wipe MacBook hard drive to install Leopard - upgrade / archive and install didn't work too well).

Not sure what settings I need to use here.

Any ideas?

MacBook Core2Duo 2.0GHz (White), Mac OS X (10.4.8), Also have a Mac Mini CoreDuo, and a Dual G5
  • LONJJ1 Level 1 Level 1 (10 points)

    To get things going with 3 in the UK I've run the HuaweiDataCardApp application to set the APN (its three.co.uk) here
    Then in Network section of system preferences, select the modem and set the telephone number to *99#

    you can then hit connect to establish the link

  • Hamish B. Level 1 Level 1 (10 points)
    Thanks mate!

    I couldn't get the Mobile Connect app to work, but found a newer version from a UK site.

    Read about my tribulations and triumphs here:

    Took all of 10 minutes. I love the net!
  • Tim Haigh Level 7 Level 7 (24,185 points)
    I have the HUAWEI mobile E220.

    Using the drivers that came with my T-mobile webnwalk pack it worked first time in leopard.

    You can get the drivers from my dot mac space


    Once installed you can use the HuaweiDataCardApp to set your APN.

    I don't require anyother 3rd party software to make the conneciton.

    I went to SystemPreferences-->Network-->Location -->Edit Locations

    click the +

    I added HSDPA as my location name.

    Then I chose add configuration

    I called it 'T-Mobile'

    I used *99# as the telephone number

    my provider does not require me to use a username and password so I left that blank.

    I checked 'show modem status in menubar'

    Then click Advanced.

    click the modem tab

    Model: Huawi Mobile Connect

    I have enabled error correction checked

    Dial mode 'ignore dial when dialing'
    Then click the PPP tab


    uncheck 'send PPP echopackets'
    Then click ok
    then Apply

    Now to engage the connection I plug in the usb modem wait for the green or blue light to flash.

    I goto the menubar modem icon and choose Connect HuawaiMobile

    This works.

    Now to monitor my modem signal, usage etc I use cheetahwatch


    Good luck
  • ganselmetti Level 1 Level 1 (0 points)
    I tried to follow your suggestion but when I use HuaweiDataCardApp this run forever I have to forced to stop it.
    (leopard and Huawei E220 card)
  • Tim Haigh Level 7 Level 7 (24,185 points)
    I tried to follow your suggestion but when I use HuaweiDataCardApp this run forever I have to forced to stop it.

    You only need to run this app once. Once you have run it and entered the APN you don't need to run it again as the information is embedded in the usb device.
  • Brett Jolly Level 1 Level 1 (15 points)
    Tim, you absolute diamond, I had been sitting all day trying to sort out the Huawei E220 problem with Leopard. Your solution worked first time, thanks mate.
  • pab-gva Level 1 Level 1 (0 points)
    Thanks to all for the ideas.

    However I can set up the APN neither with HuaweiDataCard.app (I try to use the USB modem...) nor with the application sold with the modem (MobileConnect.app). The first one give an error message "APN is configured failed!" and the second one simply crashes before opening.

    As the obvious consequence, though correctly (I think) parameterized the modem run and run till the error message.

    I tried to download the latest version of the piece of sofware at
    but the download stops always after 97.45%.

    I am surprised as the package is advertised by Swisscom as working under Leopard.

    Any clues? Many thanks.

  • sgleadow Level 1 Level 1 (0 points)
    I managed to get hold of Three Australia on the phone to fix the problem. Turns out the instructions they offer are not valid for Leopard. I still can't open the MobileConnect application, but I can now connect through the phone icon in the menu. This is what I did:

    - add the device in the network preferences (though this may also be automatic)
    - set Configuration to Default (may be automatic)
    - set phone number as *99# (I guess this number may vary across the world, but they'll tell you which number to use)
    - open the Advanced tab
    - select Vendor: Generic (not Other, as my instructions stated)
    - select Modem: GPRS (GSM/3G) (not Huawei, as my instructions stated)
    - select APN: 3netaccess (though that'll almost definitely be different for each provider)
    - CID: 1
    - Click Apply, then Connect, and away you go

    Hope that helps. It's been a frustrating few hours. The box should say it doesn't work with 10.5 or give the latest instructions.
  • lippyni Level 1 Level 1 (0 points)
    While I find it annoying that a T-mobile supplied driver worked on leopard whilst the three one whom i am with didnt and kept crash, I feel I must post and thank you tim you flipin dancer! Posting it right now through my huawei.
  • Tim Haigh Level 7 Level 7 (24,185 points)
    As you only need to set the APN once. goto a friends house who has a PC and setup the APN with our USB modem connected to a PC. Then bring it back to your mac.
  • soulpappa Level 1 Level 1 (0 points)
    Have had a look at what needs to be done to get the E 220 to work.. Guess what? The Driver CD that comes with the 3 Mobile Broadband kit seems to work just fine.. In fact the drivers do! What needs to happen is the correct configuration of the APN which should be 3netaccess (using the Huawei E 220 APN Configuration App provided in the above post) all standard fields should be filled out as per the instructions outlined in the .pdf file on the Driver CD. So go to Tim Haigh's post dated 30th October 2007 and download the file... open it and fire it up.. then all you need to do is enter 3netaccess into the configurator and your done and dusted. Thanks Crew and.. Happy Surfing! (Special Thanks to Tim!!).
  • coding.kev Level 1 Level 1 (0 points)
    Just wanted to say thanks for your post. Saved me a load of hassle.


  • luckysevenstar Level 1 Level 1 (0 points)
    Tim and all, thankyou so much.
    After a frustrating day, I am now able to use my E220 on 3 mobile broadband.

    Thanks again
  • Gerbras Level 1 Level 1 (0 points)
    Hi Tim

    Thanks very much for taking the time to post this. I am in Aus with the Huawei e220 (Vodafone) and about to leave for Tassie tomorrow. I need to work while I am away so will be relying very heavily on the e220. I had a little freak out last night when I couldn't get it to work with Leopard. Tried a range of different suggestions, but only yours worked.

    So thanks again!



    PS: Have also downloaded Cheetah Watch!