12 Replies Latest reply: Nov 13, 2007 7:47 PM by nymacmac
nath0590 Level 1 Level 1 (0 points)
the other day, when i connected my iphone to my PowerBook, iTunes said:

it couldn't read the contents of iPhone "Nathan's iPhone." Go to the summary tab in the iPhone preferences and restore it.

So I do, and when iTunes is almost done "extracting software..." it gives me an "Unknown Error (-18)" and says that the iPhone couldn't be restored.

to add some more stuff into the mix, I tried this:

I clicked "restore" once the confirmation dialog popped up, letting me know that the iPhone data will be erased, I unplugged the iPhone from the computer. Keep in mind, that the restore function has not even touched the iphone yet, it is still waiting for me to confirm.

so, I click restore, and it starts "extracting software..." and at the SAME place in the progress bar, near the end, it gives me the unknown error (-18), without the phone even plugged in.

So I think that this is a bug in the 1.1.1 software restore.
----
Oh, and this also happened on my PC with the same error.



any and all input will be appreciated, thanks

Powerbook G4 1.67Ghz 15" Aluminum, Mac OS X (10.4.10), Final Cut Studio 2!
  • nath0590 Level 1 Level 1 (0 points)
    oh, and the software symptoms that the iPhone is showing are these:
    Basically, there are 7GB of music/videos on the 8GB iphone, but the "About" section of the settings says 0 songs and videos. When I open the iPod app, it says no content. Oh, and the About section also says that I still only have about 150MB free, with "0" songs or videos.

    From this, I assume that the iTunes database file got corrupted. But when I connect to iTunes, it says that it cannot read it.

    Could there be a partition of the iPhone memory that is for the iPod music? Could that have been corrupted some how?
  • Aaroneous Level 1 Level 1 (0 points)
    Did you ever find out how to fix it? Same problem here and have yet to find an answer.

    Thanks.
  • Lawrence Finch Level 7 Level 7 (32,750 points)
    Make sure you are connected directly to a USB port on the computer, not through a hub.

    Why did you disconnect the iPhone? That is most likely the cause of the error -18.

    You may have a defective cable or dock; there were a lot of reports of dock failures early on.
  • nath0590 Level 1 Level 1 (0 points)
    Yes, I am connecting directly through a hub. And it showed the error -18 the first time that I tried to restore, I let it sit, and while it was extracting software, it gave me the error.

    What I also noticed was that the iPhone never says "Slide to Cancel" the sync, it says slide to unlock. From that I can tell that the iPhone is not connecting properly. Oh, and I tried it with several other iPod/iPhone USB cables, and I got the same result.
  • xpesrx Level 1 Level 1 (0 points)
    I have the same issue... glad to find someone else who does... apple? what's the solution?
  • peteobe Level 1 Level 1 (0 points)
    I also have this same exact problem! Any ideas?

    Message was edited by: peteobe
  • nymacmac Level 1 Level 1 (0 points)
    I have the same problem too. One thing I noticed was that all songs in my iPhone were deleted after this error occurred. Other data (email setting, contacts, calendar, etc.) seem intact.
  • peteobe Level 1 Level 1 (0 points)
    Yes, this is exactly what is happening to me...the phone is fine, all the music and videos are deleted from my iPhone, and it will not make any updates to Photos, Contacts, etc...although these features are still working on the Iphone.

    So far, I have unistalled my iTunes software and then reinstalled a new version, reset my iPhone, deleted some pictures and playlists that were listed in iTunes, and reset "all settings" on the iPhone in the general settings area -- nothing has worked...
  • Sliney Level 1 Level 1 (55 points)
    Same problem here. Apple Store here I come....
  • nath0590 Level 1 Level 1 (0 points)
    Ok, I have just got my replacement from the apple store. The Genius Bar guys couldn't fix it, they tried just about everything that I did myself.

    So, just go there to get it replaced. It is less of a hassle than carrying around a $400 iPhone minus the iPod


    Oh, and if I didn't already say it, the first symptoms that I noticed were that my iTunes Album art wasn't showing up in the iPhone cover flow mode foe songs that DID have album art. If this happens to you, don't wait, just restore your phone. This might just save you a few days/weeks of frustration



    good luck all!
  • peteobe Level 1 Level 1 (0 points)
    Hi Everyone,

    I was able to fix this problem...Here is what I did.

    On the iPhone:

    Go to Settings/General/Reset
    Click on -- Reset all Settings and then
    Click on -- Erase All Contents and Settings

    You will lose any pictures that you took with you iPhone since your last sync, so save them to your hard drive before you do this.

    Before syncing -- restart your computer -- then sync

    I tried to sync before restarting -- to no avail

    I have synced about 10 times since and my phone is working perfectly.

    I suspect that this happened because I removed the iPhone from the cradle while it was syncing.

    Good Luck to all...
  • nymacmac Level 1 Level 1 (0 points)
    I solved this problem with the method mentioned here:

    http://discussions.apple.com/thread.jspa?messageID=5470573