Previous 1 2 3 Next 40 Replies Latest reply: Jun 17, 2008 9:19 AM by Bob Greenspan
jayctravis Level 1 Level 1 (0 points)
Upgraded from Tiger to Leopard with an existing working Bootcamp partition. Also picked up the new wired keyboard.

Works great in OSX, works some of the time in random user accounts in XP. Sometimes the keyboard will not type on the login screen and the mouse will work. I'll click a guest account and then the keyboard will work inside, then both mouse and keyboard will freeze if I switch accounts. But not every time. I hypothesized the user account might be stealing the device and not allowing other accounts to manipulate it?

Most annoying is the option key will not trigger an OS selection on boot. I tried the keyboard in a usb hub and directly into the back of the iMac and neither way makes much difference. Thing is it's random what works and what doesn't. Should I try running the Bootcamp setup again from the Leopard disk? New driver disk?

One other thing I thought of, the previous keyboard was bluetooth - should I perhaps make sure XP isn't still polling for BT?

Message was edited by: jayctravis

17"iMac, 2.0ghz Macbook, Mac OS X (10.4.9)
  • David A. Gatwood Level 3 Level 3 (580 points)
    If it doesn't work for the boot picker or in XP, my guess would be a defective keyboard, but then again, you say it has no problems in Mac OS X.... You might try borrowing someone else's wired keyboard and see if it gives you the same problems. If so, return the keyboard to wherever you bought it and get a new one. If not... then I'm baffled.
  • AlanBaxter Level 1 Level 1 (0 points)
    It sounds like the mouse/keyboard problems I am having on two different set ups (posted elsewhere). When it happens on the desktop, applications keep running but all USB ports lose power - including mouse and keyboard. The desktop machine frequently boots into a dead USB situation, requiring a hard reboot.. Never had these problems with either machine under 10.4.


  • David A. Gatwood Level 3 Level 3 (580 points)
    Hmm. Have you installed any firmware updates recently? I wouldn't such a problem to be caused by Leopard but only show up in XP....

    That said, anything is possible. I remember a time when MkLinux caused the clock to stop in Mac OS 7 or 8. If you booted into MkLinux, it disabled the 1 Hz interrupt, and Mac OS didn't enable it (since it assumed the hardware would come up in its default state with that interrupt turned on), so if you rebooted instead of shutting down, Mac OS seemed normal in every way except that the menu bar clock didn't ever update. So yeah, I suppose anything is possible... in theory....
  • soulracer Level 1 Level 1 (0 points)
    I have the same problem with my iMac and 10.5, the problem is I am not sure if it is the alum kb or if somehow it is related to my recent 10.5 updated.
  • lowededwookie Level 1 Level 1 (0 points)
    I have the same problem.

    Option key won't work and while I was trying to install WinXP it wouldn't press Enter, then a reboot and it would maybe press enter then stop after trying to format the partition.

    I unplugged the aluminium keyboard and plugged in an old HP USB keyboard and it worked fine.

    Now Windows runs okay although I have to unplug then replug the mouse back into the keyboard and it works.

    But I cannot get the Option key to work on bootup neither will the C key or any other key work on startup.

    There hasn't been a firmware update for the Mac Mini in almost a year so that can't be the problem. It's only been since installing Leopard (fresh install).
  • Justin Greenfield Level 1 Level 1 (10 points)
    I am having a similar problem.

    I picked up a new wired aluminum keyboard and an external USB hard drive the other day to compliment my Leopard installation. All that stuff works fine.

    This morning, I decided to boot into windows XP to update the drivers from the Leopard install DVD, but I could not get the boot camp chooser to appear by holding the "option" key during startup.

    I had to go into the Startup Disk preferences and select my XP partition to boot, and that worked fine. I also do the opposite in XP to get back to booting OS X.

    But holding down the "option" key during startup to select a boot partition is not working for me.

    This is on a 20" iMac 2.0GHz Core Duo with Leopard, upgraded from Tiger 10.4.10. The keyboard is connected to the back of the iMac, and the new USB hard drive is also connected back there. The only thing connected to my keyboard's USB hub is the mouse.

    I have not tried going back to my old keyboard and restarting, to see if it's something to do with this new keyboard, but I will try that.
  • Robert Higgins Level 1 Level 1 (0 points)
    I have the new alum keyboard on an 2Ghz core duo Imac and the option key would not startup either. Original wired keyboard does. Tried the aluminum keyboard update but says not needed as OS 10.5 must have all drivers needed. Got thru bootcamp install using the original keyboard, also had to format partition in windows xp install to work, otherwise disk error.
  • smile dr Level 1 Level 1 (10 points)
    I just purchased a wired aluminum keyboard and have the exact same problem. The option key does not work when booting into bootcamp. Apple sent me a replacement but same result. Its obviously a bug in the keyboard. I was told the keyboard update was suppose to address the problem but it didn't. Hopefully there will be a patch. Its not Leopard. The problem was there before I upgraded from 10.4.9.
  • Justin Greenfield Level 1 Level 1 (10 points)
    For the record, I went back to my old Apple Pro keyboard that came with my iMac and the option key worked fine to select the boot partition on startup.

    Looking at the things in System Profiler shows that the old keyboard was USB 1.1 and this one is USB 2.0.

    Since the new external drive is connected to the USB 2.0 bus as well, I disconnected it and restarted, however the option key on the keyboard still failed to bring up the Boot Camp chooser, so it's not a combination of aluminum keyboard and external USB drive.
  • the.browns Level 1 Level 1 (0 points)
    I bought the new keyboard on Saturday (11/3) and have the same problem with the option key not working on startup (although it worked on a new Macbook I tried). I am also having trouble assigning keyboard shortcuts to the available "F" keys; they don't seem to work either. I spent about an hour with Applecare on Sunday and they said that it might be a bad keyboard, but I have yet to hear from anyone who has the new aluminum keyboard where the Option key does work. I tried to install the keyboard update 1.2, per Applecare's suggestion, but I got a message saying that what I have is newer than the update. I assume that Leopard had the update already built in. It does appear to be a bug.
  • Mercdom Level 1 Level 1 (0 points)
    I've had this same problem with my previous install of 10.4.9 and still have the problem in my clean install of 10.5. None of the keys on the keyboard work during the initial OSX boot screen, but the older white keyboard does not have this problem. I'm also able to use the apple remote to get to the drive selector just fine. It is something specific to the new aluminum keyboard.
  • StarBlue Level 1 Level 1 (0 points)
    I am having the same problem. I have an early 2006 Intel iMac. Also recently purchased the new Aluminum Keyboard. I made sure I had the latest greatest firmware before upgrading to Leopard. There has not been an update in a while for my model. Anyway everything works great as expected except for I can't hold Option down on startup with the New keyboard. If I use the old one that came with my iMac it works perfectly.

    I have an Western Digital External Hard drive and have noticed that it seems to take a lot longer to boot if it is plugged in when I turn on the system. I got around that by turning the external drive off until after I boot. But I will see if it still affects me.

    Jhan Jensen
  • Jerry Ennis Level 1 Level 1 (0 points)
    I have the same problem. Just bought a new keyboard and OPTION does not work during startup. Had to resort to using an old keyboard and pressing OPTION on that works fine during startup.

    I'm running 10.4.10 btw.
  • deadlyhifi Level 1 Level 1 (5 points)
    Having same problem here on 24" alu iMac. Have tried 2 different versions of windows (home and pro) both with SP2.

    Have tried starting without keyboard, mouse, etc. All combinations!

    Come on Apple, release a fix!
Previous 1 2 3 Next