8 Replies Latest reply: Jan 2, 2008 10:12 PM by Noah Kivett
knateb Level 1 Level 1 (0 points)
Disk utility has found problems. Specifically it returned this info:

Verifying volume “Macintosh HD”
Checking HFS Plus volume.
Checking Extents Overflow file.
Checking Catalog file.
Invalid node structure
The volume Macintosh HD needs to be repaired.

Error: The underlying task reported failure on exit


1 HFS volume checked
Volume needs repair

I have tried to restart the iBook using the original restore CD, the original install CD, the Leopard CD, the Tiger CD and Norton Utilities CD. The computer will read the discs but will not boot from them so I can't find a way to repair the effected volume.

Tried Parameter Ram but feel there are deeper problems; just don't know how to get to them.

ibook g4, PPC 1.42GHz, Mac OS X (10.4.10)
  • Duane Level 10 Level 10 (117,950 points)
    knateb, Welcome to the discussion area!

    Just for the record, your iBook shipped with a version of OS X somewhere between OS 10.4.2 and OS 10.4.4. Therefore it will never boot from a retail Tiger (10.4) disc.

    Have you tried resetting the PRAM?

    Have you tried resetting the open firmware? The procedure is
    1. Start up into Open Firmware by pressing and holding the Command-Option-O-F key combination during startup.
    2. At the Open Firmware prompt, type: reset-nvram
    3. Press Return.
    4. At the Open Firmware prompt, type: reset-all
    5. Press Return.
  • spudnuty Level 5 Level 5 (7,045 points)
    I have an external DVD-ROM that I salvaged from a Mac G3 B&W in an alley. It's in a LaCie Firewire External box that I got from the thrift store for $5.

    Not that I'm bragging about the cost (I am) but I use it for almost all installs now. Sometimes the drives in the machines I repair are flaky and cause problems on installs. I just spent half the night working on an install on a G3 B&W that kept failing, errors, won't boot. Finally I pulled that drive out of my external and just plugged it in to the G3. Installed everything in 2 hours this morning, no problems.

    Richard
  • knateb Level 1 Level 1 (0 points)
    Thanks for the timely posts. I tried the Open firmware resets. I learned something I did not know existed. It did not help. And yes, per my original post I tried resetting PRAM. I did not know that this machine would not boot from a retail OS X disc; however, I tried the original restore and install discs and held down the "C" key to no avail. The machine should have, I think, booted from the system disc on Norton Utilities, no? Anyway, thanks for the input.
  • Duane Level 10 Level 10 (117,950 points)
    I did not know that this machine would not boot from a retail OS X disc;...


    It won't boot from a retail Tiger disc since this is an earlier version of OS ;X than the iBook shipped with.

    It shouldn't have any problem booting from the retail Leopard disc.
  • knateb Level 1 Level 1 (0 points)
    Duane, thanks for your timely responses and help. One can always learn something new. Unfortunately, I still cannot get the iBook to boot from CD and, as far as I know, that is the only way I'll be able to use disk first aid to attempt repair.
  • Susan M Level 2 Level 2 (320 points)
    Do you have access to another Mac with a firewire (or an external firewire drive with the OS installed)? If so, you should be able to attach it in Target Disk Mode and use Disk Utility to repair your disk.

    Hope this helps.
  • Elmo299 Level 1 Level 1 (0 points)
    I have the same problem. If you put in the Retail DVD of Leopard on startup, you will hear the dvd spin and search. But then does a normal startup.

    It does take longer from the grey screen to the grey apple screen.

    Tryed everything above and does not work.

    If i mount it in OS and start it from there, i can press restart give in my password and it will restart, butt the same as above.

    Apple suggests on its webpage to go to the startup section, there choose the Leopard dvd and press restart. It does not restart then and give an error sound like you unplug hardware.

    Can anyone help me 2?
  • Noah Kivett Level 1 Level 1 (30 points)
    Anyone have a solution for this yet?? I am trying to install 10.5 on a friends ibook G4 and I cannot get it to boot of of any retail DVD I have nor will it boot off of an external HD... When trying to boot off of the retail DVD it just makes a lot of spinning noises...