Previous 1 2 3 Next 40 Replies Latest reply: Jan 19, 2008 12:19 AM by frankxiv Go to original post
  • OKCdan Level 1 Level 1 (0 points)
    AnnEarl wrote:
    Did you by chance install Rosetta Stone SMS?


    I'm having the exact same problem on an iMac that I upgraded to Leopard. I do have Rosetta Stone installed with the SMS. I just figured it was a Leopard problem but I guess I'll have to try it on some other machines and see. Have you tried removing Rosetta's SMS and, if so, did it make a difference?
  • AnnEarl Level 1 Level 1 (35 points)
    Yahoo! and Dang!
    I checked that my managed account was still in a locked down state. Yep. Then I logged out and logged in as the administrator. I stopped the Rosetta Stone SMS service (Apps -> SMS -> Stop SMS). Fast switched to the managed account and had total web access. Logged out, started SMS, logged in and back to locked down.

    So, on my machine, the Rosetta Stone SMS caused the managed accounts to go into a no internet access state. I know what is wrong but, dang, I can't seem to have both at the moment.
  • AnnEarl Level 1 Level 1 (35 points)
    Follow-up. I changed the SMS from 127.0.0.1:8080 to 127.0.0.1:8090. I wanted to change the ip to 127.0.0.5 but I it only gave me the one choice but let me change the port. So, I did that. It now seems to be allowing both to run at the same time.

    With 10.5.1 and the change to the SMS, my parental controls seems to be working (at least how I want them too).
  • wildsage2 Level 1 Level 1 (0 points)
    I am surprised that you have resolved this problem in regard to The Rosetta Stone application. I have no such application, and I, like many others, still have no Internet access if the Parental control is invoked, no matter how strictly or permissively. See postings following the heading: "Parental controls gone mad". There is a much broader problem here.
  • skidave1 Level 1 Level 1 (0 points)
    AnnEarl,

    Thank you for your thoughts, but now, try not to laugh but I have no Idea if I have rosetta stone, what rosetta stone is or if I have it weather I need it or how to get rid of it. I am a newbee to mac (long, long time windows man till Sep 07) loving my mac and OS 10.5.1 sooo, you and the other very helpful posters are talking a bit over my head. Can you advise me as to how I can tell if I have this rosetta stone and how if not needed get rid of it. other than the OS the only programs I have installed are adobe creative suits and iWorks. Thanks again for your thoughts and help and to all who have read and advised.
  • AnnEarl Level 1 Level 1 (35 points)
    Rosetta Stone is a packaged software product that teaches foreign language. My daughters are using it for French. The version we have has two components, a "client" that does the actual teaching and a "student management system (SMS)" that orders the lessons and keeps records.

    In my case, the "SMS" acted as web server and communicated with the "client" like a web page does with a browser. It appears to me on the surface that Parental Controls might do a similar trick to verify web traffic (i.e. route it through an internal web server before it goes out). If I am correct (and I am just guessing), the Rosetta Stone package software and Parental Controls were both trying to talk over the web address of 127.0.0.1:8080 (which is the kind of thing any URL turns into behind the scenes).

    Since you don't know what Rosetta Stone is, then you probably don't have it installed and some other cause is driving bad Parental Control behavior. I do not have the Adobe products but, because they act as a suite, they may communicate with each other through a common server. They may just share file formats only; I am out of my knowledge area.

    My working theory is that for me, in addition to Parental Controls some other application was talking on 127.0.0.1:8080 (Rosetta Stone in my case) and when Parental Controls tried to use 127.0.0.1:8080 to get to the internet, it got the other application and declared the internet not accessible.

    I found when I switch Rosetta Stone package software to 127.0.0.1:8090, they both could co-exist.

    Hope this helps explain my current solution and maybe helps you find your own solution.
  • Dave Drake Level 1 Level 1 (0 points)
    in my experience so far 10.5.1 does NOT fix any parental control issues. when you restrict web access to the highest setting in parental controls (allow only approved sites) you cannot easily access kid friendly sites like webkinz. I had to move to the intermediate security level to get these sights to work.

    All this work perfect in Tiger, whatever apple changed they certainly need to fix.
  • jenellemcbride@yahoo.com Level 1 Level 1 (0 points)
    I ended up turning off Parental Control. It's not very useful, more trouble than its worth. I had trouble with some java apps on the net not working right (due to OS X setting the account to managed).

    *Anyway here is my problem:* Parental control's are no longer on. My account is set as an Administrator and parentalcontrolsd process uses 90-100% CPU all the time! Regardless of restarts. And I have the latest Update 10.5.1.

    Any Ideas?

    Thanks to anyone who can help.
  • BostonSwitcher Level 1 Level 1 (30 points)
    I bought my iMac right around the time of Leopard release and one of the first things I did was turn on Parental Controls. I had many of the same problems and additional ones (dashboard was hosed and I could not get it back for the life of me). I tried every solution there was out there and including some that werent (local genius tried to help). In the end I had to Archive and Install, after that everything has been fine.

    Parental Controls are certainly not worth it
  • jenellemcbride@yahoo.com Level 1 Level 1 (0 points)
    Thanks that worked.
  • FunnyHowThatWorks Level 1 Level 1 (0 points)
    Philip,

    I found your blog via Google. Thanks much! I only wish I had found it two plus hours earlier.

    To say it is frustrating that Simple Finder searches through subfolders to find applications to allow but does not support actually using them, is an understatement. I tried everything including adding my own aliases to /Users/userid/Library/My Applications. This worked until I logged out. When I logged back in, the Finder deleted my aliases.

    But your post did give me an idea. I placed aliases to my desired applications in /Users/Shared. This works great and survives logout/login. It is not as obvious as placing aliases to Applications in the Applications folder (oh Apple...), but it works very well.

    Hope this helps others...
  • wishimac Level 1 Level 1 (0 points)
    I have the same issues with parental controls. As far as it not recognizing sub-folders when listing applications in the "My Applications" folder, here my solution... and it works for me.

    I created a simple automator workflow to launch an application (the one in the sub-folder) and saved it as an application with the same name of the application to launch. Then I placed it in the /Applications folder. I copied the icon from the application target application to the Automator application I created just to make it look correct. Finally I opened parental control, checked the automator app and the target application in the list. Now everything works fine... (except for the additional icons in my applications folder)

    Hope this helps.
  • Doug_G Level 1 Level 1 (0 points)
    was having similar problems after a Time Machine system restore. Namely, my daughters parental control managed account was giving "Could not connect to server at..." errors.

    Turns out that Time Machine failed to create some necessary directories under /private/var/log. The one that effects Parental Controls is /private/var/log/apache2

    To check for this problem, start a console window, and type:

    iMacG5:~ admin$ ls -ld /private/var/log/apache2

    if you get the following, the directory does not exist and must be created:

    ls: /private/var/log/apache2: No such file or directory

    to fix this, in the console window type:

    iMacG5:~ admin$ sudo mkdir /private/var/log/apache2

    you will be prompted for your account password. from there, verify directory creation

    iMacG5:~ admin$ ls -ld /private/var/log/apache2
    drwxr-xr-x 4 root wheel 136 Nov 24 09:31 /private/var/log/apache2

    log out and back in to the parental control account, and network access should be restored

    Doug G
  • Peter R. Level 4 Level 4 (1,190 points)
    Doug_G wrote:
    start a console window, and type:


    Eh - dummy question - how can I type in console.app? This is read-only, isn't it?
  • Doug_G Level 1 Level 1 (0 points)
    Peter R. wrote:
    Doug_G wrote:
    start a console window, and type:


    Eh - dummy question - how can I type in console.app? This is read-only, isn't it?


    ack. try the above in a terminal window.