Skip navigation
This discussion is archived

JBL Speakers

1445 Views 10 Replies Latest reply: Nov 7, 2007 7:27 AM by Topper99 RSS
HH4 Calculating status...
Currently Being Moderated
Oct 30, 2007 7:58 PM
I just purchased a new iMac, which I upgraded to OS x.5. My JBL speakers, which worked on my old iMac (with x.4) worked fine. Now they do not show up in my list of output devices. They are powered on. Anyone have info on this? The speakers may be old, but they should work- shouldn't they? Thanks.
iMac, Mac OS X (10.5)
  • Andre John Mas Level 4 Level 4 (1,015 points)
    Currently Being Moderated
    Oct 30, 2007 8:14 PM (in response to HH4)
    What model are they and do you know if you needed to install drivers previously to use them?
    MacBook Pro 15" 2006, Mac OS X (10.4.8)
  • Andre John Mas Level 4 Level 4 (1,015 points)
    Currently Being Moderated
    Oct 30, 2007 8:38 PM (in response to HH4)
    Have you looked at JBL's support page or contacted them:

    http://www.jbl.com/

    I wish I could be of more help.

    While I'm thinking about it, do they appear in the System Profiler?

    Message was edited by: Andre John Mas
    MacBook Pro 15" 2006, Mac OS X (10.4.8)
  • Andre John Mas Level 4 Level 4 (1,015 points)
    Currently Being Moderated
    Oct 31, 2007 4:30 AM (in response to HH4)
    Are they properly connected, do they still work with the old computer?
    MacBook Pro 15" 2006, Mac OS X (10.4.8)
  • Andre John Mas Level 4 Level 4 (1,015 points)
    Currently Being Moderated
    Nov 1, 2007 3:49 PM (in response to HH4)
    Stupid question, but are they powered up, or are they meant to use the Mac for power?
    MacBook Pro 15" 2006, Mac OS X (10.4.8)
  • Anthony Donnelly Calculating status...
    Currently Being Moderated
    Nov 1, 2007 4:05 PM (in response to HH4)
    HH4 wrote:
    I just purchased a new iMac, which I upgraded to OS x.5. My JBL speakers, which worked on my old iMac (with x.4) worked fine. Now they do not show up in my list of output devices. They are powered on. Anyone have info on this? The speakers may be old, but they should work- shouldn't they? Thanks.


    They should work fine. Where are you expecting to find them? I have some JBL speakers myself. For output to go to the speakers I just had to go to System Preferences, Sound, Output and choose Line Out (Built in Line Output) and they work fine.

    Is your output already set to Line Out?
    Mac Pro Mac Pro 8-core, 8GB, 30" Apple Cinema Display / MacBook 17" HD 4GB, Mac OS X (10.5), iPod Touch, 3G Nano, Classic 160GB, 2G Shuffle
  • Topper99 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Nov 7, 2007 7:27 AM (in response to HH4)
    I'm having the exact same problem. My external speakers -- Altec Lansing, only a few months old -- which worked fine up to now, are not being recognized by my iMac. It's as if they're not there. There's no option in preferences to select them.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.