Previous 1 2 Next 18 Replies Latest reply: Dec 17, 2007 7:39 PM by bongoherbert
wrecked4 Level 1 Level 1 (35 points)
ok, this is a funky one. i just did an archive and install with Leopard, from tiger. after installation, i downloaded a few apps, that were updated for Leopard, and all was well. i tap the power button, revealing the menu that asks if i want to shut down, sleep, restart, etc.. i click "shut down". computer shuts down.

when i go to close the MacBook up, the indicator light on the front comes on. i then open the lid and it shuts off. i do this again and again- same thing.

so i go to start my computer. i push the power button- nothing happens. i hold it down for 5 seconds then push it again- computer boots up. after login, i get a message saying that the computer unexpectedly shut down.

if i shut down again, this process repeats. however, if i start the computer in the same manner as i described earlier, but do not log in and shut down directly from the login screen, computer shuts down properly.

the condition i described earlier sounds like the computer is not fully shutting down. while the screen goes black and everything stops running, it's acting like it has not fully shut down- almost acting like it's in sleep mode, or sleep/shut down mode. since i have to hold down the power button for 5 seconds, then push it again, it seems as if i am forcing the computer to power down, then restart, thus giving me a message saying the computer unexpectedly quit after i log in (i hope that made sense).

this has only started since the Leopard installation.

anyone else have this problem? i don't know if it's something i did, Leopard did, or what. any help would be awesome.

otherwise, i really like Leopard for the most part.

Thanks!

iMac Intel Duo Core 2, MacBook Intel Duo Core 2, Mac OS X (10.5)
  • danegeld Level 2 Level 2 (185 points)
    I had the same problem with my MacBook Pro after doing a Leopard upgrade. I had a couple of kernel panics (grey curtain) when I went to shut it down and then it would exhibit the symptoms you describe: screen went black, the sleep light came on when the lid was closed, and I'd have to press the power button for 10 seconds to make it really shut down. I was planning to do a clean install next weekend, but now the problem has mysteriously cured itself. It makes me nervous and I'll probably go ahead and do the clean install anyhow. I don't know whether it has anything to do with it, but the last few times I've shut down, I've made sure there were no running applications.
  • wrecked4 Level 1 Level 1 (35 points)
    did you by any chance use screen sharing with a home Mac? my symptoms seemed to appear after running that application. mine also mysteriously cleared up, but then after running screen sharing, it reappeared. i emailed apple about it. we'll see what happens.
  • SamDark Level 1 Level 1 (0 points)
    This fix was posted under a different category and it worked for me.

    ppleCare Instructions
    Posted: Oct 31, 2007 5:34 PM

    AppleCare had me reset my SMC. After resetting I tried shutting down my Macbook and closing the lid immediately after the screen went black. The power light went solid and I initially thought the problem was still occurring but after waiting 5 seconds the light faded off. After the light was off I tried opening and closing the lid to ensure the Macbook was truly off.

    Looks like there is a slight lag between when the LCD is shut off and when the Macbook's shutdown cycle finishes. The reset process seemed to keep the macbook from glitching and remaining on (i.e. Fans running and battery draining in my backpack).

    Here are the instructions for resetting the System Management Controller (SMC)

    MacBook, MacBook Pro

    If the computer is on, turn it off.
    Disconnect the AC Adapter and remove the computer's battery.
    Press and hold down the power button for 5 seconds and then release the button.
    Reconnect the battery and AC Adapter.
    Press the Power button to restart the computer.

    *taken from http://docs.info.apple.com/article.html?artnum=303319

    Hope this fix works for everyone.

    Paul

    P.S. Applecare also mentioned resetting the NVRAM instructions here http://docs.info.apple.com/article.html?artnum=2238

    I reset the NVRAM however I have no idea if this made any difference with solving the problem
  • Michael Q Level 1 Level 1 (0 points)
    Thanks for the information about reseting.

    My G4 ibook wouldn't shut down at all when it was plugged in to the power adaptor, and took forever when it was just running on batteries.

    I applied the fix @ http://docs.info.apple.com/article.html?artnum=14449 - which resets your clock but easily fixed.

    Works great now.
  • sbuzdug Level 1 Level 1 (0 points)
    Hi, did the clean install work? I did an archive and install and I'm experiencing these problems. Tried resetting the SMC, etc, which worked for a little while but this problems seems to be cropping up again. I can't shut down without holding the power button down for ten seconds or so...

    Stephen
  • ps40897 Level 1 Level 1 (0 points)
    I'm having a similar problem since installing Leopard:

    Problem: I've had several instances where I shut down my macbook and the process seems to be working fine, LCD shuts off, and not other signs that the computer is still on. When I come back to the computer in the morning (didn't shut the lid) it won't power on and the computer is still warm. If I hold the power button for 10 seconds (or whatever the reset length is) the computer will then power on after that. I don't get any incorrect shutdown errors and this has happened at least twice to me.

    I had performed a clean install of leapard and migrated my files to it before this started occuring. Was previously running tiger.

    Message was edited by: ps40897
  • gn9 Level 1 Level 1 (0 points)
    I'm havving the same problem after upgrade to leopard. and if it put it in my bag after supposedly shutting down, it gets very hot and the power drains.

    Any solution.

    It does not happen every time though.
  • v1q Level 1 Level 1 (0 points)
    i have the same exact problem the OP has described, in my case its a macbook pro though. i have tried resetting the smc and pram/nvram which made my mbp shut down properly right after the procedure. however, after trying to shut down for the second time the problem reappeared. today i have observed what the mbp is doing after i close the lid, it seems like as it powers itself back on with the fans running and the cpu being under a bit of a load, because it heats itself up pretty fast. here is a bit of advice though:

    DO NOT under any circumstances put your laptop in a bag like this! if the indicator light is steady it means the laptop itself is on, which in this case it seems like it really is. im trying to go for a new clean install but will not do so until some apple official confirms this issue being related to a partly bad installation/upgrade to leopard.
  • FlyEvolution Level 1 Level 1 (0 points)
    I've been have the same **** problem and have been going absolutley nuts trying to fix it.
    I first observed it when i had shut down my MBP earlier in the day and put it in its case, only to find it a few hours later, extremely hot and completely dead battery...
    Since then I have noticed that sometimes, seemingly randomly, the fan will just stay on even after the computer appears to have shutdown.
    I have submitted a comment to apple about it, detailing my findings on it from the console: (tell me if any of it makes sense to you guys?)

    I've been having a very bothersome problem with 10.5.1 for a couple of weeks now and cannot seem to get it fixed.
    Basically what happens is when I go to shut my mac down, it will appear to do so - the screen will go black and turn off - but the fan will stay on forever until i force it off with the power button. It's happen a bunch of times in the last few weeks, at least once a day, but i cannot duplicate it on request, it seems so random.
    I've looked over console logs and at first it seemed that what was causing it to hang was the qmasterd qmaster daemon, because the was the last thing it was dealing with and i suppose may have gotten stuck on before i had to force it off. I removed compressor and qmaster and the problem is still persisting, but now it seems to be hanging over my boot camp partition, with a report in the console saying "11/30/07 8:29:01 PM kextd[10] error reconsidering volume /Volumes/NO NAME
    I have the logs to help solve this problem, if it would help to provide them.
    The last time it happen the last couple of reports were:
    11/30/07 8:43:09 PM Disk Utility[185] Mount of “NO NAME” succeeded

    11/30/07 8:43:09 PM fseventsd[29] log dir: /Volumes/NO NAME/.fseventsd getting new uuid: 8E4A2AAF-E9EB-44F0-81A5-F2FDD95918EB
    11/30/07 8:43:18 PM [0x0-0x25025].com.skype.skype[183] Main starting
    11/30/07 8:43:21 PM loginwindow[25] DEAD_PROCESS: 0 console
    11/30/07 8:43:21 PM kextd[10] error reconsidering volume /Volumes/NO NAME
    11/30/07 8:43:21 PM shutdown[211] halt by pflacks:
    11/30/07 8:43:21 PM shutdown[211] SHUTDOWN_TIME: 1196473401 824106
  • v1q Level 1 Level 1 (0 points)
    i suppose i could post my error log aswell but i dont think that has anything to do with the machine coming back on after it has been supposedly shut down. the error log only comes up because you forced it to shut down by holding the power button for 5 seconds....or am i totally wrong here?
  • masoneva Level 1 Level 1 (10 points)
    The problem continues for me on MBP despite trying all the "fixes," including Archive and Install a second time. I'm going to track my logs for a while, but I'm pretty sure they are all the same. Great article at PC Mag, with which I absolutely agree: "Leoptard" http://www.pcmag.com/article2/0,2704,2223921,00.asp
  • v1q Level 1 Level 1 (0 points)
    its a bit off topic, but...

    i have a couple of hickups aswell on leopard, namely my external creative soundcard just freezes up the system when i disconnect it when it is playing back something (itunes or similar). with tiger that NEVER happened. sometimes when i disconnect and connect usb devices a few times in a row, the usb devices just stop responding. again, this NEVER happened with tiger. and another tiny little thing which is really annoying: whenever im on a wifi network and close the lid on my macbook, then after a while open it again and my mac comes out of sleep, it cant seem to find the network, although its on and functioning. only after turning wifi off and on again or manually selecting the network will my mac connect to the network again.

    just what went wrong over at apple? :/
  • v1q Level 1 Level 1 (0 points)
    ok here is the log, but like i said i doubt that you can even guess what went wrong by looking at it.

    Sun Dec 2 14:57:08 2007
    panic(cpu 1 caller 0x001A7BED): Kernel trap at 0x529a4214, type 14=page fault, registers:
    CR0: 0x8001003b, CR2: 0x0000064f, CR3: 0x0101b000, CR4: 0x00000660
    EAX: 0x006bc918, EBX: 0x000000ff, ECX: 0x00508444, EDX: 0x09671954
    CR2: 0x0000064f, EBP: 0x3426bcb8, ESI: 0x03cea000, EDI: 0x529a63e8
    EFL: 0x00010206, EIP: 0x529a4214, CS: 0x00000008, DS: 0x00000010
    Error code: 0x00000000

    Backtrace, Format - Frame : Return Address (4 potential args on stack)
    0x3426bac8 : 0x12b0e1 (0x455670 0x3426bafc 0x133238 0x0)
    0x3426bb18 : 0x1a7bed (0x45ea20 0x529a4214 0xe 0x45e1d4)
    0x3426bbf8 : 0x19e517 (0x3426bc10 0x4370200 0x3426bcb8 0x529a4214)
    0x3426bc08 : 0x529a4214 (0xe 0x520048 0x10 0x10)
    0x3426bcb8 : 0x529a276b (0x529a6428 0x3cea000 0x6cefc8 0x3e753a)
    0x3426bce8 : 0x529a27ee (0x3cea000 0x6da720 0x3cea000 0x8eef1c)
    0x3426bd08 : 0x40aa1b (0x4647680 0x0 0x3cea000 0x3e8169)
    0x3426bd38 : 0x40b610 (0x3cea000 0x40aa480 0x0 0x3cea000)
    0x3426bd78 : 0x40f73a (0x3cea000 0x3bbfc40 0x0 0xffffffff)
    0x3426bdc8 : 0x40f8ed (0x3de9700 0x7 0x1 0x3e839c)
    0x3426bde8 : 0x61a606 (0x3de9700 0x3 0x1 0x3ddb200)
    0x3426be08 : 0xc23b02 (0x3de9700 0x3 0x0 0x3ddb900)
    0x3426be28 : 0xc23c89 (0x3ddb200 0x634064 0x1 0x8ca2e0)
    0x3426be68 : 0xc1fe04 (0x3ddb200 0x2e3e9000 0x3426beb8 0x1361b0)
    0x3426bea8 : 0xc218f1 (0x3ddaa00 0xc206e8 0x1 0x0)
    0x3426bed8 : 0x412c9c (0x3ddaa00 0x1 0x3ddaa00 0x3ddaa00)
    Backtrace continues...
    Kernel loadable modules in backtrace (with dependencies):
    com.baltaks.driver.DoubleCommand(1.6.5)@0x529a1000->0x529a6fff
    dependency: com.apple.iokit.IOHIDFamily(1.5)@0x6a3000
    com.apple.driver.AppleUSBHub(3.0.3)@0xc1e000->0xc28fff
    dependency: com.apple.iokit.IOUSBFamily(3.0.3)@0x60d000
    com.apple.iokit.IOUSBFamily(3.0.3)@0x60d000->0x634fff

    BSD process name corresponding to current thread: kernel_task

    Mac OS version:
    9B18

    Kernel version:
    Darwin Kernel Version 9.1.0: Wed Oct 31 17:46:22 PDT 2007; root:xnu-1228.0.2~1/RELEASE_I386
    System model name: MacBookPro2,2 (Mac-F42187C8)
  • v1q Level 1 Level 1 (0 points)
    just an idea: has anyone ever tried to log out before shutting down? did that produce any different results?
Previous 1 2 Next