1 2 Previous Next 17 Replies Latest reply: May 31, 2008 4:19 AM by xld00d
Ryan Hodges1 Level 1 Level 1 (0 points)
In 10.4 I was able to mount my /Users directory from a separate disk partition by inserting a line like the following in /etc/fstab:

LABEL=Users /Users hfs rw 1 2

This works under Leopard. The problem is that my bootup times increased dramatically. After examining the console log and system log I was seeing errors from automount that say something like:

Can't stat LABEL=Users: No such file or directory

fsck_hfs was also printing scaring messages regarding this partition. I don't have the exact errors on hand. Since this is a work machine and I needed to be up and running quickly, I just reverted back to a single partition setup.

Things would work fine but I think these messages are related to how long it was taking to boot the machine.

Cheers,
Ryan

Macbook Pro, Mac OS X (10.5)
  • 1. Re: Leopard and /etc/fstab
    jherbold Level 1 Level 1 (0 points)
    Ryan,

    I was searching the forums because I have a similar setup and wanted to see how it would fair under and upgrade from 10.4 to 10.5. I have not have the boot-up delay problems you report. This is probably because I explicity refer to the disks in the fstab. I recall reading other reports of OS X not seeing the volume labels at boot time.
    Here's what my fstab looks like:

    #device mount point filesystem options freq passno
    /dev/disk1s3 / hfs rw 1 1
    /dev/disk0s3 /Users hfs rw 1 2

    Hope this helps,

    -Jake
  • 2. Re: Leopard and /etc/fstab
    jherbold Level 1 Level 1 (0 points)
    Ryan,

    I made the mistake of not seeing that your post as a warning. I upgraded the G5 where /Users is mounted from another drive. With 10.5 I now have the same problem. The boot process stalls for a while, all the fans go full speed (it gets pretty loud). I believe I'm onto to source of the problem.
    I get system.log messages like:

    Nov 8 00:51:36 thresher com.apple.autofsd[57]: automount: Mount for LABEL=bigeye has no host name

    I can't use the paths to devices like /dev/disk0s3 like I recommended because these now change around with every boot.
    I guess it's good news that someone else has duplicated your problem. I also believe I'm on my way to a solution. It appears that leopard adds a daemon called autofsd and files auto_master, auto_home, autofs.conf in /etc. I'm somewhat familiar with this auto mounting scheme from doing some solaris administration. From what I can tell by doing "man auto_master" the documentation indicates that autofs is reading the fstab. The man page says it should only be processing things in fstab that network drives but that does not appear to be the case. I think the solution is to have leopard mount the drive automatically under /Volumes/LABEL and then use this autofs stuff to also mount it at /Users. I hope to try this tomorrow.

    -Jake
  • 3. Re: Leopard and /etc/fstab
    jherbold Level 1 Level 1 (0 points)
    So I think this new automount stuff in 10.5 is buggy. Anything that I put in /etc/fstab that does not refer to a network drive causes the long boot delay and corruption of that drive.
    My hopefully temporary solution is to use the automount features.

    I edited /etc/exports to have the line
    "/Volumes/<drive name> -alldirs <hostname>"

    where <drive name> is the label on the drive and <hostname> is your computer's host name

    I changed /etc/auto_master to look like this:
    #
    # Automounter master map
    #
    #+auto_master # Use directory service
    /net -hosts -nobrowse,nosuid
    /Users auto_home
    /Network/Servers -fstab
    /- -static

    Note the only changes from the default is I commented out the directory service line and changed the auto_home line from "/home auto_home -nobrowse" to "/Users auto_home".

    In /etc/auto_home I have a line
    "<user> <hostname>/Volumes/<disk name>/<user>"
    for every user on the system and this line for the Shared directory
    "Shared <hostname>:/Volumes/<disk name>/Shared

    Again <disk name> is the same disk label used in /etc/exports and <hostname> is your computer's name, <user> is the user name which is normally also the name of the user's home directory.

    This does mount my systems user directories from a disk that is not the boot disk. It has the disadvantage of using NFS to do it. I expecting some disk related performance hits but I haven't had time to try that out yet. Will report more in future.

    Also the other configuration that worked for me was to put symlinks in /Users to the location of each user's home directory. For example the shell command
    ln -s /Volumes/<disk name>/<user> /Users/<user>
  • 4. Re: Leopard and /etc/fstab
    jherbold Level 1 Level 1 (0 points)
    The copy of my /etc/auto_master that I just posted didn't come out correctly it should look like:

    #
    #Automounter master map
    #
    #+auto_master # Use directory service
    /net -hosts -nobrowse,nosuid
    /Users auto_home
    /Network/Servers -fstab
    /- -static
  • 5. Re: Leopard and /etc/fstab
    jherbold Level 1 Level 1 (0 points)
    Using automount setup I described causes many applications to preform unacceptably slow. iPhoto hangs when deleting the trash, iMovie is slow. Therefore I don't recommend this setup. I'm now using symlinks to put the directories on my second harddrive into the right place.

    While nothing fails, using symlinks is not a good long term solution. Some application's file open or save as dialogs open in /Volumes/bigeye instead of the user's home directory.

    Short story: Leopard forces you to put it all on one disk.
  • 6. Re: Leopard and /etc/fstab
    jherbold Level 1 Level 1 (0 points)
    Using symlinks to users home directories causes some software installs to fail. Still haven't found another solution.

    -Jake
  • 7. Re: Leopard and /etc/fstab
    KJK555 Level 4 Level 4 (2,895 points)
    etc/fstab is deprecated in Leopard

    Leopard and Tiger both normally use automounter framework

    Try AutoMountMaker instead.

    Developer
    Jean-Michel Marino
    http://jm.marino.free.fr
    mailto: codepark@free.fr
  • 8. Re: Leopard and /etc/fstab
    Goalie_ca Level 1 Level 1 (0 points)
    Maybe i'm wrong but i tried automountmaker. It was only for network mounting.

    I still have not yet found a solution to the problem. Using a symlink is not a good solution (using a hard link is not even possible).

    In the advanced option for user accounts there is the possibility of setting a different home directory. However... I wonder how much software this will break.
  • 9. Re: Leopard and /etc/fstab
    pixelglow Level 1 Level 1 (0 points)
    I used to have the same problem i.e. "UUID=xyz /Users" entries in fstab would cause all manner of mayhem during boot e.g. failing stat. In the end I had to use a "/dev/diskxxx /Users" entry which meant that 50% of my reboots end up with a blank /Users directory. Strangely enough the problem seemed to go away with 10.5.2 or the latest security updates -- I just reinstated the UUID line and rebooted, and everything works fine except for a single "automount: Mount for UUID=xyz has no host name" line in the Console on reboot.
  • 10. Re: Leopard and /etc/fstab
    William Lloyd Level 6 Level 6 (19,355 points)
    Leopard uses autofs to mount things.

    apropos autofs
  • 11. Re: Leopard and /etc/fstab
    Simeon Fitch Level 1 Level 1 (0 points)
    How is it you get autofs to mount a local partition without going through NFS? I've tried putting the following in auto_master without luck:

    /NewMountPoint :/dev/disk3s0 -fstype=hfs
  • 12. Re: Leopard and /etc/fstab
    linkx Level 1 Level 1 (0 points)
    I would like to know how to get a local partition mounted automatically in a manually defined mount point. You folks had any luck?
  • 13. Re: Leopard and /etc/fstab
    linkx Level 1 Level 1 (0 points)
    In Leopard, I was able to mount a separate partition at /Users using the new command line tool vifs to edit fstab, making sure to use the UUID to identify the drive.

    sudo vifs

    Then add your fstab entry:

    UUID=SOMEBIGOLDUUID /Desired/Mount/Point hfs+ rw 1 0

    And it worked. That was all I had to do.
  • 14. Re: Leopard and /etc/fstab
    Gerben Wierda Level 1 Level 1 (125 points)
    I have had the following in my fstab for /usr/local

    LABEL=CubeUSRLocal /usr/local hfs rw 0 0

    This works. I have the 0 0 because in the past having a real number there would crash the system when the disk was hfs. The volume is case sensitive journaled hfs+.

    I do get the messages "5/19/08 3:45:26 AM com.apple.autofsd[61] automount: Mount for LABEL=CubeUSRLocal has no host name" but no other ill effects it seems.

    G
1 2 Previous Next