Previous 1 2 Next 24 Replies Latest reply: Jul 5, 2008 2:55 PM by linkrocks
linkrocks Level 1 Level 1 (0 points)
I have gotten one of the new black and silver Intel iMacs, but a small issue popped up yesterday. The computer wouldn't go to sleep on its own. The screen would go black as if it was preparing to sleep, but the fans/disks were still running. If I click the sleep button on the login screen, it goes to sleep just fine and then wakes up normally.

I went onto the forums and looked around. I don't think it's because of anything external hardware because I have a wireless Airport base station, so the only things plugged in are the keyboard, mouse and power cord. I kept looking and found something that said to go into the preferences and go to Energy Saver/Options and uncheck the box that says "Wake for Ethernet network admin. access". Now it seems like I've found my answer, but I just want to be sure. Will unchecking that box fix the problem? Or maybe this is something that will go away on its own.

I just want to have an expert confirm this before I go messing around with my system.
  • Scorpie Level 1 Level 1 (130 points)
    "Wake for Ethernet network admin. access" sets up the machine so the Ethernet (the wired network) is listening for a special packet to allow the machine to wake up.

    Since you imply that you're only using the wireless network, I don't think that un-checking that checkbox will do anything for you. Does anyone know whether you can send a wake-on packet to the wireless MAC address?
  • linkrocks Level 1 Level 1 (0 points)
    If it is relevant, I installed a new piece of software recently. The game "Luxor 2". It isn't one of those big complicated games, as it's just 25 MB and is played right from the computer (no extra disk required). Could it have anything to do with this?
  • WyldB Level 1 Level 1 (140 points)
    funny... I can't make my iMac stop going to sleep.....
  • Steve Siers Level 1 Level 1 (10 points)
    I'm just noticing the same problem with mine. I have things plugged into the ports, but all are of. It sleeps when I tell it to, but not when I rely on it going to sleep automatically from the Energy Saver settings.

    I'm going to test this out on my Macbook Core2 Duo as well.
  • BLezcano Level 1 Level 1 (5 points)
    I'm in the same boat. My mac wont sleep on its own, but will when i tell it to. No hardware other than an external firewire drive plugged in, I'm printing through the network, and I'm using a bluetooth keyboard and mouse. Any insight?
  • George Peters Level 4 Level 4 (3,165 points)
    The system will not sleep if any processes are running. It must remain idle for the period of time denoted in your energy saver settings. For example if you are using time machine and have your system set to sleep after 1 hour and 30 minutes, when TM makes the hourly backup it would then reset your idle time back to 0 and your system would never sleep. With that said either something is running it the background or maybe there is a system bug I'm not aware of. You could also try resetting the SMC.

  • George Peters Level 4 Level 4 (3,165 points)
    I'm going to retract what I said about Time Machine in particular because I did a test on mine last night and my iMac still went to sleep after 1 hour and 30 minutes as scheduled. TM did the incremental backup after 1 hour but then did not do any backups after it went to sleep. Sorry for the misinformation.

  • Kirtap Level 1 Level 1 (0 points)
    I have the exact same problem. Killed every process that could keep it from sleeping, but no difference. Pulled the internet cable.. no difference. It sleeps just fine if I put it to sleep myself, though.

    What's wrong with these machines?

    Edit: Will try to reset the SMC. I'll let you know how it went.

    Message was edited by: Kirtap
  • Kirtap Level 1 Level 1 (0 points)
    Nope. Didn't work at all.
  • NickRich Level 1 Level 1 (25 points)
    There are quite a few people having the same trouble over on the OSX Leopard section. Some things seem to work for some people, but no definitive solution that I've seen.

    Seems like it's a Leopard bug. Anyone from Apple reading this and can confirm that it is and will be addressed?

  • Steve Siers Level 1 Level 1 (10 points)
    OK finally weighing back in here.

    I was going to reset the SMC, but instead I just did a pretty major software update, one of which was to 10.4.11. Repaired permissions first.

    I used to have my 24" iMac set to sleep at 15 minutes. To test the function after the updates, I set the panel to 3 minutes, turned off all externals. Voila! It slept in 3 minutes. Not just the screen, the whole iMac.

    Here's the log file that shows what I updated. Certainly could be lots of culprits in there. I seem to always hold of on updates, since they so often seem to have bugs of their own, but all of these are mature, maybe even revised, so I took the plunge. I hope this helps anyone with the same problem.

    2007-12-04 12:25:05 -0800: Installed "Backup" (3.1.2)
    2007-12-04 12:25:18 -0800: Installed "QuickTime" (7.3)
    2007-12-04 12:25:36 -0800: Installed "iTunes" (7.5)
    2007-12-04 12:25:46 -0800: Installed "iPhoto Update" (7.1.1)
    2007-12-04 12:25:50 -0800: Installed "iLife Support" (8.1.1)
    2007-12-04 12:25:52 -0800: Installed "iMac Software Update" (1.2.1)
    2007-12-04 12:27:21 -0800: Installed "Mac OS X Update (Intel)" (10.4.11)
  • Kirtap Level 1 Level 1 (0 points)
    Ok, I have made some progress. It still won't sleep on it's own after said time of inactivity, but it will sleep on it's own if I schedule it to sleep at a certain time.
  • NickRich Level 1 Level 1 (25 points)
    Yes, same with me. I've just noticed Steve is using 10.4 Tiger. I never had this problem until I upgraded to Leopard. Which are you using Kirtap?

  • h2oRover Level 1 Level 1 (0 points)
    I just got off the phone with Apple Support, and in my case (Leopard, 24" iMac) it will only sleep when done manually (power button, apple>>Sleep, or remote control).

    Both the 'sleep after __ minutes' and 'Schedule...' sleep functions within the Energy Saver settings would not put it to sleep.

    In my case, the culprit was *_McAfee Virus Scan v8.6_*, which was almost constantly accessing the hard drive. Apparently, any kind of disk activity will cause the sleep counter to start all over again from the beginning, so even when told to sleep after just one minute of inactivity, it was no match for the virus scan process every few seconds.

    The best thing to check is the system log file (Apple >> About This Mac >> More Info...) This will open the System Profiler, and in the box on the left (Contents) scroll down to 'Software' and click on 'Logs' Take a look at the System Log to see if there is any process kicking off more frequently than the settings of your sleep timer.
Previous 1 2 Next