Skip navigation
This discussion is archived

USB problems

9262 Views 17 Replies Latest reply: Apr 4, 2008 3:10 PM by ChrisAlexander1000 RSS
1 2 Previous Next
fredgoule Calculating status...
Currently Being Moderated
Nov 2, 2007 7:47 AM
Hi,

since i've installed Leopard my usb peripherals on my Mac Intel work hazardously, for example when i reboot i wait two minutes for keyboard and mouse to be used. Is someone have same problem ?

Fred
Mac Intel 24 pouces, Mac OS X (10.5)
  • stmidnite Calculating status...
    Currently Being Moderated
    Nov 5, 2007 3:13 AM (in response to fredgoule)
    I'm having USB bandwidth limitation issue with my TV tuners. Never have this issue with Tiger. I'm sure Leopard has some USB issues as I have folks reported that some USB devices don't work properly after the upgrade.
    Mac OS X (10.4.10)
  • soCram Calculating status...
    Currently Being Moderated
    Nov 5, 2007 3:27 AM (in response to fredgoule)
    I am using a Logitech MX 518. After closing and reopening the lid, it doesn't work anymore till i plug it into another usb-port.
    MacBook Pro, Mac OS X (10.5)
  • Resn8tor Level 1 Level 1 (115 points)
    Currently Being Moderated
    Nov 21, 2007 12:15 PM (in response to fredgoule)
    My USB peripherals seem to randomly stop working after installing Leopard, particularly the aluminum keyboard. Unplugging the usb and plugging it back in gets it working again.
    SR MBP 2.4 4GB, Boot Camp: Vista Ultimate, Fusion: XP Pro, Mac OS X (10.5), Samsung 226BW, Wired aluminum keyboard, FW800: G-Drive 250, MyBook Pro 500
  • Dale Weisshaar Level 6 Level 6 (15,855 points)
    Currently Being Moderated
    Nov 21, 2007 3:27 PM (in response to fredgoule)
    Try things in this USB faq. Do the Combo Update too.

    Cheers! DALE

    Mac Pro 3.0 GHz Dual Core, 5 GB, X1900, 30"ACD, HP C7180 Printer,, Mac OS X (10.4.10), and a G4 450 Dual (Gigabit Ethernet), 1.62 MB, 10.4.10+9.2, Cannon i475 Printer
  • soCram Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 26, 2007 3:05 AM (in response to fredgoule)
    I got no more USB-Problems since 10.5.1.
    MacBook Pro, Mac OS X (10.5)
  • ketanitem Calculating status...
    Currently Being Moderated
    Nov 28, 2007 6:40 AM (in response to soCram)
    I got my new macbook with Leopard preinstalled, and yes I have problem with USB on one of the port. The problem is only with external device like disk which doesn't have it's own power. I even suspected it was the problem of the logic board, that I have it replaced at the apple center, but the problem won't go away.

    Tried to install vista using bootcamp, and both USB ports recognized just fine by windows. So probem with Leopard?
    MacBook 2.2GHz, Mac OS X (10.5.1)
  • EvilWhitey Calculating status...
    Currently Being Moderated
    Nov 30, 2007 6:46 PM (in response to Resn8tor)
    I have several problems with USB issues since I've installed Leopard. With both 10.5 and 10.5.1 (maybe even worse in 10.5.1). On my main workstation a Mac Pro, after varying periods of time the box will kernel panic with various USB traces, or the mouse and keyboard and all USB devices just stop responding. It's rendering my workstation useless.

    I'm really hoping there is a patch for this soon.
    Mac Pro, Mac OS X (10.5.1)
  • Spencer Archer Calculating status...
    Currently Being Moderated
    Dec 4, 2007 2:22 PM (in response to EvilWhitey)
    Am having similar issues on my Mac, my EyeTV used to work perfectly under Leopard now it records when it feels like it, sometimes none of my USB devices except the keyboard works and Bluetooth has conked out a few times as well, overall am not that impressed with Leopard, but cant get my Tiger install on my external drive to boot up for some reason!. Apple had better fix it soon!
    Intel Mac Mini 1.83Ghz, 1GB Ram, 80GB HDD, Superdrive, Mac OS X (10.5.1), Dell P4
  • Mike-break Calculating status...
    Currently Being Moderated
    Dec 4, 2007 2:45 PM (in response to fredgoule)
    I've had problems with many USB devices after upgrading to Leopard. Particularly the ipod and my Blackberry Pearl. If the ipod is plugged in during startup, the computer will not boot. Once when I plugged the Pearl into a port in the back of the computer and the computer rebooted itself. Needless to say I avoid that port now and am wary of plugging in my ipod in any port.
    2 x 3 GHz Dual-Core Intel, Mac OS X (10.5.1)
  • Russa Level 4 Level 4 (1,315 points)
    Currently Being Moderated
    Dec 4, 2007 3:30 PM (in response to fredgoule)
    I am experiencing problems with the sleep mode on my MBP. Some on this forum say its related to the USB. Usually when I wake from sleep, if it does wake successfully, my bluetooth Mighty Mouse and keyboard behave erratically.
    MacBook Pro 15" 2.4GHz with 4Gbytes, Mac OS X (10.5.1), Cox cable, ZyXEL P-330W v1.7, PAP2 v2 for Vonage, G-Drive Q for TM
  • Black X Calculating status...
    Currently Being Moderated
    Dec 27, 2007 6:11 AM (in response to fredgoule)
    I had a problem with usb in my new black macbook..

    If I plug in my Toshiba HD in the left port it not showing me any HD icon on desktop and the usb stop working! and I can't use it any more with any device ( like usb mouse ..etc) tell I restart the system. the right port it's working fine without problem.

    But after that I test it with GNU/LINUX Fedora Core 8 Live CD and the 2 ports working perfectly without any problem! (with my HD too).

    So I think the problem it's about software not hardware!

    Sorry for my bad english language, because it 's not my mother language.

    Message was edited by: Black X

    Message was edited by: Black X

    Message was edited by: Black X
    MacBook 2.2GHz, Mac OS X (10.5.1)
  • Black X Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 27, 2007 7:44 AM (in response to Black X)
    Addendum:

    I was installed Windows Vista via Boot Camp before few minute, and testing the usb ports after installing the mac drivers from CD. actually it's was working perfectly without any problem!
    MacBook 2.2GHz, Mac OS X (10.5.1)
  • Tom English1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 27, 2007 1:53 PM (in response to fredgoule)
    I'd like to echo others' experiences.

    My previously-perfect MacBook C2D 2GHz (2GB) now has hilariously basic USB I/O issues, including:
    - poor data transfer rates from USB flash storage devices; both data rate and CPU load during Finder copies are fluctuating randomly
    - data rates are sometimes so bad it feels like USB1.1 on USB2 devices
    - very serious random disconnections of USB storage devices, often during copies
    - built-in USB bluetooth module occasionally appears to go missing; the OS says BlueTooth is 'not available'; does not see the module again until a reboot


    In Leopard (unlike Tiger), the console is a constant trickle of runtime errors (many serious, most unreported at GUI level) indicating that many parts of the OS are in a chaotic state and are in difficulty. USB is no exception; here is my console during a finder copy to a known-good 4GB USB flash key:

    Dec 27 17:43:05 odysseus kernel[0]: disk2s1: device/channel is not attached.
    Dec 27 17:43:05 odysseus kernel[0]:
    Dec 27 17:43:06: --- last message repeated 1 time ---
    Dec 27 17:43:06 odysseus kernel[0]: disk2s1: I/O error.
    Dec 27 17:43:06 odysseus kernel[0]:
    Dec 27 17:43:06: --- last message repeated 1 time ---
    Dec 27 17:43:06 odysseus kernel[0]: disk2s1: media is not present.
    Dec 27 17:43:06 odysseus kernel[0]:
    ...Dec 27 17:43:06 odysseus kernel[0]: msdosfsfat_uninitvol: error 6 from msdosfsfat_cacheflush
    Dec 27 17:43:13 odysseus kernel[0]: USBF: 28071.920 AppleUSBEHCI[0x3cd0800]::Found a transaction which hasn't moved in 5 seconds on bus 0xfd, timing out! (Addr: 3, EP: 0)
    Dec 27 17:43:19 odysseus kernel[0]: USBF: 28077.921 AppleUSBEHCI[0x3cd0800]::Found a transaction which hasn't moved in 5 seconds on bus 0xfd, timing out! (Addr: 3, EP: 0)
    Dec 27 17:43:19 odysseus kernel[0]: USBF: 28078.223 IOUSBCompositeDriver[0x51cca00](:n™^LÞ˜4PÍá˜f^Y{³<) GetFullConfigDescriptor(0) returned NULL

    The copy failed and the OS accused me of unplugging the device. This is remedial; it embarassed me in front of a Windows-using friend. Under Tiger, I would have been dumbfounded at this.

    Yesterday I noticed my BlueTooth module had taken the day off. Here's what appeared in the console:
    Dec 24 23:21:36 localhost kernel[0]: E:[AppleUSBBluetoothHCIController][StartInterruptPipeRead] there is alredy a pending read, skipping.
    Dec 24 23:21:36 localhost kernel[0]: [InterruptReadHandler] Received kIODeviceNotResponding error - retrying: 1.

    I had to reboot, and guess what? The Bluetooth module re-appeared. Again, remedial. Under Tiger, I rarely had to reboot the machine for any reason other than patching.

    These USB devices all worked beautifully under 10.4.x, as did BlueTooth. Only Leopard can be to blame. It's clear that (at the very least) kernel extensions for USB are very buggy. Why have even these parts of the OS disintegrated like this? Tiger was rock solid in comparison.

    General comment: I'm having so many issues with Leopard (too many to list here) that for the first time in 6 years of using Mac OS X (and over 20 years on the Mac platform) I have recommended anyone who asks me to stick with the previous release, perhaps for another two years. That's how much my confidence in this once-superlative operating system has been shaken.
    MacBook C2D 2GHz, Mac OS X (10.5.1)
  • nikey33 Level 1 Level 1 (130 points)
    Currently Being Moderated
    Dec 31, 2007 3:45 PM (in response to fredgoule)
    i totally agree to all this my digital camera is now not working on leopard nor is my psp or even a simple usb storage stick its doing my head in im so angry this has happened i sooo regret upgrading to leopard its worse, tiger was much better ive no idea what to do
    macbook, Mac OS X (10.5.1)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.