Previous 1 2 3 Next 41 Replies Latest reply: Dec 17, 2007 3:29 PM by Paul Richards Go to original post
  • MacBraveheart Level 1 (130 points)
    Could you give us the dummy's version on How To on that, please? I am going mad here. I just still cannot figure out WHY it is happening to me at all since I didn't update the weekend it started happening or even the week before. One day it is fine and I am gloating and the next- nix!

    Notably- it is less of an issue if the MacBook Pro is mains connected. Fails instantly and repeatedly once power is removed.

    Thanks in advance!
  • G. I. Level 1 (5 points)
    First navigate in Finder to /System/Library/Extensions and get info on IO80211Family.kext, if the version is 1.6 or smaller then you have some other problem. If it's 1.62 then you can try this downgrade method, but have a full system backup before you start messing around...

    1. Download and install Pacifist from
    2. Download *Mac OS X 10.4.10 Update v1.1 (Intel)* from (page 3) and open the dmg
    3. Open the install package with Pacifist
    4. Navigate in Pacifist to System>Library>Extensions in the package and drag IO80211Family.kext to the desktop, you have to enter your password
    5. Turn Airport off
    6. Navigate in Finder to /System/Library/Extensions
    7. Drop IO80211Family.kext from the desktop into this folder to replace the current version, you have to enter your password
    8. Run Disk Utility and Repair Disk Permissions (important), turn Airport on
    9. Restart your machine

    You should have a working 1.6 version extension now. In Software Update *Airport Extreme Update 2007-004* will be listed, that contains the "bad"(?) extension... In theory the droputs on battery should disappear, but I have a newer generation MBP (LED screen), so who knows... Good luck.
  • Unluckier Level 1 (0 points)
    Thanks for the instructions, G.I.

    I'll probably know next week whether the downgrade addresses my problem or not. Once again to those who are experiencing the wireless issue, please report here if you see the "athrxproc: NO RX Packets for 5 contiguous interrupts" messages in your system log. (Console)
  • ruralcow Level 1 (0 points)
    I've been having this problem for the last week or two, only with the power adapter not plugged in. It started with the airport disconnecting every hour so and progressively got worse until it was dropping out every 30 seconds today. It's been working fine for an hour now, this is what I've just done:

    Installed the Airport Extreme Update 2007-004 and OS X 10.4.11 (no change)
    Followed the airport downgrade instructions above by G.I. (no change)
    Used software update to download Airport Extreme Update 2007-004 again (no change)
    Followed the link posted by Pekka Siponen
    reinstalled the update, and it now seems to be working.
  • mkfeldman Level 1 (0 points)
    I bought my Intel macbook (airport = atheros) in October 2007 and has been bugged by this very frustrating problem since, until I fixed it or good today.
    I'm 100% sure it's not caused by the wireless router because:
    - I have another PC laptop using the same wireless router for more than a year, never a disconnection
    - I installed Linux Fedora (natively on the same macbook), never a disconnection
    I've been trawling the net for about a month looking for a solution, I tried disabling 802.11g on the wireless router, I tried fiddling with the re-authentication timers (I'm using WPA by the way), I tried changing from WPA to WPA2 (which made the connection last a bit longer) but none of these solutions worked
    I also upgraded to Leopard (I have chosen a complete fresh install with re-format) ... Still same problem.

    Since yesterday, for the first time, my connection remained up for more than 24 hours now (it never stayed up more than 2 hours before) I followed the instructions in this thread to install Airport Extreme Update 2007 0.0.4 ... if we can call that an install! more of a miracle!

    Thanks to the guy who came up with this hack.

    The release notes of Airport Extreme Update 2007 0.0.4 specifically said:

    This update is recommended for all Intel-based MacBook, MacBookPro, and Mac mini computers and improves the reliability of AirPort connections. looks like the fix was not ported to 10.4.10 and subsequent code (leopard)
  • Pekka Siponen Level 1 (0 points)
    The strange thing is that I had it already installed.. Why did the reinstalling fix the problem I wonder... :P
  • ruralcow Level 1 (0 points)
    My connection went back to the usual problem shortly after my last post. I've now gone back to my old Belkin wireless router, turned off WEP and am using mac address filtering - the setup I had before the problems began, seems ok so far...
  • Unluckier Level 1 (0 points)
    Ok, I tried with a downgraded Airport driver per G.I.'s instructions.
    I noticed similar network drop-outs but without the "NO RX Packets" errors in the system log. The airport icon showed full signal strength, but I couldn't communicate on the network. I tried the click-on-on-airport-icon trick to get things working again and I was greeted with a kernel panic. The details for the crash:

    panic(cpu 0 caller 0x001A49CB): Unresolved kernel trap (CPU 0, Type 14=page fault), registers:
    CR0: 0x8001003b, CR2: 0xa0483389, CR3: 0x018ba000, CR4: 0x000026e0
    EAX: 0x00000006, EBX: 0x24662107, ECX: 0xa0483389, EDX: 0x24307ad4
    CR2: 0xa0483389, EBP: 0x25fb3bf8, ESI: 0xa048338f, EDI: 0x243072c8
    EFL: 0x00010206, EIP: 0x00199254, CS: 0x00000008, DS: 0x81980010

    Backtrace, Format - Frame : Return Address (4 potential args on stack)
    0x25fb39f8 : 0x128d0d (0x3cc65c 0x25fb3a1c 0x131f95 0x0)
    0x25fb3a38 : 0x1a49cb (0x3d2a94 0x0 0xe 0x3d22b8)
    0x25fb3b48 : 0x19b3a4 (0x25fb3b60 0x25fb3b68 0x5adf5844 0x6)
    0x25fb3bf8 : 0x49c14e1e (0xa0483389 0x24662107 0x6 0x5ce39ec0)
    0x25fb3dd8 : 0x49c17059 (0x243072c8 0x4426204 0x25fb3f08 0x0)
    0x25fb3f08 : 0x39b96f (0x24307000 0x489a980 0x1 0x2)
    0x25fb3f58 : 0x39ab41 (0x489a980 0x0 0x0 0x19e23a)
    0x25fb3f88 : 0x39a877 (0x4d063c0 0x0 0x450 0x1f03)
    0x25fb3fc8 : 0x19b21c (0x4d063c0 0x0 0x19b22b 0x55a52dc) Backtrace terminated-invalid frame pointer 0x0
    Kernel loadable modules in backtrace (with dependencies):

    Kernel version:
    Darwin Kernel Version 8.11.1: Wed Oct 10 18:23:28 PDT 2007; root:xnu-792.25.20~1/RELEASE_I386

    So now I'm back to the updated driver. Neither solution is acceptable, but I can much easier deal with intermittent connectivity than kernel panics.
  • MacBraveheart Level 1 (130 points)
    OK- same deal as I had and I went independent of this thread because it was beginning to do my head in. I feared I had a £1,700 silver tablemat!

    I resolved my Darwin Kernel by archiving and reinstalling OSX (4.6 BTW) and then, repairing permissions and updating (whole Shebang- right up to 10.4.11!!!!!) and it has been GREAT ever since.

    I realised that I would be better to spend the evening and most the night reinstalling the system and updating it than fiddling on with PRAM resets (I even had a lazy DVD in drive during the kernel error and so could not just get on with it without some serious perspiration going down!).

    So far, so good- no drop outs and ever such a faster machine!

    As they say- SOMETIMES it is better to start from scratch than to fiddle on repairing something one only has an inkling of!
  • K I M B A K A T Level 1 (0 points)
    10.4.11 fixed this for me. My Macbook intel core duo 2 Airport wireless network was dropping randomly. Some days were bad..every 5-10 min. I had to put my computer to sleep for a about 10-15 seconds..when it woke...I had internet access restored.

    BUT...when I updated to 10.4.11 I get the grayscreen freeze about twice a day now. So far I think I'm the only one having this issue. I've been searching around..but most likely 10.4.11 may fix it.

    AND someone else in another forum was recommending you zap your PRAM after 10.4.11..a simple technique I have forgotten about. I even forgot how to do it. You will have to look it up.
  • ktorster Level 1 (0 points)
    Seems to be fixed in the latest (last?) Tiger upgrade.
  • Paul Richards Level 1 (0 points)
    I found a workaround that works on my laptop. Maybe it'll work for others.

    I think the connection only drops because it is idle for a few moments, then some power saving thing kicks in and goes wrong.. If I cause the wireless connection to have constant traffic, then the connection never drops.

    Anyway, I have found that I can leave a terminal window open running "ping" to a host on the network, and my connection will never drop. Simply leave that running somewhere in the background.
Previous 1 2 3 Next