Skip navigation
This discussion is archived

Custom access, permission problems

8657 Views 13 Replies Latest reply: Dec 17, 2007 3:48 AM by R C-R RSS
ruebezahl Calculating status...
Currently Being Moderated
Nov 2, 2007 3:06 PM
I have serious permission problems here

my home folder says " You have custom access"

some files can't be edited, some can
and so on

i tried a chown -R user:staff ~

some files show the everyone twice (in the get info dialog)
once with readonly, once with custom

is anybody able to help me?
MBP 15" C2D, Mac OS X (10.5)
  • birdiebee Calculating status...
    Currently Being Moderated
    Nov 2, 2007 7:34 PM (in response to ruebezahl)
    Hi I'm having all sorts of nightmares with Leopard (vista), as is everybody.

    I have a serious permissions problem that results in not being able to save the music I've just made in Logic 8 because "The Document "My Song Title" could not be saved. you do not have appropriate access privileges to view or change access privileges, select the item in finder and choose > Get info. well tried that and it don't work !
    2nd big problem I can't listen to a song in itunes for longer than 5-20 seconds without it stopping, then I have to hit play for it to resume for another 5-20 seconds.
    3rd I can't id3 tag songs in itunes anymore. That's my Powermac G5, my imac g5 is a mess haven't been able to open mail since the upgrade and safari dies on opening.
    Oh yeah wasted 48 hours on the blue screen application enhancer caused problems.
    What a mess Apple really messy man in a much worse than microsoft way ! you had a week of nice paid for reviews of this bit-ch of an operating system but from next week you'll see a different kind of press because we aint beta testers.
    If anyone knows how I can fix my problems thanks in advance.
    I'm so angry I can hardly type I've had 7 days of **** because I love apple and bought Leopard on the day it came out.
    Lastly I feel apple just ditched up Powerpc users out in the cold man, I mean two years ago I parted with £3000 on a Powermac g5 and an Imac g5 and it seems like everything is going okay in the intel world.
    Powermac G5 Quad, Mac OS X (10.4.8)
  • Cyrus Shafai Calculating status...
    Currently Being Moderated
    Nov 9, 2007 3:13 PM (in response to ruebezahl)
    I have fixed the Leopard permissions problem for my iMac !! It is caused by the ACL permissions issue that a few people have mentioned, and it is an easy fix. It is not a solution, as the problem is caused by Leopard, but it appears easy to fix when it happens.


    1. What creates the problem?
    You can see it in action by creating a new user account (admin access), and create some dummy files in it. Try to change the names of these files, and no problem you can do so easily. Now go to up one directory level to your user folder, open a Get Info window on the new account you just made. You will see several users in the permission section, most likely "user", "staff", and "everyone".

    Now use Get Info to apply a permission change to this new user account. For example, change the permission for "everyone" to Read Only. Then select "apply to enclosed items". Now go back to your home directory and try to change the file name of items in that account, and you will find you can't. Do a Get info on one of the files and in the permission section it says "You have custom access", instead of "You have read and write access".

    You can also easily create the problem from the Terminal window, instead of the Get Info window. For example, go to your users folder using the Terminal application, and type the following in the terminal window.

    chmod -R =rw,+X username

    This will force Leopard to set the read and write permissions to the usual default to your user folder and to all files/folders recursively (this is what the -R is for) in your user folder (the +X will retain any execute permissions that are currently set). After doing this you will again create the problem.


    2. What causes the problem?
    Run the Terminal application (you should be in your home directory) and type:

    ls -le

    This will list all your files and folders in your home directory, along with the ACL extensions to the file permissions. On my machine I get under each "permission affected" files or folders the following additional information.

    0: group:everyone deny delete

    So this "everyone" person is not allowed to delete any files (or rename them). And this "everyone" person is a "group" that includes EVERYONE including the user as well. Thus, since "everyone" can't change files, neither can the user. This part is confusing at first to realize what is going on since in Unix terminology normally "everyone" only refers to the outside world, and not the user himself. I believe Apple tried to use the ACL extension to prevent certain files/folder that Leopard would not want the user to rename/delete (i.e. Pictures directory), but for some reason Leopard is applying this to all files, folder, and contents of folders.


    3. The solution the solution is simple. Remove this ACL condition for all files or folders in your home directory.

    3a. You typically can easily do this from the user folder level in Terminal, since the affected account also has the same ACL condition applied to it. Type ls -le to see if this condition is present for the affected user folder account itself. If it is, then all you have to do is type is:

    chmod -R -a# 0 username

    This will remove the ACL condition (numbered 0) from the user account folder, and all files or folders in it (the -R condition causes this recursive fix of all contents of all folders).

    3b. You may not be able to do this from the user folder level in Terminal if the user folder itself does not have this ACL condition. In this case, simply go to your home directory in Terminal, and fix to each file or folder within your home directory individually, and do this recursively to all contents of folders so you don't have to do it for the contents of the folders in your home directory. Type ls -le, and find which files/folders are affected, and for each affected file/folder type the following to remove their ACL condition:

    chmod -R -a# 0 fileor_foldername

    After doing this, if you type " ls -le " in Terminal window you will see that the ACL condition is gone from every fixed file or folder. Also, if you do a Get Info in Finder on any fixed file/folder you will see in the permission section the phrase "You can read and write".


    Should the permission problem be fixed this way by canceling the ACL conditions, I am not sure. But it is now fixed on my machine (not solved, but fixed) and I again have full access to all my files.
    iMac, Mac OS X (10.5)
  • cSticks Calculating status...
    Currently Being Moderated
    Nov 9, 2007 4:01 PM (in response to Cyrus Shafai)
    The above trick may work, but if you're not comfortable with the Terminal, I would probably recommend just trying to hang on a bit longer if you can (if you accidentally chmod the wrong folders, you may end up with a system that won't startup) - I'm not at all saying that the detailed instructions won't work (many thanks for that Cyrus), I just wanted to make sure everyone understands at least a bit about it before accidentally choosing the incorrect path, etc.

    I would assume that the next update coming from Apple would address this problem, as it seems to be very widespread. After you see the next update from them, and if it doesn't fix your problems, then maybe you could do it by hand (unless you're already familiar with the shell).

    I personally ran into the "unknown user" when I did a clean install for Leopard. But I backed up my old system on another drive so that I could get back some of my random Application Support files, preferences, etc (while doing a clean install). It seems that all of the files from my backup that are copied over retain this "unknown user" instead of updating to (I think?) what should be either Admin or my user depending on the file location.

    Repairing permissions in Leopard fixed most, but not all of the items copied back into my main Library (though it did leave a few). Other items outside the Library and in my Home folder weren't changed; from what I understand the "Repair Permissions" doesn't fix items in your Home/Library - not sure if it ever did, or if this is Leopard only.

    Anyways, that's my take on it
    Thanks again Cyrus for the detailed instructions.
    Mac Pro quad 3GHz, Mac OS X (10.5), 4GB RAM, Radeon X1900 XT, lots of drives
  • colina2007 Calculating status...
    Currently Being Moderated
    Nov 17, 2007 4:29 AM (in response to ruebezahl)
    Hi to all,
    I have tried the 2 solutions to the permissions problem but they did not work. Perhaps I make a mistake When I apply the lines in the terminal I get as response: chmod: No ACL present

    Question: When I paste this: chmod -R -a# 0 username do I need to change username to something else or is the username referring to: 0 ?
    If I am doing it right then I am at a loss on how to do it. Are the ACL's needed or can they be turned of somehow?
    When I log in to another (test) user all works fine.
    Also some programs work, for example Dreamweaver works like a charm, but Textedit, MS Word, PS3, etc.. do not work.
    In the get info both say the same:
    You have custom access
    Me - read & write
    admin -read & write
    everyone - read only

    I would appreciate some extra help a lot

    Thanks
    By the way I am not very good with Terminal (copy and past) so I downloaded Tinkertool system, in case this helps.
    R.
    imac24, Mac OS X (10.5.1)
  • colina2007 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 19, 2007 7:37 AM (in response to Cyrus Shafai)
    Dear Cyrus,
    Your explanation on the permission problem sounds very logical. but it did not work for me 100%. I followed your instructions and got rid of the "0: group:everyone deny delete". But most of my folders still have this "You have custom access".
    Since you are fluid in Unix lingo I would like to ask your help. Here is what I see in my Terminal window:
    Last login: Mon Nov 19 15:57:56 on ttys000
    You have mail.
    Imac:~ wybirn$ ls -le
    total 16
    drwx------@ 61 wybirn wybirn 2074 Nov 19 15:11 Desktop
    drwx------@ 26 wybirn wybirn 884 Jul 7 13:13 Documents
    drwx------ 5 wybirn wybirn 170 Nov 16 21:37 Downloads
    drwxr-xr-x 14 wybirn wybirn 476 Sep 14 14:56 Fonts
    -rwxrwxrwx@ 1 wybirn wybirn 0 Jul 8 2000 Icon?
    drwxr-xr-x 110 wybirn wybirn 3740 Nov 7 09:54 Incomplete
    drwxr-xr-x@ 17 wybirn wybirn 578 Sep 29 12:56 InternetData
    -rw-r--r--@ 1 wybirn wybirn 0 Aug 23 2004 LXE
    drwx------@ 64 wybirn wybirn 2176 Nov 16 19:54 Library
    drwx------@ 11 wybirn wybirn 374 Nov 16 13:59 Movies
    drwx------@ 9 wybirn wybirn 306 Nov 26 2006 Music
    drwx------@ 9 wybirn wybirn 306 Nov 2 16:39 Pictures
    drwxr-xr-x@ 40 wybirn wybirn 1360 Nov 5 16:15 Privat & Documents
    drwxr-xr-x@ 5 wybirn wybirn 170 Jan 18 2004 Public
    drwxr-xr-x 5 wybirn wybirn 170 Nov 16 14:44 Shared
    drwxr-xr-x@ 6 wybirn wybirn 204 Nov 1 14:32 Sites
    drwxr-xr-x@ 69 wybirn wybirn 2346 Nov 19 16:28 Villascouts
    drwxr-xr-x@ 426 wybirn wybirn 14484 Nov 1 09:17 icons
    drwxr-xr-x 8 wybirn wybirn 272 Feb 25 2007 old mails
    Imac:~ wybirn$

    How can I get my files and everything else back to "You have read and write access"

    Your help would be greatly appreciated. Again I am sorry that my Unix is not great.

    Thank you in advance
    Roland
    imac24, Mac OS X (10.5.1)
  • Theophan Calculating status...
    Currently Being Moderated
    Nov 28, 2007 8:18 AM (in response to colina2007)
    I'm brand-new to the Mac, just switched from PC, and as a newbie I am VERY nervous about doing things in Terminal that I don't understand and possibly badly screwing up my nice new Mac.

    But I, too, am having frustrating problems with permissions. I try to move some files from one folder to another and am told I don't have adequate permission, and find "custom access" on the relevant files when I "get info." Applying the containing folder's "read and write" permissions to all contained within it doesn't change this "custom access."

    Is there no way to fix this that doesn't go through Terminal? Am I correctly understanding that this is a bug in Leopard, and if so, would anyone have a guess as to when Apple might be likely to fix it?

    Many thanks!
    MBP 2.4 GHz, Mac OS X (10.5)
  • biovizier Level 5 Level 5 (7,925 points)
    Currently Being Moderated
    Nov 28, 2007 9:05 AM (in response to Theophan)
    In my opinion, what you are experiencing is not due to a bug, but rather extremely poor design, i.e. it is working as intended, but the suitability of the intention was not thoroughly examined. It is likely that the problems are being caused by a user privilege rule that is invisible to the GUI.

    Once you have used the "Apply to enclosed items" option, as far as I know, there is no Apple supplied way to undo the action without using the command line. There may be third-party utilities, though I don't know of any off hand.

    It is impossible to say, but unfortunately, my impression is that while bugs may be fixed, bad design is rarely addressed, at least until the next major revision (i.e. 10.4.6).
  • Richard Bottiglieri Calculating status...
    Currently Being Moderated
    Dec 4, 2007 3:56 PM (in response to colina2007)
    Colina,

    I had the same problem. Using the following command does work:

    sudo chmod -R -a# 0 DIRECTORY

    Message was edited by: Richard Bottiglieri
    PowerBook G4, Mac OS X (10.5.1), 2 GB RAM
  • Richard Bottiglieri Level 2 Level 2 (165 points)
    Sorry, I didn't finish the first post. Unfortunately, the "-R" flag doesn't seem to fully go into each of the subdirectories and make the changes. So, I piped the results into a file on my desktop as follows:

    ls -le > ~/Desktop/le.txt

    If you open the le.txt file in TextEdit, you can easily see and search for the files/directories that have the problematic ACL associated with it. Unfortunately, you'll need to go into each of the directories and run the command, in most cases. In other cases, you'll need to apply the command to the file (without the -R flag, obviously).

    This issue created all sorts of problems for me, with some programs not being able to save their own preferences to name just one. Applying the ACL fix resolved the issue.

    However, if I can suggest one thing and one thing only, it would be this: as a best practice, DO NOT use the Finder to apply ACLs to subdirectories in your HOME folder! That said, once I removed the custom ACL from each folder, it seemed OK to apply those permissions to the subdirectories.

    Has anyone reported this to Apple as a bug? I was planning to, but if someone in this thread already has, I won't bother.

    Message was edited by: Richard Bottiglieri
    PowerBook G4, Mac OS X (10.5.1), 2 GB RAM
  • Jake The Cake Calculating status...
    Currently Being Moderated
    Dec 15, 2007 3:59 AM (in response to Theophan)
    Exactly same problem here. I have now 400+ GB of data to fix manually with terminal.

    I really loved my Mac until this... Now I just feel SOOO bad when those "it just works" ads are rolling

    Are there any 3rd party utilities that could be used to more easily fix this???? Traversing directory tree folder by folder to see where this problem exists is just pain.
    iMac 24", Mac OS X (10.5.1)
  • Richard Bottiglieri Level 2 Level 2 (165 points)
    Currently Being Moderated
    Dec 16, 2007 6:04 PM (in response to Jake The Cake)
    Actually, you do not need to do this for all of your files in the Terminal. I've found that removing the offending ACL from each top level folder in your home directory (or wherever your files are stored) is enough, followed by using the Get Info box in the Finder to apply the permissions to each subdirectory afterward.

    Assuming you're in your home directory at a Terminal prompt (cd ~), the command is as follows:

    sudo chmod -R -a# 0 FOLDERNAME

    Do this for each directory in your home folder. Then, once your finished, exit the Terminal, and do a "Get Info" on the first directory in your home folder. Apply the permissions to all subdirectories; you will need to authenticate for each directory, however.

    Once this is done, the bad ACL should be removed from all files in your home directory. To check this, use the following command in the Terminal when you're in your home directory:

    ls -Rle > ~/Desktop/le.txt

    This will pipe the results to the "le.txt" file on your desktop; open the file in TextEdit, and search for "deny". If you don't see it (other than in a file name that may contain that word), your home directory is clean.

    Message was edited by: Richard Bottiglieri

    Message was edited by: Richard Bottiglieri
    PowerBook G4, Mac OS X (10.5.1), 2 GB RAM
  • R C-R Level 6 Level 6 (13,780 points)
    Currently Being Moderated
    Dec 17, 2007 3:48 AM (in response to Richard Bottiglieri)
    Richard Bottiglieri wrote:
    I've found that removing the offending ACL from each top level folder in your home directory (or wherever your files are stored) is enough, followed by using the Get Info box in the Finder to apply the permissions to each subdirectory afterward.


    Exercise caution when doing any of these recursive changes via the Finder's 'apply to subfolders' option or the Terminal equivalent. Apple clearly intends for the special home folders (Documents, Pictures, Downloads, etc.) to exist for every normal user account; the ACL entry prohibiting their deletion is a safeguard against their accidental or intentional deletion, which may cause problems with applications or upgrades that assume they do exist.

    It is probably better to go one level deeper into these folders & apply these recursive changes individually to their subfolders only as required to solve specific access problems. In fact, since you can create subfolders in these special folders & drop other folders & individual files into them, it might be best just to create a subfolder for this purpose.

    Moreover, I suspect some of the access problems are caused by users applying these recursive changes to upper level folders without understanding the implications of doing so.
    iMac G5/2.0 GHz 17" ALS (Rev B), Mac OS X (10.5.1), 1.5 GB, Kensington Trackball

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.