6 Replies Latest reply: Jan 30, 2008 10:07 AM by MIke100100
kaidomac Level 1 (55 points)
I have a 1.66ghz Core Duo Mac Mini. I installed Leopard and am using my Logitech VX Revolution wireless mouse and my Microsoft wireless keyboard. After a few minutes of using Leopard, the mouse stops responding to my clicks. It still moves around and I can still use the keyboard. To fix it, I have to unplug my KEYBOARD from the USB port and then plug it back in. The I'm good for another few minutes until it freezes again.

I have never had a problem with the Mac Mini, with the Keyboard, or with the Mouse. All worked fine under Tiger. I've tried different USB ports. I've ran Software Update for Leopard. I've installed drivers for the Keyboard etc. Nothing has fixed it. What's up with this! I found someone else was having this problem with their Wireless Mighty Mouse:


How in the world does the keyboard even affect the mouse at all? Any ideas? I have nothing else installed on the system; fresh install, latest updates. Happens with and without the drivers.

Message was edited by: kaidomac

Intel Mac Mini, Mac OS X (10.5)