1 2 3 Previous Next 81 Replies Latest reply: Jan 5, 2008 3:13 PM by Steisler
Paul Laskin Level 1 Level 1 (25 points)
After upgrading to Leopard, the "*Macintosh HD*" icon does not show up on the Desktop or in the Finder. Not even in the Finder under my Machine's name.

The drive exists - since I'm typing this from a workable install of Leopard. But it doesn't show up in the Finder.

Using GetFileInfo (from the Developer Tools folder) I can see that the Visibility flag is set. If I turn that flag off, the drive reappears until I bring up a Finder window and select the drive. Then it is gone and something has reset the "V" extended attribute flag.

Anyone else experiencing this fun?

MacBook Pro C2D, Mac OS X (10.5)
  • 2. Re: Macintosh HD icon is not on my Desktop or visible from the Finder
    Michael Conniff Level 7 Level 7 (33,120 points)
    Paul

    From your description it seems unlikely that Francine's notes can help, since you've already done that. This is all a bit weird (OK, fun )

    I think we'll need to resort to Terminal to find out exactly what is happening. Make sure you are logged in as an 'admin' user, and copy and paste the following into the Terminal window followed by a return:
    sudo iosnoop /

    You may not get any output immediately, but if it starts generating a lot, the only way to terminate this program is with Control-C.

    Now, in another Terminal window, clear the (In)visibility flag again, and see what sort of output you get from iosnoop (but don't stop it yet—if necessary make your Terminal window longer—I have mine at 48 lines with no problem). Then try to recreate your situation where the drive goes invisible and again, check the output from iosnoop.

    If something looks promising, use the PID to discover which process is doing this. Post back if you need more help with this.
  • 3. Re: Macintosh HD icon is not on my Desktop or visible from the Finder
    Paul Laskin Level 1 Level 1 (25 points)
    Michael - Thanks for the iosnoop command. I haven't used that one yet. I piped it to a tmp file so I could take a more casual look at the output.
    This is getting stranger. I've initially narrowed it down to either syncing with .Mac - (possibly sync of Preferences) or Spotlight being update (mdworker).

    I need to test this a bit more to figure out which one, but right now Spotlight appears to trigger the disappearing Macintosh HD. I've just done a
    sudo mdutil -i off /

    And the drive is sticking around. Syncing with .Mac (with and without Preferences sync'd) seems to work fine.

    Then I turn on Spotlight ... hmm, thought that was it. It is still there. .. Ah! after about a minute it disappears. Once it is gone, bringing it back with SetFile and then opening the drive makes it immediately disappear.

    I do a mdutil -i off /
    and the drive sticks around.

    Strange.
    I think I'll try deleting spotlight preferences to see if that helps. I wonder what it the pref file is named. com.apple.mdfind?
  • 4. Re: Macintosh HD icon is not on my Desktop or visible from the Finder
    ali brown Level 7 Level 7 (26,465 points)
    Hi Paul!

    Maybe the info in this older KB Article Mac OS X volume does not appear in Finder or on the desktop after restarting or logging out and back in, is somehow related, and still pertinent.

    ali b
  • 5. Re: Macintosh HD icon is not on my Desktop or visible from the Finder
    Michael Conniff Level 7 Level 7 (33,120 points)
    Ali

    He's tried that, since that is what Francine's article is about. It's quite recent, and I think reflects the current plague of invisibles which drove Francine to write her article.
  • 6. Re: Macintosh HD icon is not on my Desktop or visible from the Finder
    Paul Laskin Level 1 Level 1 (25 points)
    Ali,

    Thanks for the reference to that article. But, I had already tried that. In fact I think I have "sudo ./SetFile -i v /" a hundred times over the last few days.

    It has been about 16 hours since I turned off Spotlight "mdutil -ai off /", deleted all the .Spotlight-V100 files on all of my volumes (Internally I have 2 that are always mounted and externally 1 or 2 FW and 3 USB volumes that are mounted when I'm working). I also deleted ~/Library/Caches folder and threw out any preferences files that had been modified since the last time Macintosh HD disappeared.

    I rebooted into the Install DVD, repaired disk permissions and verified all drives. Everything checked out fine - no problems except a permission on an Apache file. Highly doubt that was an issue.

    Since turning off Spotlight and doing all the above, everthing is working fine. The Finder is working as it should albeit without Spotlight.

    My next step is to turn Spotlight on, but not allow it to index any files. .. I

    Hmm, I just checked the status of Spotlight with "mdutil -avs" and it does show that Spotlight is on for my Time Machine backup file. I forgot, Time Machine treats that file as a volume. That means Spotlight has been working for at least the last 12 hours.

    Well, I'll add another volume to the mix. Here goes nothing.
  • 7. Re: Macintosh HD icon is not on my Desktop or visible from the Finder
    Michael Conniff Level 7 Level 7 (33,120 points)
    Paul

    Try turning Spotlight off for your Time Machine volume. There's not much point in it anyway.

    Keep us informed!
  • 8. Re: Macintosh HD icon is not on my Desktop or visible from the Finder
    Paul Laskin Level 1 Level 1 (25 points)
    O.K. - here is the update. No fix yet but it is Spotlight that sets the 'V' attribute.
    As soon as I removed 'Macintosh HD' from the Privacy list and then turned Spotlight on for that volume, the 'V' bit was flipped.

    I could reset it, but as long as mds was doing something (as measured by cpu usage) the bit would toggle back. Simply adding the drive to the Privacy list didn't seem to stop the bit twiddling. Only turning off indexing on that drive helped.

    I could also trigger this by forcing spotlight by mdimport -V /Volumes/Macintosh\ HD

    I have filed a bug with Apple on this since I'm not quite sure where to go from here. iosnoop helped me determine it was Spotlight, but I can't tell what Spotlight is doing that would make it act this way on only this volume.

    Message was edited by: Paul Laskin

    Message was edited by: Paul Laskin because he made a typo
  • 9. Re: Macintosh HD icon is not on my Desktop or visible from the Finder
    Michael Conniff Level 7 Level 7 (33,120 points)
    Paul Laskin wrote:
    O.K. - here is the update. No fix yet but it is Spotlight that sets the 'V' attribute.

    Good! Knowing the cause, or part of it, goes a long way to finding a fix
    I have filed a bug with Apple on this since I'm not quite sure where to go from here. iosnoop helped me determine it was Spotlight, but I can't tell what Spotlight is doing that would make it act this way on only this volume.

    No, I guess this is definitely one for the developers. But hopefully your detective work will lead to a fix for all sooner rather than later!
  • 10. Re: Macintosh HD icon is not on my Desktop or visible from the Finder
    Francine Schwieder Level 6 Level 6 (19,040 points)
    Wonderful detective work Paul! And I'm delighted that you filed a bug report. Let us hope that this contributes to a solution on the programmers' part for this vexing problem. I believe you are the first person to find a reproducible instance of the bug, all the other cases seem to have been sporatic, so let's hope your sleuthing leads to a cure.
    Francine


    Francine
    Schwieder
  • 11. Re: Macintosh HD icon is not on my Desktop or visible from the Finder
    Paul Laskin Level 1 Level 1 (25 points)
    Thanks for the kudos. This has actually been fun.

    One more thing I've noticed. Every now and then the 'D' attribute is set at the same time as 'V'. I put that bit of info in the bug report, but others might be seeing the same thing. It too appears to be Spotlight related but I haven't figured out how to make it reproducible.
  • 12. Re: Macintosh HD icon is not on my Desktop or visible from the Finder
    Francine Schwieder Level 6 Level 6 (19,040 points)
    Wow, the D attribute is truly bizarre. I haven't seen that one. In the "old" version of the bug the visible attribute was sporatically reset on drive (both internal and external) and folders (including both the Applications folder and the user's home folder), and very rarely on other folders and even files. There has also been a rash of the B (bundle bit) being reset, which I suspect is related. I think, but couldn't swear, that I had some file which got the C (custom icon) bit set.

    In doing research for the article I wrote the first instance I found of the visible bit being reset was one problem with it in 10.3.9, but it didn't show up again until Tiger, whereupon it began to be increasingly common (after the third or fourth instance of helping someone with it I decided to write it up).

    The D attribute? Now that's strange.
    Francine


    Francine
    Schwieder
  • 13. Re: Macintosh HD icon is not on my Desktop or visible from the Finder
    LukeEdwards Level 1 Level 1 (0 points)
    Hi Paul,

    I've got exactly the same problem on my MacBook running 10.5. It started happening when I upgraded or shortly afterwards. My primary HD disappeared from my desktop and from the finder. Based on your posts I've now disabled Spotlight indexing and changed the attributes on my HD back. I like spotlight so I would really like to get a permanent fix for this bug so I can re-enable spotlight - did you hear back from apple? what is the bug ID?

    Thanks for finding the problem - it was driving me nuts!

    Luke
  • 14. Re: Macintosh HD icon is not on my Desktop or visible from the Finder
    Paul Laskin Level 1 Level 1 (25 points)
    Luke,

    I too miss my Spotlight! It is so much quicker under 10.5 that it is actually useful.

    Apple has not gotten back to me on this bug for some reason. They have on a few other "opportunities" I logged but not this one. I'm hoping that the first patch for 10.5 will magically fix the problem. We'll just have to wait and see I suppose.

    -PL
1 2 3 Previous Next