Previous 1 2 3 Next 39 Replies Latest reply: Dec 7, 2007 11:43 PM by MacCetera
Martyn Allez Level 1 Level 1 (0 points)
Well, it was a pig to set up under Tiger but under Leopard it is not recognised at all- slight lie that I can see that it is attached to a USB port but Leopard firmly refuses to make it work.

Another step in the dark?

iMac 2.4Ghz 24" (now junked), Mac OS X (10.5)
  • WWJD Level 6 Level 6 (15,825 points)
    Do a search for "Canon" and "Scanner" to see what others are experiencing.

  • Washac Level 3 Level 3 (835 points)
    Hi Ya

    Reinstall the Canon Lide 60 software.

    Mine still works from within the Photostudio software......

    Message was edited by: Washac
  • granismith Level 1 Level 1 (0 points)
    Not a scanner, but my Canon printer had the wrong id listed and nothing under the correct id for the printer. After Leopard, the printer worked but plain black and white text printed extremely slowly. Just installed the Canon software again from disk and the printer was recognized. Printed normal speed so maybe this solved it. Try reinstalling the drivers.
  • Martyn Allez Level 1 Level 1 (0 points)
    Seems to be a known problem with Leopard and some people had it with Tiger. Basically Canon's driver stops at 10.3 because 10.4 and later are supposed to have the driver support embedded.

    I'm not spending any more time trying to sort out Apple's lack of quality control so the scanner has been reunited with a PC.....
  • Douggo Level 4 Level 4 (2,740 points)
    So you're going to blame Apple for not providing drivers for a third-party piece of hardware.. when this clearly sounds more like a case of Canon dumping their support for the product - at least on the Mac side. Dare I assume that Canon published an updated driver for Vista? By golly, they DID!! Geez, by your logic, Microsoft should have provided one for it...

  • Martyn Allez Level 1 Level 1 (0 points)
    Er no, both Canon and Apple say that Tiger and beyond have full support for this scanner, guess they should sort it out before they dump the problem on the public
  • Washac Level 3 Level 3 (835 points)
    Hi Ya

    Do not get this, I already posted about this and it should work

    Message was edited by: Washac
  • MrMikeMGM Level 1 Level 1 (0 points)

    What's not to get? Yes, you already posted that it should work, yet for many of us it doesn't, hence, why we're still posting. It's tough to follow, I know. Let me summarize for those that "don't get this".

    Canon LIDE XX (<--- Insert Model # Here. This would be 60 in my case) attached to Mac. Nonfunctional since the upgrade. Re-installed the driver more times than I can count with mandatory reboot after mandatory reboot. Still nonfunctional.
  • Martyn Allez Level 1 Level 1 (0 points)
    yep, me too. But that will be Canon's fault, or Microsoft's.... couldn't be the sainted Apple could it?

    So Apple say it is embedded under Leopard, doesn't work and it's anyone's fault except them. Microsoft say it needs a new driver under Vista, Canon produce one and it works and that's wrong?
  • More2Learn Level 1 Level 1 (0 points)
    Ditto to the scanner not being recognized... Anyone with anything new to contribute? Does anyone know of a scanner that is recognized?
  • J. Bill Level 1 Level 1 (0 points)
    I can run my LiDE 80 from Canon's "Toolbox" application but Image Capture doesn't see the device. I asked Canon support about it. Alas, no help...

    Canon Support - Scanner writes:

    ``Thank you for your inquiry. We value you as a Canon customer and
    appreciate the opportunity to assist you. We regret to hear that you
    are experiencing difficulty scanning from Image Capture with your
    CanoScan LiDE 80.

    That is very strange that the CanoScan LiDE 80 would scan using the
    Toolbox but not from Image Capture. The CanoScan LiDE 80 is not
    supported on the Mac OS X 10.5 Leopard OS. We are sorry for any
    inconvenience this may cause.

    The following models are compatible with Macintosh OS X 10.5: 4400F,
    8400F, 8600F, 8800F, 9950F, LiDE 25, LiDE 35, LiDE 60, LiDE 70, LiDE 90,
    LiDE 500F, LiDE 600F.
  • kingsleyflint Level 1 Level 1 (0 points)
    Canon are talking out of their behind - or someone else is - my LIDE 25 does not work on Leopard either - 'cannot find a driver' it says. So they have got lost I suppose! What else is going to fail me with Leopard, and will Apple take any notice?
  • J. Bill Level 1 Level 1 (0 points)
    Re. Canon's claim of support for the LiDE 25, I do see that the contents of their driver download image, lide25osx11020en.dmg, have fairly recent last-change dates of May 1 2007. (Available via

    Not so for the LiDE 80. The driver they're handing out for the 80, LiDE80_7252MXEN.dmg, contains nothing newer than December 2004.
  • John Froeb Level 1 Level 1 (10 points)
    I just found that Canon has released new 10.5 drivers on 4 nov 07 and they work with 10.5.1 on a G5 20" iMac and a LiDE 60. I did uninstall the old drivers using the CD that came with the scanner, remember to uninstall drivers you must unplug the scanner from the USB port. Another "trick" is if you have the scanner on a hub, it better be powered or the scanner reports driver files not found when it really doesn't have the power to drive the motors.
Previous 1 2 3 Next