10 Replies Latest reply: Dec 29, 2007 11:02 AM by sccr182
Warnie Level 1 Level 1 (0 points)
It says in the Boot Camp Installation Guide that hitting (fn + delete) on a mac keyboard is equivalent to the "Delete" key on a PC, while running Windows thru boot camp. This is not working for me. Is there something I'm doing wrong? This is very important that it work for me because I use it all the time.

Mac OS X (10.5)
  • Warnie Level 1 Level 1 (0 points)
    I have still not found a resolution to this problem. If any of you own a macbook, would you mind trying it? I want to see if anyone else is having this problem. Perhaps its an issue related only to new MacBooks?
  • bearboykahlo Level 1 Level 1 (10 points)
    I am also having the same problem on the new Macbook.
  • Warnie Level 1 Level 1 (0 points)
    www.autohotkey.com is a great solution for this problem. I assigned Command + Backspace as a shortcut for Delete.
  • drkfdr Level 1 Level 1 (0 points)
    What Windows OS?
    The only thing working for me on Vista x32 is Fn+function keys.
    I too would like Fn+cursors, Fn+backspace working.

    Before x32, I tried Vista x64. But that is even more unworkable right now.
  • jedmitchell Level 1 Level 1 (0 points)
    Same problems here. I've tried other key mapping utilities to fix the problem, but they invariably break other things which were working under Boot Camp (for example switching placement of Win/Alt keys renders CtrlAltBackspace inoperative through Boot Camp).
  • essen48183 Level 1 Level 1 (0 points)
    I'm having the same problem with the santa rosa. I need the delete key badly! The only reason I am running bootcamp is for a program for which the delete key is integral to it's operation. I also can't choose the OS to boot into on power on... I must boot into the last used OS and select the other one from preferences and then click restart!?!? I thought it would be ironed out after a month of leopard updates, but still no dice. Is there any way I can fix this on my own?
  • jedmitchell Level 1 Level 1 (0 points)
    oh, thought I'd share this with the rest of the thread: my temporary solution to this keyboard support problem. I make registry edits using a program called keytweak to remap keys in windows. to get the Del key back in service I just mapped it's function to the right hand shift key, which I've never used for anything (all left hand shifts). I've also remapped several other keys that aren't working in Boot Camp, but be warned -- any key you remap via a registry edit will no longer respond to the special Fn key modifier commands through Boot Camp. Oh, and I use rEFIt to fix the problem with Boot Camp not displaying my windows partition at startup. I would still prefer a legitimate solution to this problem though, as these 3rd party solutions will not cover everything.
  • Wyk Level 1 Level 1 (0 points)
    It's looking like this may only be an issue with the MacBook. I have had no issues (in this particular respect) with my MacBook Pro.
  • drkfdr Level 1 Level 1 (0 points)
    I thought I didn't need the right shift either but the next reboot, I failed to login a few times. (mixed case password:)
    I have mapped the eject button as delete. Odd that it's not the default multimedia eject key.
    Fn+Enter still works as insert. Probably hardware-coded in keyboard just like Fn+esc for num-lock (don't know what it does on keyboard without numpad though), etc.
    As for page-up/down... two-finger scrolling can replace that, albeit not very precise.
  • sccr182 Level 1 Level 1 (0 points)
    I am having the same issue as well. Also the two finger scrolling is very glitchy. Soemtimes it doesn't work but sometimes it's extremely sensetive.