12 Replies Latest reply: Apr 8, 2008 6:00 AM by WillD
conaty Level 1 Level 1 (20 points)
I did a clean install, did not import any settings or files. Had to do this because an Archive and Install left me with many many problems. Bit the bullet and started from scratch. Leopard still has many problems I think, but I am hoping that most issues are fixed soon.

One problem that I have is that junk mail does not go to junk folder. I have selected all the appropriate settings. When mail comes in I select "Junk". Even then the message does not go into the junk folder. I understand that with a new install my mail may have to relearn what is junk, but I would assume that at least when I identify junk that it would go to the junk folder.

Any ideas?

Mac OS X (10.5), Intel iMac
  • Ernie Stamper Level 8 Level 8 (37,555 points)

    Please confirm your selections in Mail Preferences/Accounts/Mailbox Behaviors for this account in regard to both Junk and Deleted Messages, please.

  • Jlock Level 1 Level 1 (0 points)
    I did the default upgrade and see a similar problem. When mail auto designates a piece of mail as "junk" sometimes it goes to the junk box and other times it does not. When I manually label mail as junk it always is moved to the junk box. I do notice that the mail that does not auto move to the junk box is not labeled junk until I open the message. Once the message is open, mail automatically labels it junk, it just does not move it to the junk folder.

  • Ernie Stamper Level 8 Level 8 (37,555 points)
    Hello, and welcome to the Discussions.

    What type of account or accounts are you using -- POP, IMAP or .mac? What are your selections in Mail Preferences/Accounts/Mailbox Behaviors?

  • drdidg Level 1 Level 1 (0 points)

    Same here. Nothing is moving into the Junk Mail folder as it should be.

    Dual 2Ghz G5
    1 .Mac Account
    1 Work IMAP Account
    2 IMAP GMail Accounts

    Clean Install
    Copied Tiger's ~/Library/Mail back to ~/Library/Mail before starting Mail 3.
    Was in Training Mode after it did it's thing. Left it that way for a few days to retrain a bit. Changed mail settings out of training mode and back to Move Junk Mail to Junk Mail folder. Junk mail is marked in the Mail Application. Web .Mac mail has also stopped marking mail as Junk. I mark it as junk and it still goes nowhere.
  • Jason Sims Level 2 Level 2 (180 points)
    This is not working for me either, as of a week or two ago. Junk mail is marked as junk, but stays in my inbox, regardless of my junk mail settings. I have it set to move junk to the junk folder, but Mail simply refuses to do so. I tried changing the setting, closing preferences, opening prefs and changing it back, but that does not help either.

    Sadly this is the least of my problems with Mail in Leopard. I've had nothing but problems with it so far and I'm getting really frustrated. I'm running out of patience and ideas and it may simply be time to wipe out all my mailboxes and preferences, reimport all my old mail and start over from scratch again.
  • the_kais Level 1 Level 1 (0 points)
    I am having this same issue, on 3 Leopard installs, all connected to the same account via IMAP.
    They were all set up from scratch, no importing of mail.
    Junk mail comes in and sits in the mailbox, and only when highlighted or double clicked it is marked as junk. Yet after that it does not move to the Junk box, but just stays put.
    In a word, Apple Mail's junk mail filtering is broken.

    Message was edited by: the_kais
  • d_mark Level 1 Level 1 (0 points)

    are there any news on this topic?

    I (and some of my colleges) have the same Problem - spam emails are recognized and marked as junk only when I'm 'reading' them. They also are not moved to the junk folder automatically. The workaround I 've found to move the junk email to the junk folder is to select all messages and then execute a "Apply Rules".

    kind regards
  • WillD Level 1 Level 1 (10 points)
    I just did my leopard upgrade, and I'm having the exact same problem. Also, I notice that it doesn't mark it junk until I click on it to read it, which is kinda counter-productive (if it's junk, I want to know AHEAD of time so I don't have to waste time reading it). No solutions yet??
  • WillD Level 1 Level 1 (10 points)
    Found in another thread suggestion to reset the junk mail settings:


    All I did was hit the reset button -- I hadn't noticed it there before. It resets the training db, and I was loathe to lose all my training, but it actually seems to have made it start working again -- new junk mail comes in, and goes straight to the junk folder and I don't see it in my inbox.
  • WillD Level 1 Level 1 (10 points)
    Nevermind, it seems to be back to its old behavior, of not marking msgs spam until I read them, and not moving them to the junk folder. Frustrating and bizarre.
  • Stefan_C_Kremer Level 1 Level 1 (0 points)
    I had this same problem on one of my machines after upgrading to leopard. I was able to fix this by changing:

    Mail -> Preferences -> Accounts -> Advanced -> Keep Message for Off-line Viewing


    Only Messages I've Read


    All Messages and Their Attachments

    I think that the first option was changed in a recent version of mail to never download the messages before reading (preventing them from being flaged as Junk).

    I hope this helps, others (I know I was pulling my hair out in frustration over this problem for a long time...).

  • WillD Level 1 Level 1 (10 points)
    Interesting. Although, I don't think it's necessary to have it keep messages to make the junk filter to work -- under Tiger I had mine set to "don't keep copies of any messages" and the junk filter worked fine.