9 Replies Latest reply: Jan 7, 2008 3:39 PM by Stephen Duvall
LuisCape Level 1 Level 1 (0 points)
Hello, yesterday a weird file appeared in my trash, and since then I've tried in every way but i cannot delete it. The file name is very weird and it looks sort of like this:

n n n n n n n
u u u Ō u u . u u
l l l l l l l

Each of those 'nul's is actually a symbol and not 3 letters on 3 rows like i displayed it.

If i try to drag the file to the Desktop the file temporarily disappears from the trash but when i reopen it, it appears again.

Do you have any idea of how to remove it, is there maybe some terminal code that would help me?

Thank you.

Luis

MBP 2.2, Mac OS X (10.5)
  • LuisCape Level 1 Level 1 (0 points)
    Sorry another thing I forgot, if I try to Get Info on the file while it's in the trash, it disappears...
    If I close the window and re-open it, it reappears again. Any ideas on why is this happening?

    Thank you.

    Luis
  • Heymike Level 1 Level 1 (65 points)
    If you have a windows partition, usually formatted as FAT 32, there is a problem with the .Trashes folder on that partition. The folder is hidden while viewing the files in the Mac Finder, but it can be seen when booted into windows.

    I repaired the problem by booting into windows using Parallels and running the Check Disk Utility for windows hard drives. (Open My Computer, right click on the C drive and click properties. Click on the tools tab, then click repair hard drive. Make sure there is a check in the box that says "repair errors". Then you will be prompted to reboot. Check Disk will run on reboot)

    Check Disk found the error in the .Trashes/501 folder and repaired it. Now my Trash in OS X does not have the strange characters when I empty it.

    I haven't tried it, but I would assume that if I just booted into windows, (through bootcamp or Parallels, or VMWare Fusion) and deleted the .Trashes folder on the C drive, that would work also. If you have an external drive formatted in FAT 32, you can plug it into a windows machine and you should be able to do the same thing.

    Hope this helps, good luck.
  • ladytudorrose Level 1 Level 1 (0 points)
    I have the same problem. I do have a Windows partition I created in Boot Camp, but I have yet to actually install Windows, so there is no way for me to open Windows to delete the file from the trash. Is there any other way to get rid of this file? I've tried working within Terminal but nothing happened and I got TrashIt and tried that, but again nothing.

    Help please?
  • Smokerz Level 6 Level 6 (9,410 points)
    106272 read this Apple doc apple/support and go to the bottom of page under advanced. Use copy/paste in the Terminal to get rid of that pesky file which will not empty on trash.
  • ladytudorrose Level 1 Level 1 (0 points)
    Tried it. No such luck. It kept coming up with the error message: -bash: ␀␀c.␀␀: command not found
  • R C-R Level 6 Level 6 (15,995 points)
    Smokerz wrote:
    106272 read this Apple doc apple/support and go to the bottom of page under advanced. Use copy/paste in the Terminal to get rid of that pesky file which will not empty on trash.


    This won't work because the file name has "special characters" that are normally prevented from appearing in file names for various reasons. Here, the "nul" character is probably ASCII character number zero, a character so special it normally appears only in raw code & is replaced in textual contexts by Unicode #2400, the "symbol for null," to keep it from wreaking havoc.

    Because if this, you might try the article's method mentioned in *Does the file or volume have special characters?* & see if you can rename it (while in the trash) to something not-so-special, like simply "t," & seeing if you can then delete it.
  • krazytekn0 Level 1 Level 1 (15 points)
    http://discussions.apple.com/thread.jspa?threadID=1234388&tstart=0

    this thread is about the same problem and has a solution
  • ladytudorrose Level 1 Level 1 (0 points)
    I've actually already posted on that thread and, no, there is no answer there either. I've tried all the possible solutions mentioned and none of them (that are possible with what software I have at this very moment) worked. So I am waiting until I can get the copy of XP to install on my Boot Camp partition and then I think I can make this file go away.
  • Stephen Duvall Level 1 Level 1 (25 points)
    I've had a similar problem. Usually the root user can delete it (it can be enabled via Directory Utility). I wouldn't get into the root user if you're not comfortable with computers, though.