Previous 1 2 Next 15 Replies Latest reply: Jun 30, 2008 1:17 PM by gregcaulder
Rehan Ashroff Level 1 (0 points)
Hi After much googling a post on this page

states the following command allows timemachine to backup to any mounted network share, and they are correct. I am succesfully running my 1st backup to a Windows share over SMB. Will keep you posted on how it goes. But here is the command:

defaults write TMShowUnsupportedNetworkVolumes 1

iMAc G5 17inch, Mac OS X (10.5)
  • Rehan Ashroff Level 1 (0 points)
    My backup was succesful, and subsequent incremental backups are taking place as expected as well. The initial backup did take sometime but ran it overnight so wasnt that bad.

    So in short, Timemachine is working over a network share and backing up to a Windows PC.

    Now I am happy to use timemachine.
  • David Leeds Level 1 (0 points)
    Have you verified the backup. Meaning can you use Time Machine to browse your backup. It seems that you can get a network drive to be utlized but when you activate it you only see today in Time Machine.
  • Rehan Ashroff Level 1 (0 points)
    All I have right now are the hourly backups so far for the 1st 24hr period. Granted not much has changed I am able to scroll through them and get to the very 1st backup. I will let you know how things look tomorrow and the rest of the week.
  • RocketAlchemist Level 1 (30 points)
    This worked ... for a while for me with an Infrant ReadyNAS share. Either SMB or AFP was recognized.

    TM recognized the shares.

    Backed up for while ... (50 GB of 150 GB) ... and then stopped.
  • David Leeds Level 1 (0 points)

    Have tested and verified my Time Machine backup via smb. I have a my book work edition gigabit ethernet hard drive. Due to the speed of the connection (gigabit) as well as my apple extreme gigabit
    with wireless n. Even the wireless n is just as fast as a usb connection. I have had no reliability problems as of yet. Backup is browsable and everything is automatic. We will have to see if this works out long-term.

    Thanks for the info.

    It terms of the command in terminal: Is there a way to undue the command and go back to the standard settings if I have any system stability issues? Does anyone know?
  • seanwenzel Level 1 (0 points)
    To rollback or undo I'd try:

    defaults write TMShowUnsupportedNetworkVolumes 0

    Haven't tried it myself. Why undo a good thing?
  • Rehan Ashroff Level 1 (0 points)
    Ok so far so good. everything seems to be working as expected. I havent had any issues retrieving data from backup in the random tests that I have done so far. My internal network is Gigabit, so the backups do run fairly fast, I would not think of doing this over a wireless connection though , especially not the 1st full backup. Maybe the incrementals if I had to, but TimeMachine or not, backups are a resource intensive process, and wireless being such an unreliable medium for most things other than casual browsing, email etc. I cant imagine why anyone would take the risk with gigs of data.

    Anyways hopefully it looks like others have been succesful at using network based backup as well with TimeMachine, which is great!
  • David Leeds Level 1 (0 points)
    Time Machine was initially slated for wireless backup and I am sure this will be fixed and supported in future osx updates. I have done all backups via airport extreme n wireless and have had no performance issues. Wireless N seems to work almost as fast as a usb connected drive. My guess is that there were concerns with wireless a/b/g backup performance and this is why the airport fisk feature was pulled. Also it seems to me that
    wireless backup is the only reasonable decision for those of us with Laptops.
  • Felix-FI Level 1 (0 points)
    I have been running Time Machine on an network SMB mounted partition for a couple of weeks (using the trick where you disabled the time machine disk check
    defaults write TMShowUnsupportedNetworkVolumes 1)...

    I know it was a bad idea... but I have plenty of SMB space available at my lab, while no real hard disk (until today )

    Everything went fine until today, where finally the disk filled up... and I got this in the console

    20/11/07 15:10:42 /System/Library/CoreServices/backupd[11539] Trusting backup times for remote backups.
    20/11/07 15:10:51 /System/Library/CoreServices/backupd[11539] Starting pre-backup thinning: 5.03 GB requested (including padding), 3.07 GB available
    20/11/07 15:11:30 /System/Library/CoreServices/backupd[11539] Deleted backup /Volumes/Backup of Zig/Backups.backupdb/Zig/2007-11-19-145728: 3.07 GB now available
    20/11/07 15:11:30 /System/Library/CoreServices/backupd[11539] Removed all 1 expired backups, more space is needed - deleting oldest backups to make room
    20/11/07 15:12:20 /System/Library/CoreServices/backupd[11539] Deleted backup /Volumes/Backup of Zig/Backups.backupdb/Zig/2007-11-09-145354: 3.07 GB now available
    20/11/07 15:13:08 /System/Library/CoreServices/backupd[11539] Deleted backup /Volumes/Backup of Zig/Backups.backupdb/Zig/2007-11-12-085647: 3.07 GB now available
    20/11/07 15:14:02 /System/Library/CoreServices/backupd[11539] Deleted backup /Volumes/Backup of Zig/Backups.backupdb/Zig/2007-11-13-105151: 3.07 GB now available
    20/11/07 15:14:57 /System/Library/CoreServices/backupd[11539] Deleted backup /Volumes/Backup of Zig/Backups.backupdb/Zig/2007-11-14-094201: 3.07 GB now available
    20/11/07 15:15:49 /System/Library/CoreServices/backupd[11539] Deleted backup /Volumes/Backup of Zig/Backups.backupdb/Zig/2007-11-15-093340: 3.07 GB now available
    20/11/07 15:16:58 /System/Library/CoreServices/backupd[11539] Deleted backup /Volumes/Backup of Zig/Backups.backupdb/Zig/2007-11-16-091426: 3.07 GB now available
    20/11/07 15:19:39 /System/Library/CoreServices/backupd[11539] Deleted backup /Volumes/Backup of Zig/Backups.backupdb/Zig/2007-11-19-084944: 3.07 GB now available
    20/11/07 15:19:51 /System/Library/CoreServices/backupd[11539] Deleted backup /Volumes/Backup of Zig/Backups.backupdb/Zig/2007-11-19-160038: 3.07 GB now available
    20/11/07 15:20:25 /System/Library/CoreServices/backupd[11539] Deleted backup /Volumes/Backup of Zig/Backups.backupdb/Zig/2007-11-19-164736: 3.07 GB now available
    20/11/07 15:21:14 /System/Library/CoreServices/backupd[11539] Deleted backup /Volumes/Backup of Zig/Backups.backupdb/Zig/2007-11-19-174849: 3.07 GB now available
    20/11/07 15:21:39 /System/Library/CoreServices/backupd[11539] Deleted backup /Volumes/Backup of Zig/Backups.backupdb/Zig/2007-11-20-100005: 3.07 GB now available
    20/11/07 15:22:07 /System/Library/CoreServices/backupd[11539] Deleted backup /Volumes/Backup of Zig/Backups.backupdb/Zig/2007-11-20-104417: 3.07 GB now available
    20/11/07 15:22:39 /System/Library/CoreServices/backupd[11539] Deleted backup /Volumes/Backup of Zig/Backups.backupdb/Zig/2007-11-20-114450: 3.07 GB now available
    20/11/07 15:23:00 /System/Library/CoreServices/backupd[11539] Deleted backup /Volumes/Backup of Zig/Backups.backupdb/Zig/2007-11-20-124449: 3.07 GB now available
    20/11/07 15:23:00 /System/Library/CoreServices/backupd[11539] Error: backup disk is full - all 15 possible backups were removed, but space is still needed.
    20/11/07 15:23:00 /System/Library/CoreServices/backupd[11539] Backup Failed: unable to free 5.03 GB needed space
    20/11/07 15:23:01 /System/Library/CoreServices/backupd[11539] Backup failed with error: Not enough available disk space on the target volume.
    20/11/07 15:23:03 /System/Library/CoreServices/backupd[11539] Ejected Time Machine disk image.
    20/11/07 15:23:03 /System/Library/CoreServices/backupd[11539] Ejected Time Machine network volume.

    Do you see where I am coming? this is already scary... it deleted ALL but one backups, without recovering one byte... Jez... without a warning (despite the check box in the TM pref option pane)

    Look at this:

    [zig:~] felix% mount
    /dev/disk0s2 on / (hfs, local, journaled)
    devfs on /dev (devfs, local)
    fdesc on /dev (fdesc, union)
    map -hosts on /net (autofs, automounted)
    map auto_home on /home (autofs, automounted)
    // on /Volumes/felix (smbfs, nodev, nosuid, mounted by felix)

    This is the SMB partition:
    [zig:~] felix% df -g /Volumes/felix/
    Filesystem 1G-blocks Used Available Capacity Mounted on
    // 66 63 3 96% /Volumes/felix
    [zig:~] felix% ls /Volumes/felix/
    [zig:~] felix%

    <here I mounted the sparsebundle image using the finder>

    [zig:~] felix% mount
    /dev/disk0s2 on / (hfs, local, journaled)
    devfs on /dev (devfs, local)
    fdesc on /dev (fdesc, union)
    map -hosts on /net (autofs, automounted)
    map auto_home on /home (autofs, automounted)
    // on /Volumes/felix (smbfs, nodev, nosuid, mounted by felix)
    /dev/disk2s2 on /Volumes/Backup of Zig (hfs, local, nodev, nosuid, journaled, mounted by felix)
    [zig:~] felix% df -g /Volumes/Backup\ of\ Zig/
    Filesystem 1G-blocks Used Available Capacity Mounted on
    /dev/disk2s2 132 129 3 98% /Volumes/Backup of Zig

    So the Backup partition pretend to use 129 Gig (weird as its containing SMB partition is 66 Gig big) and 3 Gig left...

    [zig:~] felix% cd /Volumes/Backup\ of\ Zig/
    [zig:/Volumes/Backup of Zig] felix% ls
    [zig:/Volumes/Backup of Zig] felix% ls Backups.backupdb/
    [zig:/Volumes/Backup of Zig] felix% ls Backups.backupdb/Zig/
    2007-11-20-141210/ 2007-11-20-151041.inProgress/ Latest@
    [zig:/Volumes/Backup of Zig] felix% sudo du -sk .
    35637816 .

    But all the files on this partition amount to 35 gigs... (which is indead more or less the size of one backup)... where are the other 31 gig gone? My explanation is that the space has not been properly recovered after the old backups deletion... (which indeed also explains why backupd deleted ALL but one backups)

    In any case, I would advise any SMB mounted partition Time Machine user to NOT rely completely on those backup. I will try to see if one can recover the space in a sparsebundle image... but even so, it makes the whole process dangerous.

    You have been warned...

    [zig:/Volumes/felix] felix% hdiutil compact Zig_0017f2c89d46.sparsebundle
    Starting to compactâ¦
    Reclaiming free spaceâ¦
    ................................................................................ ....................................................................
    Finishing compactionâ¦
    Reclaimed 19.5 GB out of 97.9 GB possible.
    [zig:/Volumes/felix] felix% df -g .
    Filesystem 1G-blocks Used Available Capacity Mounted on
    // 66 43 22 66% /Volumes/felix
    [zig:/Volumes/felix] felix%
    Note that I only recover (by hand) 22 gig while 31 should be available... but this is explained in man hdiutil:

    "For SPARSEBUNDLE images, completely unused band files are simply removed."

    Completely... so Iguess only 22 gig of bands were free 9 gigas are in band which are partially used by good data.

    [zig:/Volumes/felix] felix% cd /Volumes/Backup\ of\ Zig/
    [zig:/Volumes/Backup of Zig] felix% df -g .
    Filesystem 1G-blocks Used Available Capacity Mounted on
    /dev/disk2s2 132 109 22 83% /Volumes/Backup of Zig
    [zig:/Volumes/Backup of Zig] felix%

    So the space has been indeed returned to the SMB volume... and I was able to restart TM after that and complete a backup...

    In any case, I say it again... do not rely on SMB mounted partition based TM backup.

    As for me, I am ordering a 200 gig external HD :-D
  • lior Level 1 (85 points)
    Sorry about the SMB business. BUt would this fix work for a simple backup drive that is MAC OS Journal formatted?
  • badtz Level 2 (250 points)
    was there ever a remedy for this?
  • Biola Chris Level 1 (0 points)
    I have two machines that are successfully backing up to a AFP volume with this trick. My Macbook is backing up fine, and can also retrieve the old information when needed. My Macbook Pro however can perform each incremental backup but will only show "Today" when entering Time Machine for a backup. Both machines are running in the same environment with 10.5.1.

    I can mount the sparsebundle file and retrieve my information, but Time Machine does not seem to add it all up.

    Backups work fine with both Gig ethernet and 802.11n.
  • Scot Stevenson Level 1 (15 points)
    was there ever a remedy for this?

    Yes. Flokru not only wrote a short piece on how to use network shares - rd/

    - but also an explanation of what goes wrong in this case with three suggested solutions: le-problems/

    He also explains how to repair the Spotlight index when it gets screwy with TM, but the article is only in German (his native language) so far: etzen/

    If I understand correctly, the root of the problem seems to be that the contents of a sparse bundle are not really deleted when they are told to. The solution is to make sure your sparse bundle maximum size is never larger than the physical share size available. Again, you'll want to read the article yourself, because I haven't gotten around to setting up a new system yet and might be "nicht verstehen" something.

    I think Apple is being short-sighted by not providing more information on this. Until they provide a RAID system for storage -- a Time Capsule version with more than one drive would be a good start -- we of the paranoid tribe are going to be looking for external solutions.

    Hope that helps,
    Y, Scot
  • Adam C-R Level 1 (0 points)
    This problem has now been fixed with Apple's latest Time Machine and AirPort Updates v1.0. Time Machine will now compact the sparse bundle after it deletes an old backup to make sure it has the right amount of free space. I've posted my logs to show the new behaviour: e.html


Previous 1 2 Next