8 Replies Latest reply: Nov 29, 2007 1:19 PM by Pmcaneeley
frmrt Level 1 (10 points)
I have FCP 5.1.4 installed, along with Compressor 2.1 (as part of FCP Studio 1). I've been searching in this forum and elsewhere on the web, and it appears that many people are having a similar problem: the Compressor application will simply not launch. It hangs on the dock for a moment, then disappears. Nothing else happens.

I have tried the steps that are proposed by Apple in that often cited support document (removing all files, reinstalling Compressor, upgrading from Software Update, then rebooting) a total of three times, and the problem still exists. I even removed every last piece of FCP Studio 1 (every related file) and then attempted a full reinstall of the FCPS 1, with no luck. Compressor is dead.

I see one other solution proposed, and it's a head-scratcher. I'm supposed to wipe my hard drive clean, and then reinstall my entire system? That sounds precisely like the nightmare I expect from Windows, and is the reason I left PCs for Macs in the first place. Risking my entire system to get a single application to work. Absolutely staggering...makes me almost wish I was back on Adobe Premiere Pro again. It wasn't great, but it did actually work.

If anyone has any other suggestions, I would greatly appreciate it. I'm on a deadline to finish a short, and the director finds it really strange that I cannot output DVDs of the cuts for him.

Many thanks,

Mac Book Pro, Mac OS X (10.4.10)
  • frmrt Level 1 (10 points)
    I downloaded a Pro Applications update that popped up two days ago, and all of a sudden...Compressor works.

    I'm not sure I can explain it any more than that (and apologize if this news isn't useful to others who are suffering from mysterious and frustrating problems with Compressor) but everything on my system now appears to be working perfectly. FCP, DVD Studio, Compressor, Cinema Tools--all of them, and quite speedily. What I expected from Apple.

  • CHFILM Level 1 (0 points)

    I have EXACTLY the same problem like you, but the update was not able to resolve the trouble... its so frustrating. What else could i try?
  • frmrt Level 1 (10 points)
    I gather you've already done a full uninstall/clean reinstall of FCP (and all related Studio applications) but if you haven't that's the place to start. You'll need to find every last vestige of all the applications, which can be tricky, so be sure to use Spotlight, and search for the Apple support doc that outlines the way to find the files that are REALLY hidden, and be sure to delete everything, without exception. (Even one little bit left behind will cause a problem with the new install.)

    If you've already done this, and are sure the reinstall was clean, then I'd advise you try it one more time, just to be sure.

    One other possibility: did you install Leopard recently? I stayed with Tiger just to be safe, and it's possible your problem is compounded by the new operating system.

    Sorry I can't be of more help than this.

  • liveonce Level 1 (0 points)
    I too have this exact problem.
    Compressor 2.0.1 will not launch either in the finder or in FCP 5.0.4

    I have tried reinstalls as described elsewhere. Does anyone have any idea how to solve this problem? If not, what third party software should I consider to export to DVD Studio Pro 4.0.3

    Any help on this would be greatly appreciated as I am up against a deadline and the Mpeg 2 option has disappeared from my quicktime options in FCP.

    So, what are my options to export to DVD Studio Pro?

  • frmrt Level 1 (10 points)
    Well, the good news is that DVD Studio Pro does MPEG2 encoding as it authors DVDs, so you don't need to use Compressor or FCP for that.

    So I'd recommend exporting a Quicktime movie from FCP (File: Export: QuickTime movie; using whatever compression options and settings most closely mirror your original media, without making the file size too large) and then importing that as an asset into DVD Studio Pro. From there, it will handle the MPEG2 conversion during the burn.

  • liveonce Level 1 (0 points)
    Thanks, I'll try this
  • Compressor Zealot Level 2 (305 points)
    It's a long shot, but did you try this stuff?
  • Pmcaneeley Level 1 (0 points)
    We were having the same issues with Compressor after installing the updates for FCP Studio 2. It would launch but there was no project window, so therefore nowhere to drag a file for compression.
    We went through the whole painful process of uninstalling and re-installing the whole FCP Studio application but Compressor still behaved the same way. What we discovered by accident was that we had to delete the shortcut icon from the Doc and from the desktop and then it worked fine! So, this simple step might solve some the problems that others are experiencing. Good luck!