Previous 1 2 Next 22 Replies Latest reply: Feb 23, 2008 8:37 AM by Nathan Fisher
rfnoise Level 1 Level 1 (0 points)
Has anyone seen the following?[1] (0x1109b0.cron[87714]): Could not setup Mach task special port 9: (os/kern) no access

I am getting this notice every 5 minutes.

MAC OS X Server, Mac OS X (10.5), upgrade
  • rolnas Level 1 Level 1 (0 points)
    That is coming from user cron jobs, but it is not clear why it appears always on any user cron job execution. I tested with /usr/bin/true cron job - the same result, so it is not releated to cron job itself.
  • vidgizmo Level 1 Level 1 (0 points)
    I'm seeing the same thing... have you seen any feedback on how to clear it? Syslog is qualifying it as a warning.

    Full text of the one message in my log:
    11/14/07 3:52:00 PM[1] Warning (0x10c120.cron[3193]) Could not setup Mach task special port 9: (os/kern) no access
  • vidgizmo Level 1 Level 1 (0 points)
    Actually looks like there's another thread on this topic, perhaps more appropriately titled:
  • vidgizmo Level 1 Level 1 (0 points)
    A cosmetic improvement, simply remove the lines from your asl.db (Apple System Log)...

    Add the following line to your crontab

    */10 * * * * /usr/bin/syslog -p -k Message R "Could not setup Mach task special port 9"

    Of course that doesn't clean them out of /private/var/system.log and doesn't address the root issue.
  • SpectraTech Level 1 Level 1 (0 points)
    I'm getting the same event logged! Maybe I should of waited awhile before upgrading and stayed with Tiger! This has been the worse upgrade for OS X. Hope someone can figure out how this can be fixed.
  • mactechconsulting Level 4 Level 4 (2,775 points)
    I am getting this notice every 5 minutes.

    Sheesh I'm getting it Every Minute!! How do we make it happy?
  • mactechconsulting Level 4 Level 4 (2,775 points)
    Well I Clean installed again and DID NOT use the Migration assistant. I pulled over by hand what I knew I needed and left a Tome of old stuff behind. I did this as I had a Vanilla 10.5.1 on another drive and when I looked in console there were only 200 entries and nothing being written every minute. The install I was using that used the migration assist with had about 2500 entries every 2 days. Every minute It was doing the crone error. It was driving me nuts seeing the VM memory climbing to 2 megs. Now I have none of those issues!!! So whatever it was I did not pull over, Thank God. I kept checking console as I pulled things over and restarted and all held with no repeating errors in perpetuity. I had sent the issue to MacFixit and he suggested a clean install without migration. He could not figure out what it was either. I had felt this was what to do after seeing the other install (that had no migration) and when he confirmed it I bit the bullet and spent the day and now I have none of those repeating errors issues. Yikes this upgrade has been a BEAR But I Do Love Leopard! Very fresh once you start Fresh. I hope this helps out some of you with the same issue.
  • criquet Level 1 Level 1 (30 points)
    Thanks for the details but that's not helpful for me. Mine was a fresh install. I pulled no settings.
  • mactechconsulting Level 4 Level 4 (2,775 points)
    You must have added something to cause the activity. It does not happen on a Vanilla install.
  • criquet Level 1 Level 1 (30 points)
    Just curious, did you set up any cron jobs in your fresh, vanilla install? Because mine was most definitely a fresh install with nothing special. But once installation was complete, I configured some cron jobs. Though I don't actually know if the messages began before that because I wasn't paying any attention to the logs prior.
  • mactechconsulting Level 4 Level 4 (2,775 points)
    No I did no installs of any cron jobs. You may want to delete them and see if that does it? One of the jobs may have invoked some backround task as all the processes were changed Im Leopard. They took them from the startup Folder and reassigned them to the Launch Demons and Launch agents,,, This from MacFixit...

    +How processes get launched automatically on Leopard+

    +A number of recent communications to MacFixIt have implicitly raised the issue of how things get launched automatically on Leopard, prompting this little tutorial explanation.+

    +You are all familiar with the Account system preference pane and its Login Items. As you know, any application listed here will be launched automatically when the user logs in (which may be the same as starting up the computer, if you're set up for automatic login). But this is obviously insufficient to explain the presence of the numerous other processes you can see running in Activity Monitor. How did they get launched?+

    +In Leopard, the answer to this question changed - or rather, in Tiger, the groundwork was laid for a change in the answer to this question, and Leopard that groundwork is carried to through to its logical fulfillment. The focus of this change is a process called launchd. (For how things started up before launchd existed, see this excellent description.) The launchd process is called during the boot sequence as the computer starts up, and is the "root system process", the one process responsible for launching all others. You can see this in the Activity Monitor window if you switch to viewing "All Processes, Hierarchically": there are just two top-level processes, process 0 (kernel_task) and process 1, which is launchd and is the parent of every other process. Aptly, launchd is often analogized to Tolkien's "one Ring to rule them all," and you can see this analogy being made, if you're interested in the technical side of these things, in a video lecture starring the author of launchd, Dave Zarzycki.+

    +When launchd starts up, it looks for files in /System/Library/LaunchAgents and /System/Library/LaunchDaemons. Each of these files is a cleverly coded set of instructions describing what process to launch and when. If you simply look at the files in the Finder, you can see that their names correspond to the system processes that are shown in Activity Monitor. For example, on my machine, a process shown in Activity Monitor is autofsd; that was launched because of a file in LaunchDaemons called The next process shown in Activity Monitor is blued; that was launched because of a file in LaunchDaemons called And so on.+

    +It's important to emphasize that the files in LaunchDaemons and LaunchAgents are not themselves the launched processes; they are just instructions for launching processes. If you'd like to read those instructions, the best way is with the freeware utility Lingon, which we've mentioned several times recently in this context. It shows, for example, that actually launches a process located at /usr/sbin/blued. Of course, that doesn't tell you what the process blued does; but sometimes you can find out about that in some other way. For instance, blued has a man page (type man blued in the Terminal to see it) that explains that this process is in some way responsible for Bluetooth communications.+

    +(What's the difference between LaunchAgents and LaunchDaemons? Well, it's a bit tricky, but LaunchDaemons should be considered as tied to the machine as a whole, whereas LaunchAgents are tied to individual users. So, for example, blued is a LaunchDaemon because any Bluetooth device that comes along is going to make contact initially with this machine as a whole; but the first thing my /System/Library/LaunchAgents folder,, launches the process that apps would use to communicate with an individual user's Address Book - there is no Address Book for the machine as a whole.)+

    +There can be LaunchAgents and LaunchDaemons in other places than the System folder. For example, there are also /Library/LaunchAgents and /Library/LaunchDaemons. These places are for items that are installed by you (or whoever is administrating your computer). For example, on my machine, as I already explained, there's the LaunchAgent at.obdev.littlesnitchd, which is installed by Little Snitch and is responsible for launching the process that intercepts outgoing communications. And then there are also ~/Library/LaunchAgents and ~/Library/LaunchDaemons in your own User folder, which might also have something in them; if you enable AppleScript "folder actions", for example, files will appear in your own LaunchAgents folder, and these are responsible for triggering the processes that handle folder actions on Leopard (the architecture here is very different than it was on Tiger).+

    +As the video I mentioned earlier says, Leopard has 166 launchd processes built in. That doesn't mean all 166 will be running at the same time, but it does mean that there are 166 "things" in Leopard that might get launched via launchd, depending on the circumstances. Not all of them are launched at startup, either; launchd launches some things at startup, but it also launches other things just when needed. All of that, however, should mostly work okay. One of the cool features of launchd is that if one of its processes crashes, and if this is a process that is supposed to be kept running at all costs, launchd notices this and relaunches it. You might see evidence of this in the Console, and generally it should probably not be taken as a sign of trouble. Things do go wrong; when launchd relaunches something, it's just taking care of business.+

    +Okay, now I'm going to add a level of complexity. On Tiger, it was not uncommon for processes wishing to be launched automatically at system level to take advantage of a different mechanism, namely through files installed in /Library/StartupItems. For example, on my Tiger machine, /Library/StartupItems contains three folders: KeepIdle (installed by Interarchy to make FTP communications work better), MySQLCOM (which launches the MySQL server), and RetroRun (installed by Retrospect). On Leopard, such files are still honored - they are handled by the SystemStarter process, which is one of the things launched by launchd - but they are deprecated, meaning that Apple would like to phase out StartupItems and SystemStarter altogether. (The SystemStarter mechanism goes back to the early days of Mac OS X.)+

    +You might like to look in /Library/StartupItems right now, because you might see something that surprises you, or that explains how some funny process you don't know anything about is getting launched. For example, every once in a while, under Tiger, a user would complain to MacFixIt about an inability to shut down the computer (the computer would halt at the blue screen near the end of the shutdown process, but the power wouldn't go off); this phenomenon is often caused by a rogue process in StartupItems. On my Leopard machine, /Library/StartupItems is empty, and I intend to try to keep it that way; any application that wants to install something here is not truly Leopard-ready.+

    +Another problem with process launching that can affect users is when process try to launch and fail. This should not happen at all, but when it does, launchd will usually just try again a minute later. The act of repeatedly trying and failing to launch a process can cause your CPU to peg out and your Console to fill up with messages, as described in this note from a MacFixIt reader:+

    +Leopard is writing this to Console [repeatedly] and for the life of me I can't figure out what program the cron is associated with...+

    +11/28/07 7:42:00 PM[1] (0x10a420.cron[2176]) Could not setup Mach task special port 9: (os/kern) no access+

    +I don't know either (what process is ultimately behind this), but it is apparent that something is trying to launch and failing, perhaps because of a permissions problem ("access"). Since cron is mentioned in the Console message, the user having this problem might also want to look at his crontab file (type crontab -l in the Terminal); this file is yet another place where surprises may lurk. If you see mention of some process you don't like, and if you don't know how to edit your crontab file, you can remove it entirely with crontab -r.+

    +Similarly, a recent thread over at TidBITS-Talk describes repeated Console messages about "Throttling Respawn" and "com.mozy.backup". The latter is something installed by Mozy Backup - which, interestingly, figures in a number of complaints to MacFixIt from users - and the solution would be to try to find it, probably by looking in the /Library folders we've already mentioned, namely StartupItems, LaunchAgents, and LaunchDaemons.+

    Hope that helps I ended up doing the clean Install (3rd time) with No Migration and I'm WAY better off for it. Believe me I was loath to do it, +but Im pleased as punch I did!+
  • criquet Level 1 Level 1 (30 points)
    One of the first things I did when I noticed these messages was to delete all the cron jobs. The message persisted. What I didn't think to try was to completely remove my user's crontab file (but that's because I have no clue where it is now, since leopard seems to not be using anything like /var/cron* anymore, ***?!).
  • Benjamin Robertson Level 1 Level 1 (100 points)
    I am having the same issues - tried a couple things today though, and thought I'd list out.
    Running 10.5.1 / MBP; clean install and migration from clone (SuperDuper) - all kinds of goofiness, with apps not launching properly, Mail not showing all the accounts, and giving permissions errors.

    did Spotlight search for com.dartware.InterMapperServer which was the file constantly being referenced, and found nothing except an Installer log file that contained it - here's a small copy of the installer log file:

    +tem will be copied: /Library/Internet Plug-Ins/NPSVG3Carbon+
    +Nov 3 17:30:21 localhost Unknown[66]: 2007-11-03 17:30:21.713 Mac OS X Installer[147:dc4b] 2007-11-03 17:30:21 -0700 -[SMFileGrouping paths]:370 Item will be copied: /Library/Internet Plug-Ins/NPSVG3ReadMe.html+
    +Nov 3 17:30:21 localhost Unknown[66]: 2007-11-03 17:30:21.713 Mac OS X Installer[147:dc4b] 2007-11-03 17:30:21 -0700 -[SMFileGrouping paths]:370 Item will be copied: /Library/LaunchDaemons/com.dartware.InterMapperServer.plist+
    +Nov 3 17:30:21 localhost Unknown[66]: 2007-11-03 17:30:21.714 Mac OS X Installer[147:dc4b] 2007-11-03 17:30:21 -0700 -[SMFileGrouping paths]:370 Item will be copied: /Library/LaunchDaemons/com.mystfans.MenuTemperature.SpeedIt-launcher.plist+
    +Nov 3 17:30:21 localhost Unknown[66]: 2007-11-03 17:30:21.715 Mac OS X Installer[147:dc4b] 2007-11-03 17:30:21 -0700 -[SMFileGrouping paths]:370 Item will be copied: /Library/Mozilla/Global.regs+

    opened up /Library/LaunchDaemons/, and the file was listed there, but only 1 of 2 - deleted it, and the message changed to: +12/2/07 3:18:33 PM[122] (0x10e960.Locum[1673]) Exited: Terminated+
    but it still continues - Intermapper's uninstaller claims that it's not installed (and I have indeed deleted it).
  • Patrick Gibson Level 1 Level 1 (95 points)
    I noticed this was happening to me, and just realized that it happened after I activated Mailman. For now, I've disabled Mailman and shut down cron.
Previous 1 2 Next