Previous 1 2 3 4 Next 59 Replies Latest reply: Jan 8, 2008 5:14 PM by beatlesace Go to original post
  • jmcjr1 Level 1 (0 points)
    Had a 80 GB that would not charge in my vehicle ONLY. Apple store swapped me a new one. How great is THAT?! However, now I have this same problem. Everytime I connect it, it prompts me to register. Must be a back up at Apple. You think they could just let us know that. We'll get it...apple is huge right now and growing too fast maybe? I register every time.....
  • Billsan101 Level 1 (10 points)
    Anyone find any soultions to this problem yet?
  • Billsan101 Level 1 (10 points)
    *hmm, i see the Register Later button is temporary fix for me :)*
  • D_C_T Level 1 (0 points)
    Is it possible that 7.5 has a firm USB 2.0 requirements?

    I know the IPT is suppose to require USB 2.0 but I have heard from others in the forum that it works with 1.1, just slower.



    DCT (Dan)
  • AlistairG Level 1 (0 points)
    Likewise - keep getting asked to register and given up after 5 goes

    How many posts before someone from Apple support explains what is going on?
  • Paul Mottram Level 1 (15 points)
    I had this problem too but it went away. I don't know whether this is the reason, but I was initially calling my ipod touch a different name to an older ipod that I owned and was using with my itunes. When I called the new ipod by the same name as the old one, the problem disappeared. I don't know whether this is coincidence but it worked for me. The serial number of the new etc still comes up so I think I'm registered.
  • alliexoutrageous Level 1 (0 points)
    i have the same problem.
    i just got my ipod touch, and i registered it 4 times.
    it keeps asking me to register it, and it won't put on any of my songs.
    i'm so freaking confused.
  • jrpca Level 1 (0 points)
    Piling on. Ditto. Previously (still do) had a mini. Now itunes asks to register and reregister every time I load itunes with the ipod touch attached. Very annoying.
  • Zeffiro Level 1 (0 points)
    I posted this previously, but I Restored my iPod Touch using iTunes, and it stopped asking me to re-register (also worked on a Nano). To Restore, connect your iPod to your computer, go to your iPod in iTunes and select the Summary tab. Then click on the Restore button.
  • Roridge Level 1 (0 points)
    Me too, iTouch same thing.

    Mine also doesn't load up iTunes when I plug it in, even though I have set it too.

    argh.. annoy.. this is my first proper iPod and so far, i'm not having fun!!


    Come on Apple, fix the issue or at least provide some feedback!!
  • undftdx10 Level 1 (0 points)
    doooooode i cant even see my music!.

    and now when i connect it send me directly to the license agreement -.-

    and if i press cancel it disconnects it! -.-

    plus.. i cant even go to the far right on my itunes the writing on regestering gets cut off!

    help?
  • Huskrfj Level 1 (0 points)
    I am trying to sync my ipod touch with my itunes music library. It recognizes it by the name I gave it but every time I plug it in, I am asked to register my ne ipod. I have done this about five times as well as clicked the register later button to get to the main summary page. Click on sync button, itunes reports syncing Ipod, or says so, Stays that way for a few minutes then the ipod touch shuts itself of and the itunes reports that it is no longer syncing and just shows that it is connected. I have downloaded the most recent version of itunes, itunes even downloaded and installed an update on the ipod touch. I am running windows vista home media center. If I go under my computer it is not listed anywhere as a drive.
    Don't know if any solutions are available. This *****.
  • hammocksrus Level 1 (0 points)
    I'm having the same problem with my nano. Keep getting registration screen but most of text and some of the options like "register later" don't appear. Finally got it to show "never register" and did that even though I've already registered online. But now I can't get past the license agreement screen. I agree to it, but whether I hit cancel or save nothing happens and again part of the screen is cut off. Is there another option I'm not seeing?

    I can download music onto my device, but can't look at or manage any of it in itunes, just see the license agreement. Any help would be appreciated but it appears this is a bug that needs to be fixed.
  • bender420 Level 1 (0 points)
    Same problem here.
  • default.hostility Level 1 (0 points)
    Same problem here. Love my Touch.. everyone in the pharmacy envies it