1 2 Previous Next 29 Replies Latest reply: Mar 29, 2008 8:40 AM by Douglas Ely
MacHead1896 Level 1 Level 1 (0 points)
I use airport to connect to a netgear router.

After installing 10.5 onto my intel mac, I have been having an issue in safari where after some time (never seems to be the same intervals) my internet drops and when I re connect I get an error that says Connection Timeout until I reboot my router. I read something about something in your system files called AppleAirport2.kext but that does not seem to be the problem, as I do not have the file. Does anyone know what is going on?

Mac OS X (10.5)
  • 1. Re: Connection Timeout?
    Craig Brady Level 4 Level 4 (1,790 points)
    You list your software version, but not your hardware type. I have had a similar issue with my MacBook. The problem seemed to go away when I set my router to operate in fixed, versus mixed, wireless mode.
  • 2. Re: Connection Timeout?
    MacHead1896 Level 1 Level 1 (0 points)
    I'm using an iMac with a Core 2 Duo processor
  • 3. Re: Connection Timeout?
    MacHead1896 Level 1 Level 1 (0 points)
    Bump
  • 4. Re: Connection Timeout?
    LarryHN Level 9 Level 9 (56,670 points)
    Try Erik's solution - it fixed internet access for me -- in this thread -- http://discussions.apple.com/thread.jspa?threadID=1225208&tstart=0

    Larry:

    In my case, this is an issue with the DNS Server. In my set-up, I had a G5 with intermittent access, and a MacBook Pro & iMac G5 with no problems. There is only one difference in the configurations. The MBP and iMac had additional DNS addresses added into their network configuration from my last ISP. I had manually entered them, and never removed them. When I added the same DNS Servers to the G5, problem solved. When I removed them from the MBP, problem appears. This was not an issue in Tiger, and although I'm not sure why, I have determined a few other workarounds and contributors.

    First, in the Network Preferences, you can hit the Advanced... button and click the DNS tab to see your DNS Servers. Likely, you only see 10.0.1.1 or something similar which means the computer is getting DNS info (routing to internet servers) based on what the Airport Extreme/Express or other wireless router is sending through DHCP. If you have the actual DNS Server addresses from your ISP (or any ISP) you can add them here and probably fix your problem. Add them and click OK, followed by Apply.

    Now to the root of the problem in my case. By opening the Airport Admin Utility, and selecting my base station and clicking on the Internet tab, I can see that my Base Station is serving up two DNS Servers. One is it's own router number which falls into the 192.168.xxx.xxx range. I know this isn't a valid number. The second is the actual number from Cox (my ISP).

    So when the computer relies on DNS info delivered through Airport using DHCP, it is getting a bogus number first, but it keeps trying. Eventually, it might look at the 2nd option, which explains the delays. If you enter the DNS info directly into the System Preferences, it seems to ignore the DHCP version and go right to the site you want.

    Check with your ISP for a list of DNS Servers. Any server will work, just be sure it is from a reputable source. If your Airport shows two servers like mine, use the Network Utility to do a look-up on the non-192.168 number and see if it comes back as your ISP. If so, then you can probably just insert it as the first server on the Airport or add it to the Mac with the issues.

    I hope this makes sense and addresses your issue. It sure did help with mine.

    Erik


    Larry Nebel
  • 5. Re: Connection Timeout?
    dshillis Level 1 Level 1 (15 points)
    Try restarting in safe mode by holding down the Shift key during startup. Hold the shift key in until you reach the login screen. Login using your system password, and let it fully load. Then restart normally.

    Apple has published an article on this, in case you want to see it...
    http://docs.info.apple.com/article.html?artnum=306879

    Hope this helps...
  • 6. Re: Connection Timeout?
    MacHead1896 Level 1 Level 1 (0 points)
    Larry, I do not have an airport base station so I don't think that will work. Also, you said in the DNS tab I should have 10.0.1.1 or something like it, and its actually a 192.168 number. Does this matter?
  • 7. Re: Connection Timeout?
    MacHead1896 Level 1 Level 1 (0 points)
    Dshillis, I tried that earlier and it did not work. Thank you for the suggestion, though.
  • 8. Re: Connection Timeout?
    dshillis Level 1 Level 1 (15 points)
    OK. I've read so many multiple solutions to this problem and it not working for everyone, I'm wondering if there aren't multiple issues going on here with the wireless, and not just one issue? I tried 3 other tips in the last couple of weeks with no luck, and tried this one and it helped. My connection still seems a bit slow, but I don't get any more time outs...
  • 9. Re: Connection Timeout?
    MacHead1896 Level 1 Level 1 (0 points)
    Ok, maybe I'll try it again when I get home.
  • 10. Re: Connection Timeout?
    LarryHN Level 9 Level 9 (56,670 points)
    I am using an iMac with a netgear wireless router

    your entries in the DNS tab will be completely different (however a 192.168 is a problem - that is a local network number.

    Call your ISP and get two or three local DNS server addresses or find them on the web (for Cox Erik's document reference give nationwide addresses) and log into your netgear router admin page and set those DNS addresses rather than letting the router get them via DHCP. That was all I had to do (about a one minute fix once Erik found it for us)

    Larry Nebel
  • 11. Re: Connection Timeout?
    ErikW Level 2 Level 2 (250 points)
    192.168. ranges are generally reserved for internal use only, so unless you're running your own DNS Server, which may be the case in a large IT environment, but not likely at home, this is most likely the problem.

    As Larry states, call your ISP, or get ANY valid DNS server number and insert it into Network Preferences, click Advanced..., and select the DNS tab. The manually entered one will take priority over the automatically assigned (grayed out) number.

    It's a quick check to rule out other problems.

    Erik
  • 12. Re: Connection Timeout?
    MajikalMan Level 1 Level 1 (0 points)
    Since I installed Leopard, I seem to be having a similar issue except I'm not even on an Airport or wireless connection. I'm connected through ethernet and every few hours or so, the connection dies and reconnects soon afterward. This would only be a minor annoyance if it weren't for the fact that Mail.app completely refuses to check for new mail and simply says "Connection Failed" on all three of my accounts. The only way to resolve this is by manually resetting the my ethernet configuration in system prefs but this doesn't prevent the anomaly from occurring again. This really odd behavior. What gives???
  • 13. Re: Connection Timeout?
    Paul Craton Level 1 Level 1 (30 points)
    Larry - this looks like the problem I'm having as well (in other posts)...
  • 14. Re: Connection Timeout?
    LarryHN Level 9 Level 9 (56,670 points)
    Once again - try changing from using DHCP to get a DNS server address and add a couple or more that you get from your ISP - It is a simple thing to try and works for many people - if it does not work for you go back to DHCP and nothing has changed

    My symptoms were exactly like yours and it FIXED it instantly -- give it a try. You can NOT hurt anything.

    Larry Nebel
1 2 Previous Next