Previous 1 2 Next 16 Replies Latest reply: Apr 15, 2008 4:39 AM by Ewan Mcsween
Sally Rose Level 1 (25 points)
When I try to open the Accounts preference pane in system preferences it says "Loading Accounts..." in the header bar but nothing happens. If I again select the Accounts icon the preference pane goes blank. I have no idea when this started because I don't need to access this pane often. How do I gain access to my account setups?

iMac G4 1.25 GHz, Mac OS X (10.4.10)
  • laurafee7 Level 1 (10 points)
    have you tried restarting the machine?
  • Sally Rose Level 1 (25 points)
    Yes, many times. I have Macaroni installed which I have used to Repair Permissions and do the Unix Maintenance routines. None of this has helped.
  • Niel Level 10 (293,590 points)
    Open the NetInfo Manager in the /Applications/Utilities/ folder and look for user accounts that have no name property or for which the name property is reported as not being an UTF8 string; if you find any, create or change the name property so that it has the same value as the realname property.

    Do not delete anything in the NetInfo Manager.

  • Sally Rose Level 1 (25 points)
    I checked that folder and found no accounts with name property problems.
  • Herr Lazaro Level 1 (45 points)
    I'm suffering the same problem on my private iBook G3-600, which I finally updated from 10.3.9 to 10.4.10. Before the update Accounts Prefencepane worked at least once after lauching Preferences. In case I'd reopen Accounts a second time, it didn't load. To have it work again, I needed to qut Preferences and relaunch it.
    After updating to 10.4. Accounts doesn't open at all. The symptoms are as described above in this thread: First click on Accounts in Prefrences yields a window title "Loading Accounts..." with nothing else happening. A second click on Accounts then leads to an empty window. Trying to open Accounts from the Fast User Switching menu or by opening /System/Library/PreferencePanes/Accounts.prefPane don't work either.
    Same result when trying to use Accounts from within the root-User's account.
    Only clue so far is the following log-entry in console.log when trying to open Accounts:

    2007-11-20 23:45:30.214 System Preferences[373] * NSRunLoop ignoring exception '* -[NSCFString replaceCharactersInRange:withString:]: nil argument' that raised during posting of delayed perform with target 368e70 and selector 'setCurrentPreference:'

    BTW: Disks are checked and Permissions verified.

    Since the problem some existed with my earlier system but has increased with the update to 10.4. I assume it is related to some hidden problem within my user setup because this is the constant factor that didn't change alongside with with updated system.
    So there ought to be command line utility or other tool to verify or correct my user setup. I looked into Netinfo Manager but didn't find anything unusual.
    Any clue anyone?
  • Herr Lazaro Level 1 (45 points)
    Solved the problem for me and perhaps it helps others too:
    On my system the cause was an old user account that i had created back the days when my machine still ran OS 10.2!. The account has been created with 10.2's System Prefrences and was still valid, meanig even under 10.4 I could log into that account.
    However there must have been something with it causing 10.4's Accounts prefpane to barf!
    I simply deleted the entire user account in question with Netinfo Util and voila, Accounts prefpane loads and works again!
  • Ginny Pressly Level 1 (50 points)
    I am having this problem with one of the MACs I attempt to keep up-to-date. Like Sally Rose, it’s not something I access often, so I don’t know when it started having a problem. The computer is current on all OS updates, and I always repair permissions before and after updates, as well as run maintenance regularly. I also reset the PRAM, wondering if that would fix it.

    Since the computer with the problem had a previous user, I wondered if I could find something like Herr Lazaro found in Netinfo, but to no success. (Unlike his, no old user cold be logged on, though.)

    Under Users in Netinfo, there are a lot of strange user names, both on the problem computer and on my computer (that is not giving any problem), so I really don’t know what I should be looking for here. What does a correct “name property” look like, and what does a UTF8 string look like?

    On my computer (that is working correctly), my name property is “ginnyp”, but my realname property is my full name – “Ginny Pressly” – not the same? On the many User names, most of the name fields and realname fields are not identical, though most are similar. Specifically referring to the computer with the problem, all Users have a name and realname.

    The only thing I note when comparing the problem computer to mine that is fine, under the actual user names, the property lists are in a different order. Does this matter?

    The computer with the problem is actually working fine, but I am concerned about getting the problem fixed before I do need to access something in the Accounts preference pane.

    Any thoughts anyone?

  • TJPile Level 1 (15 points)
    I seem to recall having this problem with 10.4 early on...

    Repaired permissions.
    I deleted the following:
    Then I rebooted.

    YMMV, but that's what worked for me. I'd ask you to see if the preference pan opens inside another account, but I assume you only have one and you can't open the preference pane to create a new one. There's always the command line to do that, though.
  • Ginny Pressly Level 1 (50 points)
    Thanks for the ideas, TJPile,

    I have a question regarding the Caches – dump the whole file? Or, is there something specific? I see a couple of “” caches, but there’s a lot of other stuff in the file. I also see a “System Preferences” folder, but it appears to be empty.

    In searching through both the computer and user Libraries, I saw a file in the computer Library Preferences called “”. Wonder what happens if I would drop it, too?

    Unfortunately, do not have a second user file on this computer. Makes me think I should set up a “test” account on each computer!

    If dumping some things and repairing permissions don’t work, I’ll be considering learning the command line to open the preference pane to create a new user account

    I used to be “brave” dumping preference files in OS-9, but I’m not as bold in OS-10! Don’t have as good of understanding of OS-10 (preferences) as I did OS-9.

  • TJPile Level 1 (15 points)
    Don't delete the entire /Users/<your username>/Library/Cache folder, just everything inside it. I've done this numerous times with no, permanent ill effects. The should be OK to move to the Trash too. It's be a good idea to just move all those items to the trash and reboot. If something doesn't work right, you can always pull them back out of the Trash. Restart, repair permissions, delete (move them to the Trash) the aforementioned files and immediately reboot. After you log back in, check out the Accounts preference pane. It may work again.

    Good luck.
  • Ginny Pressly Level 1 (50 points)
    Well, I’ve been through the process 3 times. (Even did permissions repair after putting files in trash but prior to reboot. I always run permission repair off of the CD.) Didn’t seem to suffer any ill effects from dumping any of the items in the cache file, nor any of the other preference files, but problem did not get fixed. As I have been working on this computer, though, found a couple of other “funny” things . . .

    When I empty the trash, every icon on the desktop goes away for a second (like a blink), then comes back. (None of the other computers do this.)

    It will not let me put the clock up in the menu bar. (I dumped the preferences that go with the menu bar clock, but it didn’t help.)

    So, apparently there is something going on beyond the accounts pane being blank, though it would seem that dumping the system preferences would fix any of this! This is all I’ve found (so far), and the computer is still actually working OK.

    There is a command line to open the accounts pane??? Do you know it or have it handy, or know a link to it? Perhaps I ought to create a clean new user and see if these problems exist in a clean user account as well.

  • TJPile Level 1 (15 points)
    There is a way to do it in 10.4.x from the command line, but I wouldn't attempt it unless I was very familiar with the command line. You may a little afraid to do it yourself, but here is the list of commands:

    I can't take full credit for this. I found it at:

    The commands necessary to create an admin user are as follows:
    sudo -s
    niutil -create . /users/username
    niutil -createprop . /users/username passwd \"\"
    niutil -createprop . /users/username home /Users/username
    niutil -createprop . /users/username shell /bin/tcsh
    niutil -createprop . /users/username uid 520
    niutil -createprop . /users/username gid 20
    niutil -createprop . /users/username realname \"First Last\"
    ***if this property is not created, the user won't appear in the loginwindow!***
    niutil -appendprop . /groups/admin users username
    ***only for admin users!***

    These below are optional:

    niutil -createprop . /users/username hint \"password hint\"
    niutil -createprop . /users/username writerspassword username
    niutil -createprop . /users/username writershint \"\"
    niutil -createprop . /users/username writerspicture username
    niutil -createprop . /users/username sharedDir Public

    There needs to be a valid home directory, shell, and/or SharedDir for the user. A home directory can be created as easily as:

    sudo mkdir /Users/username
    sudo chown username:staff /Users/username

    Or if you want the default OS X user directory structure:

    sudo cp -rp /System/Library/User Template/English.lproj /Users/username
    sudo chown -R username:staff /Users/username
    ***(/System/Library/User Template also has other localized language templates)***

    Additional info:
    To change an admin user back to an ordinary user:

    sudo niutil -destroyval . /groups/admin users username

    Be careful to leave at least one accessible admin user, otherwise you will lock yourself out of your machine.

    after changing netinfo:

    sudo niutil -resync .

    log out and in the user you changed.
  • Ginny Pressly Level 1 (50 points)
    Thanks for the info. I definitely want to study this before I dive in (if I do), and take my time on it. Unfortunately, I’m going to have to wait until late next week to get back to this. I’ll be at a trade show most of next week. I’ll have a couple of days after I return before the user of this computer returns, though.

    Happy weekend!!!

  • Ginny Pressly Level 1 (50 points)
    Well, back to trying to solve this problem. Don’t think I’m brave enough (yet) to try using the command line approach.

    In digging around on this computer, though, I found that somewhere deep in the computer, it thinks it’s still my computer! My name is imbeded deep within the system somewhere. If I could find where this is and change it, perhaps this problem might correct itself (at least after dumping preferences and updating permissions after changing whatever/wherever it is from my name to her name)???

    When I open “Terminal,” I get the following:

    “Last login: Wed Mar 12 14:50:15 on ttyp1
    Welcome to Darwin!
    Ginny-Presslys-Computer-3:~ deborahg$”

    When I explored “Console,” I see the following line appear numerous times (with date/time changed each time):

    “Mar 12 14:50:15 Ginny-Presslys-Computer-3 netinfod local[41]: cannot lookup child”

    Anyone have any idea where my name (Ginny Pressly) might be imbeded as the “owner” instead of the person’s name who is now the user (owner)?

    (Perhaps I need to make this a new post, more specific to the "owner" issue?)

Previous 1 2 Next