12 Replies Latest reply: Dec 10, 2007 5:32 PM by al.d.
Chustle Level 1 Level 1 (0 points)
After installing Leopard I find that I have been downgraded to a standard user and there is no administrator. The accounts are locked and I cannot unlock it without an administrator logging in.

Any ideas how to get my administrator privileges back?

Thanks

MacBook Pro, Mac OS X (10.5)
  • Elrick Level 1 Level 1 (70 points)
    HI,

    I think this can be useful for your case:
    http://docs.info.apple.com/article.html?artnum=306876

    Regards
  • Chustle Level 1 Level 1 (0 points)
    The problem with this instruction is that I cannot run the Install DVD without the administrator's password, the absence of which is the problem.

    How do you "Start from your MAC OS X 10.5 Install DVD?"
  • nabilanwar Level 1 Level 1 (0 points)
    i'm having the exact same problem after leopard install. However i figured out how to boot the cd otherwise and tried to follow the instructions by resetting the root password. Only problem is that after i did that, and booted back the leopard install on the hard drive, it showed the same users on the login screen, with no option for 'root' access via 'other'. Thats where it ends for me. Repeating the process yields same result.

    btw, the other ways to boot the cd are on this link:
    http://kb.iu.edu/data/ages.html

    This is a ridiculous problem for leopard, any one whats going on here?
  • thealexness Level 1 Level 1 (70 points)
    Hi,

    I completed all of the instructions, then I logged into my account an voila! Administrator Status. But then I go to complete Instruction #9, and on the edit menu it reads +Enable Root User+, but there is still that Other icon on my login screen, but when i go to Accounts, there is no root user, is it disabled are enabled?

    Thanks,
    Alex
  • Todd McM Level 1 Level 1 (25 points)
    Was a bit more involved than the help doc.
    -Boot from Install DVD by holding c right after chime
    - Utilities menu / reset password - you need to select the proper hard drive with osx on it, and select root user from the drop down (NOT your usual account name) - Type in a password and click save. DO NOT click the button at the bottom of the window to reset.

    - Once you click save, quit the reset password utility
    - Go to utilities / startup disk
    - Select the hd you just changed the root password for
    - Click Restart
    - My computer logged straight into my normal account automatically... SO - Apple menu / log out
    - Log in by selecting "Other" and using root for the user name, and whatever password you created previously
    - Cancel all the first time startup windows and registration
    - Open System Prefrences - Accounts
    - Select your normal account
    - Check the box "Allow user to administer this computer"

    - From the Apple menu select Log Out
    - Select your normal log in
    - Viola, you now have permissions

    Regarding #9 - This IS SCARY to me. My root user did not show as being enabled either, even though we set a password for it.

    I went through the extra steps of enabling, then disabling just to make sure it remains disabled. The "OTHER" shows up on mine as well if I log out. I wouldn't be too concerned about it once you've enabled and disabled again.


    Lastly, RUN the QT and iTunes update. It "seems" to have done more than that for my MacPro.

    Good Luck People

    Message was edited by: Todd McM
  • Leslie Gill Level 1 Level 1 (15 points)
    Regarding disabling, I followed the apple instructions but in the edit menu in the directory utility, but it didn't have a menu item for disabling root access. It only had enable root access which didn't seem to do anything when I selected it. Has anyone else had the same problem?
  • Elrick Level 1 Level 1 (70 points)
    Hi,

    You should open the padlock on the bottom left corner before to get the enable \ disable root highlighted on the drop down menu.
  • holls at whidbey Level 1 Level 1 (0 points)
    For whatever reason, I wasn't able to get "Disable Root" to work (even after clicking on the lock and entering an admin password).

    At this point, with my main administrative user back, and most of my applications and files restored that seems like a minor problem.
  • nabilanwar Level 1 Level 1 (0 points)
    i still have the same exact problem with no solution in sight. The 'Other' account still remains, with no way of turning it off.
  • William Lloyd Level 7 Level 7 (20,980 points)
    Boot with the option key held down and select the CD. Or boot with the C key held down.
  • Gabriele Corcos Level 1 Level 1 (5 points)
    Thank You THank YOu Thank you.
    After two hours of insanity I came across your post,
    finally able to update leopard...problem seems to be fixed..
    again,
    thanks
  • al.d. Level 1 Level 1 (0 points)
    hey, i'm having the same problem but when i startup from the install disk to reset the password my hard drive doesn't come up as an option, only the dvd... help!!

    beware - i don't really know how to use terminal or single user mode properly...

    thanks!