Skip navigation
This discussion is archived

Clipboard (copy and paste) functionality not working

2781 Views 12 Replies Latest reply: Jan 1, 2008 9:57 AM by IPingUPing RSS
markman-Detroit Calculating status...
Currently Being Moderated
Nov 10, 2007 5:22 AM
Recently upgraded to Leopard and I am experiencing major clipboard problems. Basically, I can not copy and paste anything without issues. Examples - trying to copy any content is any Microsoft Office (2004) application does not keep data in the clipboard. Error messages include "Could not empty clipboard" and "not enough memory or disc space available". I can not copy URLs from the address bar in Safari and paste them into a new window. I can not copy or move files in Finder. If after copying text, I go to Finder and select "show clipboard", nothing is there.

This problem exists if I try keyboard shortcuts or use the pull-down menus.

This is obviously a major hinderance to getting any real work done.
MacBook Pro 17" - 2.4 GHz Intel Core 2 Duo, 4 GB RAM, Mac OS X (10.5)
  • Francine Schwieder Level 6 Level 6 (19,000 points)
    My experience with the Leopard clipboard has been pretty erratic. Sometimes it works fine: you copy something, you can paste it, if you look at the clipboard you can see the item on it. Sometimes it doesn't work: you copy and nothing happens, there is either nothing on the clipboard and it says so, or it says contents are unknown. Sometimes it shows nothing, but does correctly say what should be there (picture or text) and it will paste even though nothing is showing. Relaunching the Finder from the Dock will sometimes bring the functionality back (hold the option key down and click on the Finder's icon in the Dock, then select Relaunch). I don't know what is going on with this.
    Francine


    Francine
    Schwieder
    2x2.66 Dual Core MacPro; iBookG4; iPod, Mac OS X (10.5), Cinema Display, Wacom Tablet
  • nschemmaster Calculating status...
    this is a nightmare. I have no drag and drop or cut and past functionality at all. Basically this has crippled any ability to move folders, copy or paste files or drag things to the trash. I cannot even copy or paste text!
    mac book, Mac OS X (10.5)
  • cameronr Calculating status...
    I have the same issue. The last cut and paste brought my machine to a crawl, allocation 10GB+ of Virtual Memory. (from top -o cpu)
    15" 2.33 GHz Intel Core 2 Duo, Mac OS X (10.5)
  • mcdavis42 Calculating status...
    I have also lost my clipboard functionality now. Applications do not appear to be a part of the issue, as regardless of what app I copy from or attempt to paste to, all I ever get on the paste operation is a single *

    Does not matter how I attempt to access the command (keyboard, context menu, or menubar).

    I performed an upgrade from 10.4 to 10.5 day of release. I installed the 10.5.1 update the day it was released on software update.

    Significant impact on my ability to get things done.
    MBP Core2 15", Mac OS X (10.5.1)
  • scooter77018 Calculating status...
    This did not work for me...i went through all the steps except repair disk because nothing was found during verify disk....so the button wasn't even available. Still having the same problems...
    iMac, Mac OS X (10.5.1)
  • gigdiary Calculating status...
    I've got a similar problem. No cut, copy or paste functions, menu or keystrokes.
    I tried all the steps you listed, except the repair disk option,
    as the repair disk button was grayed out.

    I restarted, rebooted etc, nothing, still no copy and paste. help!!!!!!!!!!!
    G3, Mac OS X (10.4.9)
  • Francine Schwieder Level 6 Level 6 (19,000 points)
    Currently Being Moderated
    Nov 24, 2007 11:31 AM (in response to gigdiary)
    You can't repair the desk you are booted from. If verify disk didn't show any problems, then it probably didn't matter. However, if verify disk did show a problem, then you need to boot from the install disk, check your language, then go to the menu bar and select Disk Utility and run Repair Disk, and restart.
    Francine


    Francine
    Schwieder
    2x2.66 Dual Core MacPro; iBookG4; iPod, Mac OS X (10.5.1), Cinema Display, Wacom Tablet
  • ragatep Calculating status...
    Followed the sequence:


    Disk Utility...

    Verify disk
    Repair disk
    Verify disk permissions
    Repair disk permissions

    Reboot....

    And it worked perfect. Thanks you....
    Mac Book Pro, Mac OS X (10.5.1)
  • David Cross Calculating status...
    Currently Being Moderated
    Dec 26, 2007 4:35 PM (in response to ragatep)
    I experienced this problem after installing some Logitech software for a universal remote. The installation process required my administrator password, which I did not like. Logitech has a reputation for troublesome installs. At any event, I lost the ability to copy and paste. Nothing would go to the clipboard. I also noticed that I could not drag an application from a mounted disk image to the Application folder.

    I tried the permission repair/disk repair/restart routine with no effect. Since the problem began after installing software, I suspected a problem with update of prebinding. This Terminal command followed by a restart, did the trick and restored copy/paste at once:

    sudo update_prebinding -root / -force


    Message was edited by: David Cross
    MB Pro CD2, PM G5, iBook, Mac OS X (10.5.1)
  • IPingUPing Calculating status...
    Had this problem and curiously I had the Logitech software as well. I was able to resolve it by only running repair disk permissions. Another thread on the topic is at: http://discussions.apple.com/thread.jspa?messageID=6231096#6231096
    MacBook Pro 15" 2 Ghz, Mac OS X (10.5.1)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.