6 Replies Latest reply: Jan 6, 2008 6:40 AM by Marktryingtohelp
Bruno Jacquet Level 1 Level 1
Every time I try autofill Safari pop a message saying the info does not match what I got in the adress book and i does not recover any info including the passwords for specific website. It actually does not ask me to store a new password. Can somebody help me with that.
Thanks

Power book G4 digital audio 733Mhz, Mac OS X (10.4.2)
  • indigo2012 Level 1 Level 1
    expertise.macosx
    Mac OS X
    I am having the same problem
  • Roger B Meadowcroft Level 1 Level 1
    Yeah similar here too. If the site is already saved in autofill then it autofills Name but not password, and although it prompts to save the input password it doesn't subsequently use it when I navigate back. When using 'new' pages Safari doesn't even offer to save name and pword. I've seen other threads with the same issue and non obvious solutions forthcoming. It might be time to migrate to Firefox.
  • Roger B Meadowcroft Level 1 Level 1
    Bump.

    Anybody heard anything about a fix?
  • jeremyweiss Level 1 Level 1
    Ok, I just think I found a solution, but it's less than ideal. First step is to open Keychain Access in Utilities. On the left, click Passwords -> Internet and then select all passwords by clicking the first then shift-clicking the last. Then...hit Delete. I told you it wasn't pretty. My passwords are autofilling now, but I have to fill them all in again. Oh well. Good thing I use the same three for everything! If anyone else is brave enough to try this please say if it works.
  • Elstro Level 1 Level 1
    Open the Keychain Access application in your Utilities file.
    Click on "Passwords" in the "Category" window
    Under the "Names" column, scroll down to "Safari Autofill" and double click
    Select the "Access Control" option at the top
    Click the "Allow all applications to access this item" radio button
    The application will ask for your password before saving.
    This should provide access in Safari to the passwords in your keychain.
  • Marktryingtohelp Level 1 Level 1
    go to safari in finder>get info>and turn off open using rosetta and it solved my problem with passwords not going into autofill forms.

    what other problems this will cause with flash i'm not sure.