Previous 1 2 Next 16 Replies Latest reply: Jun 17, 2008 11:24 AM by JB2801
jpuleo Level 1 Level 1 (0 points)
itunes 7.5
When I connect my iphone I get an error in iTunes saying: "This iPhone cannot be used because the Apple Mobile Device service is not started." When I run services.mcs and try to start the service I get a prompt saying "The Apple Mobile Device service on Local Computer started and stopped." I have tryed removing Apple Mobile Device service and reinstalling iTunes and I get the same results. Someone please help, what good is an iPhone that I can't sync.

dell inspiron 9300, Windows XP
  • jpuleo Level 1 Level 1 (0 points)
    I get the following error in the application event log:
    The description for Event ID ( 0 ) in Source ( iPod Service ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: Service started.

    Message was edited by: jpuleo
  • mmp1152 Level 1 Level 1 (0 points)
    I have the same problem. The Apple Mobile Device shows up as stopped. When I try to start it stops immediately. I'm trying to set up my new iPhone but can't due to this problem. I uninstalled iTunes and reinstalled it (7.5) from the Apple site but the problem persists.
  • Lawrence Finch Level 7 Level 7 (32,290 points)
    Try this:

    1. Uninstall iTunes; do not reboot when prompted
    2. Uninstall Apple Mobile Device Support
    3. Uninstall Quicktime
    4. Reboot
    5. Delete the 2 Quicktime files in c:\Windows\System32
    6. Reinstall iTunes 7.5 (you should not need to reboot)

    Just uninstalling iTunes does not remove a broken Apple Mobile Device support driver; you have to do that separately. Uninstalling Quicktime assures you have the latest version of it when you reinstall.
  • mmp1152 Level 1 Level 1 (0 points)
    I followed these instructions precisely. The Apple Mobile Service is still stopped and won't start. Dead end.
  • Lawrence Finch Level 7 Level 7 (32,290 points)
    I've now exhausted everything I know about this problem. You might want to call 800-myiphone for help or visit a Genius bar.

    One other thing I would do if it were mine is to run a good registry repair program. I like Registry Mechanic. But this is a little risky if you have no experience with such tools.
  • mmp1152 Level 1 Level 1 (0 points)
    Solved the problem by uninstalling McAfee but I'm not sure if I should reinstall it now or go to another, more compatible virus protection/security package on my XP computer. Any recommendations?
  • Lawrence Finch Level 7 Level 7 (32,290 points)
    It sounds like McAfee was blocking the connection. You may be able to configure it to allow it.

    I don't particularly like McAfee, I like Symantec (Norton) even less. I'm currently using PC-Cillin (Trend Micro). But check the McAfee site for a workaround. Or look for the "white list" of allowed applications.
  • jpuleo Level 1 Level 1 (0 points)
    I finally got mine to work by installing iTunes 7.4. I also have McAfee I think that sounds like to common thread. If anyone has any ideas on how to resolve this I would like to reinstall 7.5.
  • daccad Level 1 Level 1 (0 points)
    I think I have just experienced the same problem. This happened to me just after McAfee security Center updated itself - some kinda weird co-incidence?

    The way I got it to work again is to:

    1. Right click "My Computer"
    2. Left click "Manage"
    3. Double click "Services and Applications"
    4. Double click "Services"
    5. Locate and Double click "Apple Mobile Device"
    6. Change Startup type from "disabled" to "automatic"
    7. Click apply, then OK
    8. Click "Start" the service
    9. Locate and Double click "iPod Service"
    10. Change Startup type from "disabled" to "automatic"
    11. Click apply, then OK
    12. Click "Start" the service

    Re-boot, and hey presto everything works again, or it did on my laptop.

    Kinda weird?

    Cheers,

    daccad
  • Sunnybsl2005 Level 1 Level 1 (0 points)
    Hi,
    My laptop running a 32 bit window vista operating system. Turn off UAC, uninstall virus software, re-install latest iTune, Apple mobile device service running,USBAppl.sys in place....but OS prompt USB device attached has malfunctioned and windows cannot recognize it. Try manually update driver but windows prompt not compatible.

    Don't know what else to do....can anyone help?
  • Jay-hai Level 1 Level 1 (0 points)
    Watch out for McAfee!
    If you have it, right click on the McAfee logo in the system tray, then select Firewall Settings. Select the Internet Applications tab and you'll probably see that Apple Mobile Device Service is blocked. Switch it to Full Access. It will work fine.

    Had to work this out Xmas morning. Apple suggests uninstalling / reinstalling. Check firewalls first!
  • psyclone56 Level 1 Level 1 (0 points)
    Same thing here - spent an hour on Christmas figuring this out. As usual, Apple Support is not very helpful at all. Thank goodness for the discussion groups.

    Specifically, under McAfee Firewall Program Permissions settings, Apple Mobile Device Service has to be set to "Full Access" - not just "Outbound Only" ('outbound' works on iPod Nano). I don't like giving any app full access through my firewall, but it's apparently the only way the new iTouch will work.
  • Paul Shaver Level 1 Level 1 (0 points)
    all you have to do to fix this is to go to add/remove programs (if ur using a PC) then click on apple mobile device service then click change... thats it, its a snap
  • iPvvnagde Level 1 Level 1 (0 points)
    yeah im getting the same problem does anyone know how to fix it
Previous 1 2 Next