Previous 1 2 Next 23 Replies Latest reply: Aug 16, 2008 4:31 AM by skerby
Debmented Level 1 (0 points)
"An Ipod has been detected, but it could not be identified propoerly. Please disconnect and reconnect the Ipod, then try again."

This is the message that pops up in Itunes whenever I plug in my Ipod.

My friend gave me their Ipod Nano 2G (1st Gen), and I installed the disk and everything. The computer recognized it as an ipod, then I upgraded to Itunes 7.5. Itunes just pops up the message, and now my computer doesnt see it as an Ipod.

I've tried EVERYTHING on this website, EVERYTHING. I've searched through all the posts and can't find anything. I am getting sick with trying to get this Ipod to work.

Hp notebook, Windows XP
  • Kaleb Wyman Level 1 (5 points)
    I'm having the exact same problem... and I just purchased a brand new iPod Nano 4 GB (3rd Gen) today from the Apple Store.

    It connected fine at first. But after I used Software Update to update my PowerBook G4 to Mac OS X 10.4.11, Quicktime Pro 7.3.0, and iTunes 7.5... that's when the endlessly looping, useless error message began.

    "An iPod has been detected, but it could not be identified properly. Please disconnect and reconnect the iPod, then try again."

    Following the instructions in this error message frustratingly does nothing.

    The iPod mounts to the desktop at first, then immediately disappears / disconnects with the launch of iTunes, and pops this same useless error message up again. ***!

    I followed all of the recommended "5 R" techniques from the iPod help site for this model... I reset the ipod to the default settings, restarted the iPod, restarted my computer, re-installed iTunes 7.5 from standalone download... I tried everything, nothing worked.

    So... I tried connecting it to my wife's MacBook Pro. It connected fine with iTunes 7.4, and so I used it to reformat the iPod Nano with the iPod Restore feature. Then I tried to connect back to my PowerBook G4... no luck.

    My PowerBook G4 with iTunes 7.5 still fails to recognize my iPod Nano any longer, and I keep getting the exact same error message.

    I figured maybe it had something to do with being formatted for an Intel Mac or maybe just for iTunes 7.4, so I decided to try connecting to a PowerMac G5 with iTunes 7.5 to confirm this.

    But the G5 recognized it just fine, no problems... What the ****!

    This test confirms that it's not a problem between Intel Macs and PPC Macs, and it's not an iTunes 7.4 vs. iTunes 7.5 problem...

    I am flustered and completely baffled. Why the heck would it work on a MacBook Pro with iTunes 7.4 AND a Powermac G5 with iTunes 7.5, but NOT on a PowerBook G4 with iTunes 7.5?

    There must be some ridiculous conflict of settings or a preference file that needs to be deleted from my laptop, that's the only thing that I can think of. If it connects fine to other machines, and not to this one, my laptops settings must be the problem.

    My wife bought the exact same model of iPod Nano today too, I then tried connecting it to my PowerBook G4... and that didn't work either! AHHHHHHHH!

    Well, I have scheduled an appointment at the Apple Store Genius Bar for tomorrow, I'll let you know how it goes.
  • Paul Wang Level 1 (0 points)
    Hi I have the same problem on my main computer (powermac G5) after upgrading my itunes. I tried my ipod on my old ibook just to see if my ipod works on there and Im connected. So I try a restore (on the laptop) on the ipod (erases and restores to factory settings while updating firmware for ipod) and connect to back to my main computer and still more of the same... except now I have no music on the ipod.

    I guess I can upload all my music to my laptop and just sync my itunes from there but I dunno, its a bit of work and I dont want to have to use my laptop just for music. My main should be good enough.

    Does anyone have any more workarounds? Im thinking Id probably have to wait til the next update for a fix but hoping someone finds something.

    Have you tried connecting to another Mac Debmented?
  • mpage_colo Level 1 (0 points)
    I've been following this forum for a few days now hoping someone would post a solution ... but hasn't happened yet.

    So after 2 days of the same error msg and nothing I could think of working I went to see a Mac Genius too. The Genius tried every trick he could think of to no avail but finally sent me home to reinstall the Mac OS ... preserving user data as part of the process.

    After this my iPod synced up w/o problem.

    However, now my mac is somewhat hosed. Cisco VPN no longer works for me. Theer may be other problems yet to be uncovered and perhaps I just need to install a new copy of VPN.

    But my new iPod Classic is finally functional.
  • QUiSHi Level 1 (0 points)
    I have the same issue. brand new macbook, worked fine with my iPods until I updated OSX to 10.4.11 and iTunes to 7.5 and get the error message. If I completely remove iTunes and roll back to 7.2 I can see the ipod (both in finder and other progs e.g. YamiPod) but it loaded songs wont play. I have no problem when plugging them in to a Windows machine with iTunes 7.5, but as soon as I update the mac to iTunes 7.5 iPods wont show in finder or iTunes. This is really frustrating. Any news on an Apple fix for this?
  • Kaleb Wyman Level 1 (5 points)
    Well, I have an update regarding this issue.

    As stated before, I can get my iPod Nano to mount on the desktop of my PowerBook G4... but right after iTunes auto-launches, it unmounts the ipod and throws the error message "An iPod has been detected, but it could not be identified properly".

    By leaving the iPod plugged in, I was able to bypass iTunes and mount the iPod Nano on my PowerBook G4 desktop. After the error message above, I left the iPod plugged in, but removed the headphones. Eventually the iPod mounted on the desktop without re-triggering iTunes to launch (which causes unmounting because of this undocumented updater problem in iTunes 7.5 (19). Unfortunately, this is only good to transfer text files or data... launching iTunes unmounts it again.

    So I went to the Apple Store in Palo Alto... no luck at the "Genius Bar".

    I told them that I had no problems hooking up this brand new iPod Nano to my computer before the 10.4.11 update which included iTunes 7.5... but their response was that there are no reports from Apple on this issue, so their final recommendation was to do an Archive & Install of Tiger.

    They pointed the finger at third party applications...

    My response was, why would you blame third party applications to cause this to stop working, if it stopped working after the update from Apple, not from a third party?

    They said a third party app probably works differently now and must be conflicting.
    (What a load of B.S. I really don't want to reinstall all of my applications... especially ZBrush, which took forever to get licensed properly through Pixologic.)

    Has anyone actually done an archive & install to successfully fix this problem?

    What I don't understand is, how would this fix a problem caused by the latest Mac OS X and iTunes update which is bound to be installed once Software Update kicks in after the archive & install anyways. Wouldn't reinstalling all of my third party applications back onto my system cause the same problem, if it truly is a third party application issue? Uuuuuuuuugh.

    Message was edited by: Kaleb Wyman
  • Debmented Level 1 (0 points)
    Unfortunatly, I dont have a Mac to hook up to and neither do any of my friends. I will try to plug into one of the macs at my school though.
  • paddydiowa Level 1 (0 points)
    I've just installed Leopard and it seems to have solved the problem.
  • apps54 Level 1 (0 points)
    Any fix yet for this?
    I'm having this problem with 12" Powerbook running OS 10.3.9 and iTunes 7.6 (didn't work for 7.5 either).
    The Nano works on my PC (but no music there).
  • apps54 Level 1 (0 points)
    I've tried two 1st generation nanos -- same problem. I also restored to factory settings and it did not help.
  • Kaleb Wyman Level 1 (5 points)
    Apple also says reinstallation of 10.4, Archive and Install, will fix this problem.

    That's way too much hassle... I wish Apple would just pinpoint the issue and release a patch for it in the ipod software / firmware itself.
  • Marc Morris Level 1 (95 points)
    After giving up on my 3rd generation iPod which died yesterday, today I went and purchased a brand new 80GB Classic. And guess what? It's not working!

    I'm also getting the "An Ipod has been detected, but it could not be identified properly" message. I called Apple and they were no help at all. They said to take it bak and get another iPod!

    Does anybody know what is causing this? Is it some sort of conflict with my old iPod settings perhaps?

    I'm not impressed at all.
  • Kippy99 Level 1 (0 points)
    I had the same problem, but I hope this may help... I have a IPOD Nano 4gb and kept receiving that message. After hours of trying to figure it out, I finally realized I had a movie in my CD-Rom. I took out the CD and it finally started my ipod up again, although it said it was corrupted and needed restored. So I simply clicked the restore button and resynced and it worked. I would recommend just unplugging or taking out any other device that is in you computer because for some reason that seems to mess it up. Hope this helps!
  • umatic Level 1 (0 points)
    Yes same problem here with my 5th gen ipod! Maybe if enough of us post, Apple will actually DO SOMETHING ABOUT IT!!!

    Have just got a MacPro 8-core/10.5.2. ipod won't sync with the above error message, even though the ipod software is up to date. 30 mins of messing about with an AppleCare engineer got me nowhere. They are completely clueless - suggested re-formatting the ipod and various other nonsense that clearly won't work.

    A workaround I found was to dump itunes 7.6.2 and install a version 6 copy. The ipod synched-up and worked fine inside iTunes. However, the Ipod cannot be ejected properly - it keeps remounting itself on the desktop.
  • switchkosterice1 Level 1 (0 points)
    having the same problem. posting to gather more attention to the issue. this *****.
Previous 1 2 Next