Previous 1 2 Next 17 Replies Latest reply: Feb 29, 2008 6:03 PM by john j T
Patfitz Level 1 Level 1 (0 points)
I just bought a 24" iMac last week. This is my first mac and I don't have any old software/files on this machine. This is about the 4th time my mouse has frozen within the one week I have owned the machine. The keyboard works fine. Both keyboard and mouse (stock mighty mouse USB) were plugged into individual USB ports on back of iMac. The keyboard works fine even though the mouse is frozen. I can only restore mouse function via a reboot.
I have tried unplugging/replugging the mouse but to no avail. I have just moved the mouse to the keyboard port (never knew that was there until tonite) and will monitor.
Is anyone experiencing this?
and
Does anyone know how to restart the mouse process.

I have had a similar issue with loss of audio. For no apparent reason I completely lose all audio. By restarting the coreaudservices process I can recover audio. Annoying but at least fixable without a reboot.

24" iMac
  • clintbradford Level 3 Level 3 (905 points)
    If I were you, I'd be on the phone with Apple and working on receiving a replacement unit.
  • Patfitz Level 1 Level 1 (0 points)
    I trolled the console logs to around the timeI had the last feeeze and here are a couple of hints that this may be related to sleep/wake on my iMac. I'm going to disabling sleeping for now to see if that improves anything.


    11/10/07 8:07:08 PM kernel System Sleep
    11/10/07 8:19:36 PM kernel System Wake
    11/10/07 8:19:36 PM kernel AppleYukon2 - en0 link active, 100-Mbit, full duplex, flow control disabled port 0
    11/10/07 8:19:39 PM kernel AppleUSBHub::setPowerState(0x4102600, 2 -> 4) timed out after 10421 ms
    11/10/07 8:19:39 PM kernel EIR is not supported.
  • schmed Level 1 Level 1 (10 points)
    I have the same problem, and as others have reported, I generally find mouse tracking in Leopard far inferior to Tiger.

    I called Apple today, and the representative suggested that I reset my PRAM (based on a non-Leopard-specific, and as of today still marked "not answered", forum posting: <http://discussions.apple.com/thread.jspa?messageID=5544493>). I did so and so far the mouse hasn't frozen. The mouse is tracking acceptably now as well, though I'm unsure whether any of this is going to last.

    I'd be interested in hearing from others who try to solve this by resetting their PRAM.
  • myflatsix Level 1 Level 1 (0 points)
    I owned my new 24" iMac for four weeks with no problems - it crashed once. I upgraded to Leopard then every time I tried to switch my Screen Saver, the computer would completely freeze up or go to a blue screen. Apple Care had me reset the PRAM and that took care of the problem.

    Now, my mouse freezes about 50% of the time when my computer comes out of sleep. I still need to call Apple Care to rectify the problem. It sounds to me like Leopard is full of bugs. Hopefully this first update will alleviate some of them.
  • Robert&Mieke Level 1 Level 1 (0 points)
    I have the same challenge. The wireless mouse freeze. Most of the time after the system came out of the sleep mode. To solve it, I have to do a hard reset. Reseeting with the software is not possible. I called Apple for over hours on this challenge but I was informed that my mouse might be broken. Given the system I have is 2 months old, it all worked fine in 10.4 and suddenly changed with 10.5, I do not believe it. I will get a new mouse from Apple and will test it. Personally I believe it is a bluetooth software challenge. There are to many people with the same problem. There is not a way to send Apple a problem report and hope they pick this up from the form and do a check of the system and send an software update. this way, it is hard to work on the Mac.
  • jempixa Level 1 Level 1 (0 points)
    I'm having the same problem. After I installed the update for leopard. My wireless mighty mouse has been freezing a lot. Mostly after it is woken from sleep.
    I really hope Apple does something about this soon.
  • Trevor Jacques Level 1 Level 1 (10 points)
    Mine, too. I've just deleted my caches to see if that's the problem. I want my stable iMac back. I;m seriously considering going back to Tiger.
  • Gus Skink Level 1 Level 1 (0 points)
    Same as above, and no solutions found elsewhere.

    It is my first week since switching over and I am not too impressed.

    Haven't tried support given the posts here.
  • eenduiker Level 1 Level 1 (0 points)
    My Mini C2D + Leopard also has a mouse freeze issue. After a sleeping or just the screensaver coming on it almost always causes the mouse to freeze. It happens with the Wireless Mighty Mouse and a Wired USB Mouse. Haven't tried them both together . Its real annoying as a Hard Reset is needed to get the system back up. The Mini was upgraded to Leopard with a Drop-in DVD that came with it.
  • naq59 Level 1 Level 1 (15 points)
    I´ve got the same thing but funnily enough, if you connect Logitech USB mouse then, that works fine and after some time (20 minutes+) the optical mac mouse comes back to life! I also phoned Mac Hotline and tried all their ideas but nothing helped. I guess it´s a OSX 10.5 bug that´ll need fixing.
  • Stephen Wonfor Level 1 Level 1 (0 points)
    20" iMac 10.5.1. machine a week old. A client reported that in Leopard her mouse froze (Logitech trackball). She tried the Apple mouse - same thing. Tried all USB ports. She was able to restore is by going to another identical machine and using Screen Sharing to move the mouse. It worked. This may be 1) coincidence or 2) a lame but effective fix.

    Stephen
  • BYODKjiM Level 1 Level 1 (0 points)
    I had the same problem and found the answer in another mac-related forum on the internet:

    <http://www.mac-forums.com/forums/showthread.php?t=49>

    Check your System Preferences for Universal Access. Leopard seems to come with the Mouse Keys function enabled. When you press "0" the keypad controls the mouse until you press "5". Turning Mouse Keys off in the System Preferences eliminates the problem.
  • realtimerender Level 1 Level 1 (0 points)
    same problem, but i looked at universal access and mouse keys are off. never tuched that preference pane before. didnt work for me..
  • Burndog Level 1 Level 1 (5 points)
    I have had wireless MM freezing and have tried everything (awake setting, 2 soft installs, 1 hard/erase install, etc) under the sun. Bottom line, Apple Care can't help and doesn't know what to do, other than to login and read forums back to you on the phone. EVERYONE, please send feedback to the following: http://www.apple.com/feedback.

    Apple needs to do an upgrade to repair this "glitch" in OSX (Leopard specifically). They are not responding to the needs for hard working people who pay premium for there product. Attn Apple: Don't make the same mistake you did in the '80's...listen to your paid customers.

    Burndog
Previous 1 2 Next