13 Replies Latest reply: Apr 12, 2008 7:34 PM by SeattleMo
Jaxboro Level 1 Level 1 (5 points)
I'm getting an error when I open Itunes since I upgraded to 7.5, I didnt see my specific error covered in previous threads.

It says that the file "iTunes Library" cannot be read because it was created by a newer version of iTunes. The box has an ok button, which i click, and it the program closes without ever opening.

Its a very odd error becase my Library was created using older versions of iTunes, and the newest one is having an issue with it when I click on the iTunes icon.

The funny thing is...if I go into Music > iTunes >iTunes Music and click on a song that's there, iTunes opens up just fine, and all my libraries are there, just like it should be.

Anyone got any ideas on how to make my iTunes open normally again?

G4 iMac, Mac OS X (10.4.10)
  • Yogananth Level 1 Level 1 (0 points)
    I do face the same problem.

    Could anyone please help us on this regard.
  • katyeatman Level 1 Level 1 (0 points)
    same thing happened to me, out of the blue.
    I fixed it by putting the itunes icon in the trash (the one that wouldn't open) then I went to applications>found another itunes icon>drug that to my desktop and presto! It opened fine!
  • Vince Burn Level 2 Level 2 (160 points)
    You can try to remove your
    iTunes Library and/or iTunes Music Library.xml file.

    But that way you would lose your playlist.

    You may need to drag the content of your iTunes Music folder back into iTunes so
    it can make a new iTunes Library data file.
  • cypressdrive Level 1 Level 1 (5 points)
    Brilliant. I'd forgotten this as a potential fix. I remember having the same problem with Mail a while back and stumbled on the delete and add icon trick. Thanks
  • Mike_Fuji Level 1 Level 1 (0 points)
    I have had a similar problem. I was experimenting with creating a new iTunes library (press and hold Option key while clicking on iTunes icon) with iTunes v7.5 on my Mac Pro. When I decided to reselect my current iTunes library ("iTunes Library") I received an error message that it could not be opened because it had been created by a newer version of iTunes (presumably v7.6). I was able to open the previous iTunes library, but lost some recent entries.

    I checked the iTunes program version and it was still 7.5. When I checked for updates I received a message that iTunes v7.6 was available. When I tried to install v7.6 it I received a message that my software was up to date. I restarted iTunes, but it still indicated that it was v7.5.

    I downloaded iTunes 7.6 and again tried to install it. The installation completed normally. When I subsequently started iTunes again and checked the version it indicated that it was version 7.5!

    Does anyone know what is going on??
  • Mike_Fuji Level 1 Level 1 (0 points)
    I should have read the suggestions before posting. I originally moved iTunes onto my desktop. When I opened the program using that icon it opened as v7.5. I moved that icon to the trash and made an alias of the iTunes program I found in the applications folder. I moved the alias to the desktop. When I opened iTunes using the new alias it opened as v7.6. I also replaced the iTunes icon in the Dock with the new one.
  • John Huh Level 1 Level 1 (65 points)
    I experienced the same error message.
    Downloaded the latest version of iTunes (Mac) and reinstalled. But this didn't solve anything either.

    Going into Applications and launching iTunes worked ok, however launching from the Dock gave the same error message.
    Just removed iTunes icon from the dock and added again. This worked.
  • np3 Level 1 Level 1 (0 points)
    I experienced the same error message. Up until this morning, I was running the latest version of Tiger with all available updates (i.e., the latest version of iTunes). I did an archive & install of Leopard this afternoon. When I went to open iTunes, I got the same error message you did. When I googled that error message, it brought me to this thread, so I tried removing the icon from the dock and opening it from within Applications. No dice. I navigated to my Previous Systems folder, and opened iTunes from within the Applications subfolder in there. Everything opened perfectly. So in my case, it does have to do with the version of iTunes running. I'm in the process of updating iTunes in my current Applications folder now.
  • GregSJP Level 1 Level 1 (0 points)
    Hi,
    Here's another potential solution to this problem. While holding down the Opt key, click on the iTunes icon. This forces iTunes to ask for a new iTunes folder. When prompted, find the iTunes folder on your system (usually in the Music folder) and select it. I tried a number of other suggestions and this was the only one that worked for me. Hope this helps.

    Best Regards,
    Greg
  • Starfishbysea Level 1 Level 1 (0 points)
    I just had the same problem occur. I tried troubleshooting it, but I can't even get Itunes to open without downloading it again. The last time I did this during a previous updgrade everything was deleted from my library and after working with Apple we couldn't retrieve the info so I had to start from scratch again.
  • Mary Daykin1 Level 2 Level 2 (390 points)
    I had the same problem and did what you said which was brilliant but can you tell me how you updated it in your current applications folder please
  • Rjrsmith Level 1 Level 1 (0 points)
    I re-created my library (I didnt have a `previous system' folder to restore from) and the problem is no more. Also, my playlists are intact.

    http://docs.info.apple.com/article.html?artnum=93763
  • SeattleMo Level 1 Level 1 (0 points)
    I had the same error message when I transferred my iTunes music from my old iMac G3 with OSX 10.3.9 to my new Intel iMac with OSX 10.5. I did this using my old iMac as a Firewire Target Disk.

    I fixed it by downloading a new version of iTunes 7.6.2, from the Apple website. Just took a minute, and when I clicked the iTunes icon, there was my old iTunes library.

    Message was edited by: SeattleMo