7 Replies Latest reply: Apr 17, 2008 9:26 PM by rjsnz
frankle Level 1 Level 1 (5 points)
After purchasing the new Airport Extreme Gigabit I must say I am rather impressed. Coming from the Netgear WNR854T which had several firmware issues (dropping wireless, dropping all connections, say "boo" and it would crap itself and need a hard reset) I am very pleased with the ease of setup and use, especially the Airport Disk, great feature, and I also hope to add a USB hub and printer in the next week.

Now to my only real issue with this great product, it is having problems with FTP in that it will not allow an incoming request for a directory list. To clarify, when you login via Cyberduck it will point you to the right directory but will not give you the content contained in it.

I have narrowed it down to the AEBS due to the fact that I have 2 computers with FTP software, a PC running Serv-U and a G4 running Pure FTPd Manager, and the same problem occurs no matter which computer I forward port 21 and 20 to. This issue is not there with the WNR854T (I still have it, I can't part with it just yet) so it must be the AEBS.

Can anyone help me with this, maybe explain their setup with the AEBS that is currently working?

Thank-you.

PB G4 15" 1.5GHz, MB C2D 2.0GHz, Mac OS X (10.4.10), Old but good & new but white!
  • 1. Re: Airport Extreme & FTP
    impulse_telecom Level 3 Level 3 (635 points)
    FTP can be somewhat tricky to port forward.  I have an AEBS, but haven't experimented with allowing in-bound FTP into my network.

    Try checking the connection coming in to see what mode FTP is using.  Passive mode usually works better than active mode when you have to traverse a firewall.  For most all FTP clients other than Microsoft's command line version FTP client, passive mode is the default.

    If possible, pick FTP as an application you want to forward, rather than just listing ports 20 and 21.  The router needs to be able to associate the data and command channels of the FTP session as two parts of the same logical conversation.  Apologies in advance, if you already did it this way.

    The other thing that might be getting in your way is the MTU size is too big.  It could be that usually the packets are under 1500 bytes until you list a big directory and then that takes several packets to send the listing. That long directory listing may be lost if its consecutive full 1500 byte packets can not be fragmented and correctly reassembled as they traverse the route. This can be tough to trouble-shoot as the packets my be silently dropped somewhere mid-route.

    You may need to try setting the MTU size on your broadband router and/or the computer hosting the FTP site.  Try setting to 1300 for the MTU and work your way up towards 1500 until you find the biggest MTU packet size that works.  I've found that DSL links occasionally need MTU manually set to less than 1500.  MTU should be auto-probed, but apparently that isn't always reliable.

    Bill
  • 2. Re: Airport Extreme & FTP
    frankle Level 1 Level 1 (5 points)
    I have picked "FTP" from the list of applications to forward and on the Extreme it only forwards port 21 and not 20. I am using Pure FTPd Manager which allows you to set up passive ports, and from memory I have set up XXX01 - XXX05 for this purpose, should I set up more??

    As I am on ADSL2+ my MTU size is restricted to 1492 (after having to change this in my previous Netgear WNR854T, not that it did anything mind you, FTP worked with both 1500 and 1492) but I am not sure where I change this on the Airport Utility.

    Thank-you for your input i_t, much appreciated

    Is there anyone out there who is sucessfully port forwarding FTP with their Airport Extreme??
  • 3. Re: Airport Extreme & FTP
    Hans Luijten Level 1 Level 1 (10 points)
    Same problem here

    @Apple; please fix this! Oh and add DynDNS while you're at it
  • 4. Re: Airport Extreme & FTP
    LewMan123 Level 1 Level 1 (0 points)
    I am having the exact same problem and it's driving me crazy. For the life of me no mater how many ports I open up, even when I turn off the firewall on the computer and set up the computer as a wide open dmz host with the airport extreme base station, I can't get that little fetch dog to stop running when I try to connect from a remote location.

    I know I'm missing something, but I can't figure out what it is. Has anyone had luck getting ftp to work behind the base station?
  • 5. Re: Airport Extreme & FTP
    neptune2000 Level 3 Level 3 (670 points)
    I have no problem with both FTP and SFTP. I port forward 20, 21, and 115. I use Fetch. Notice that SFTP did not work with the AEBSn until version 7.2.1 . See below:

    http://fetchsoftworks.com/news/ftp-with-tlsssl-and-the-new-ai.html
  • 6. Re: Airport Extreme & FTP
    Davids8477 Level 1 Level 1 (65 points)
    I was having a similar problem. Ended up using port 2121 for my FTP and it worked fine - port 21 would not work for some reason
  • 7. Re: Airport Extreme & FTP
    rjsnz Level 1 Level 1 (0 points)
    Same issue with a just purchased Extreme. Motorola Cable modem connected to WAN port, port mapping set for FTP, HTTP and VNC access, all have worked prior to the AE, but now I just get (if searching from my work Windows (ugh!) machine, the scanning torch, no file list is ever returned to me. Before it was lightning fast, only change is insertion of the AE instead of an ethernet cable from the cable modem to the PBook. Like I say, HTTP and VNC don't work either, is there likely to be a single common error stopping all of these? Thanks in advance!