7 Replies Latest reply: Mar 13, 2008 11:47 AM by OldBrock
Austinite5 Level 1 Level 1 (0 points)
My HP LaserJet 5MP has been connected to my Macbook on OSX 10.5 using a USB adapter cable and have had no printing issues. When I connect it to Airport Express I get the message that my printer is offline.

The iFelix list of Aiport compatible printers (http://www.ifelix.co.uk/tech/1013.html) does not list mine as compatible but does list the LaserJet 5 and LaserJet 6MP. Does anyone else out there have experience trying to use a 5MP with AE? Is there any reason to hope that Apple will add support for 5MP?

Thx,
Charlie

MacBook, Mac OS X (10.5)
  • Austinite5 Level 1 Level 1 (0 points)
    Installing the latest driver from HP resolved this issue. I guess this post confirms that HP LaserJet 5MP is supported by Airport Express.
  • Austinite5 Level 1 Level 1 (0 points)
    Installing drivers worked for a few tests but it has stopped working now. I see an article called "Print to an unsupported USB printer on Airport Extreme" (http://www.macosxhints.com/article.php?story=20030915050404405) that involves installing the HP Linux Inkjet driver.

    I would appreciate guidance using that solution or any other possible ones to get my HP 4mp to print via Airport Express.
  • EdSprinkle Level 1 Level 1 (0 points)
    I have a somewhat similar problem, although it is not with Airport. I have an HP Laserjet 5P which I have connected to my MacBook Pro 15" (Leopard) with a USB to Centronics parallel cable. I downloaded the latest driver. The Mac recognizes the printer and sends output to the printer, but there is apparently a problem with the printer decoding the input--the text "Postscript" appears in the bunch of text which prints--which I think is Postscript. I would like to get this printer working with my MacBook.

    Ed
  • Henry B. Level 9 Level 9 (78,690 points)
    Which printer do you have - the LaserJet 5MP or the LaserJet 5P.

    For the LaserJet 5MP you can use the LaserJet 5MP Postscript printer driver.

    For the LaserJet 5P you should use the "LaserJet 5P Gutenprint" driver provided in MacOS 10.5. If you use a Postscript printer driver with the non-Postscript LaserJet 5P, your printer will simply print out pages of Postscript code.
  • EdSprinkle Level 1 Level 1 (0 points)
    As it turns out, it is the 5P, not the 5MP ai thought I had. I used the LaserJet 5P Gutenprint" driver provided in MacOS 10.5 and it now works just fine. Thanks for the confirmation.

    Ed
  • EdSprinkle Level 1 Level 1 (0 points)
    Well, the HP LaserJet 5p worked for my test print using the Gutenprint driver, but for everything subsequent the system is locked in a "connecting to printer" mode and not printing. My successful print was illusory. What would be causing that response.

    Ed
  • OldBrock Level 1 Level 1 (0 points)
    Well it seems I have a similar problem. I have a Laserjet 5P which is connected to my MacPro via USB and the driver Gutenprint 5.1.3 selected within Leopard. After one print it tends to to fall back to "waiting for device" The only way to print a second document seems to be to turn off the printer and restart the Mac. Things weren't smooth with Tiger but at least I could get more than one document printed before similar hangup would occur.

    Any suggestions please.