3 Replies Latest reply: Dec 22, 2007 1:19 PM by Jaygyver
Rory Level 1 Level 1 (25 points)
All,

Have a PowerMac G4 933 that I will be installing 4 SATA drives into. Purchased the SIIG SATA 4 channel PCI-M card (specific for Mac).

Before installing SIIG card - system boots fine. Install card, system simply will not boot - screen stays dark, cannot open CD drive, cannot boot from CD etc....

If I remove the SIIG card - system boots fine. I have swapped the card slot location and I get the exact same issue.

I only have 2 of the 4 SATA drives in the system at this time, am going to simply try using only one drive to see if that works.

Pretty frustrating at this point as many have had no issues with this card/system.

thoughts?

Powermac G5 - 2.0GHz; PowerMac G4 933, Mac OS X (10.4.9)
  • 1. Re: SIIG SATA 4 channel PCI-M - problems
    japamac Level 7 Level 7 (24,390 points)
    Hi-

    Sounds like you need to return the card.

    Just because the card is new, doesn't mean that it's not broken/defective.....
  • 2. Re: SIIG SATA 4 channel PCI-M - problems
    Bryan Thurnau Level 1 Level 1 (5 points)
    I have the same problem in my G4 1Ghz. I installed the drivers like is said but still nothing

    Any other suggestions.
  • 3. Re: SIIG SATA 4 channel PCI-M - problems
    Jaygyver Level 3 Level 3 (725 points)
    Good luck,
    I bought two of their Two Channel *Ultra ATA* cards (MP4A) Dec '05 for my 450 AGP and 533 DA and tried for two months going back and forth with SIIG trying different things out and finally got tired of doing their R&D for them and gave them back. It would hard crash (Kernal Panic) if you transfered anything over an EMPTY folder and just ramdomly crash not doing anything with the drives just hooked up. Looking at the crash report you could see the cards were the one crashing the system. I got from their support person that they only had a MDD and one of the first G-5s to check things out on.
    I tried both cards in both computers and it would do the same thing. They even sent me new cards and the same thing would happen.
    I was just thinking on looking again for either the Ultra ATA card or going to the SATA card this time from some one else. Getting tired of partitioning every high capacity drive. No support for over 128 gig drives in the early G-4's.