Previous 1 2 3 4 5 6 Next 77 Replies Latest reply: Sep 8, 2009 3:26 AM by Michael Kuck Go to original post
  • Martin Kopischke Level 1 Level 1 (0 points)
    Bugger this, I tripped over my own smarty-pantness. The find statement I used above will only process the first -or clause it finds, meaning you will need three passes to fully normalise a file whose owner, group and permissions are all off. The way to go, of course, to get the thing into a one liner for launchd is the ";" concatenator, i.e.:

    +find /Applications -type d -name "\*.app" -prune -not -user root -exec chown -R root \\{} \; ; find /Applications -type d -name "\*.app" -prune -group staff -exec chown -R :admin\\{} \; ; find /Applications -type d -name "*.app" -prune -not -perm ug=rwx,o=rx -exec chmod -R ug=rwx,o=rx \\{} \;+

    which takes somewhat longer (as it executes three find passes, something I originally tried to avoid), but will solve the problems in one go.

    I have updated the FileVault Normaliser package to reflect this, and while I was at it, I also improved the GUI script to handle multiple parameters (shift and for, here we come) and to replace the Launch Services reset agent when it is older than the version bundled in the GUI (before, it would not install over an older version). Contact me at myfirstname.mylastname@googlemail.com for a 1.1 version (I’ll send one unsolicited to anybody who has already got one; lucky me that’s a very select clientele, as this is not exactly a state of the art file distribution procedure ).
  • loniux Level 1 Level 1 (0 points)
    Any advances in 10.5.5?
    Anyone?
  • lambertd Level 1 Level 1 (25 points)
    +> Any advances in 10.5.5?+
     

    Nope (and not for lack of trying on my part).

    Haven’t had so much fun with a single feature since System 7.5.5.
  • kaz219 Level 1 Level 1 (15 points)
    Does somebody has this "Filevault Normaliser"? I tried to contact Martin Kopischke, but had not answer. I'd like to try it.
  • gordon142 Level 1 Level 1 (15 points)
    It is truly amazing that Apple pays so little attention to making sure a major OS feature works right. This isn't some obscure issue that only occurs in very specific difficult-to-replicate circumstances. It's easily reproducible on any system using Leopard and filevault, and the fix seems to be quite simple as well (load the launchservices database a few seconds later). Many people have reported it - Apple just doesn't care if it works right or not, clearly. I love how the people at AppleCare and the genius bar will tell you, the second you mention filevault, that it doesn't work properly and you shouldn't use it. Clearly, no one at Apple does use it on a production system.

    I can't wait for PGP WDE to support Boot Camp so I can be done with Apple's encryption once and for all.
  • thirteen37 Level 1 Level 1 (0 points)
    One day, some high profile Apple guy (maybe even Jobs himself) will lose his laptop and regret not having proper encryption. FileVault is just another checkbox on the OS X feature list, not a real, usable system.

    Anyone knows where to get Checkpoint's disk encryption software for the Mac? It seems the only versions on sale are the Windows ones. And more importantly, how well does it work?
  • gordon142 Level 1 Level 1 (15 points)
    I called checkpoint about this the other day. They said to contact one of their regional resellers. Their focus is definitely on the enterprise, but they claim it is possible to get a single user version. Unfortunately, there is no demo available, and not even any specific information on exactly how it operates. Very mysterious. The guy on the phone claimed it supported partition-level encryption, so in theory it should work in a dual boot environment (an advantage over PGP).

    I have not had much luck in contacting their partners. It seems most of them are not interested in selling to you unless you're buying a complete security solution for thousands of dollars for your company. Very annoying that it seems to basically impossible for an individual user to obtain their encryption product.
  • kaz219 Level 1 Level 1 (15 points)
    Did somebody try it on 10.5.6?
  • hotroot Level 1 Level 1 (0 points)
    Yes, bug still present.....
  • Robertmtk Level 1 Level 1 (0 points)
    Same here .... APPLE please fix this!

    MacPro & MacBook with FileVautl and X.5.6
  • Yoshihide K. Level 1 Level 1 (65 points)
    Not fixed. I just cannot believe they're ignoring so many users (though probably not the majority of OS X users)
    The feedback page (http://www.apple.com/feedback/macosx.html) states "We read all feedback carefully"... doesn't seem like that to me.

    Actually, I don't think Apple sees this as a problem. It just defaults back to Apple's applications: Safari, Preview, Mail, etc. If it's a bug that would make Firefox the default browser and Adobe Reader the default PDF reader, then they'll certainly fix it.

    Anyway, we should be sending feedback: http://www.apple.com/feedback/macosx.html
    ...even if there's almost no hope they'll fix it.
  • brentplump Level 1 Level 1 (0 points)
    I ran Software Update last night and was surprised to find Firefox/Thunderbird as the default apps when I restarted my computer. As a test, I set my prefs to Safari/Mail and they stayed that way after restart. After another change to Firefox/Thunderbird and restart, things seem OK.

    I don't think I ever got around to applying a scripted solution suggested here, so I think this may be fixed.
  • Yoshihide K. Level 1 Level 1 (65 points)
    Unfortunately, no, it is not fixed.

    I downloaded and installed the Security Update, but the default browser would still revert back to Apple-preferred settings. (e.g.: Camino would revert back to Safari, Adobe Acrobat would revert back to Preview, etc.)

    The tech people making Mac OS X must be stupid.

    Send feedback here: http://www.apple.com/feedback/macosx.html
  • kaz219 Level 1 Level 1 (15 points)
    Did somebody tried this on snow leopard? Just to be sure that's it's not solved, so I stop hoping.
  • Martin Kopischke Level 1 Level 1 (0 points)
    Um, I finally got around to fixing the glitches in my FileVault Normaliser tool. Apologies to all who have hoped for it, or tried to contact me – life (you know, the real one) had me firmly in its clutches, and it took me ages first to notice the app did not kep file permissions up to date after its first run; then to figure out what I had done wrong (FYI: you can't daisy chain shell commands in a launchd command, if anybody is interested); finally, to fix it, give it a good long test run on my Air, and package it. Anyway, to make up for it, I will point you to the following link:

    http://s3.amazonaws.com/filevault-normaliser/fvn-1.2.0-install.zip

    where you can download the first official release of FileVault Normaliser. Download and unpack the zip and run the package inside it, following the setup prompts. Leopard ony, I'm afraid to say. The source (seeing the thing has to be GPL'ed, as it uses Platypus) is at

    http://s3.amazonaws.com/filevault-normaliser/fvn-1.2.0-source.zip

    The usual caveats apply (viz., I take no responsibility for any kind of effects the tool might have; for all I know, it might eat yout cat, burn your socks and run away with your hard disk, though it has done none of these in the last weeks on my computer). I will however gladly accept any kind of feedback at martin[DOT]kopischke[AT]googlemail.com, though my responses (and especially any enhancements) might be delayed. Sorry about that.

    If things go right, you should run the app once when prompted to provide your admin password by the installer. Afterwards, your app permissions should be normalised and the launch services reset each time you log on, without you having to do anything about it. If you need to, you can also run the app manually (the installer should leave an alias to it in your Utilities folder); run without a parameter, it will normalise all your apps. If you drop an app on it, it will normalise just that one; note however that you will have to provide your admin password each time you do this, unlike the automatic process at logon.

    To uninstall, do:
    – /Library/Application Support/FileVault/
    – /Library/LaunchDaemons/net.kopischke.fvn.NormaliseAppPerms.plist
    – /Applications/Utilities/FileVault Normaliser
    – ˜/Library/LaunchAgents/net.kopischke.fvn.ResetLaunchServices.plist

    Note that app permissions will remain normalised even after uninstall.

    Cheers.