Previous 1 2 Next 20 Replies Latest reply: Jan 21, 2008 7:03 AM by chazbeaner
shibby74 Level 1 Level 1 (0 points)
Hi all,
Several folders on my western digital "My Book" External HD are locked (Videos, My Pictures, etc.) and for some reason I cannot unlock them by clicking info-unlock....any suggestions? I read somewhere else that I need to have administrative privileges and other things, but I tried using their suggestions and nothing has worked. thanks!

Macbook, Mac OS X (10.5)
  • BabyFett Level 1 Level 1 (5 points)
    Same here. Any suggestions out there?
  • Mauricio Pérez Level 1 Level 1 (0 points)
    Hi. I think I have an answer for this question. In a secondary drive (not boot volumne) yo need to enable the "Ignore ownership on this volumne" check box that appears on the botton part of the Info box for the drive (select the drive and prexxx Command+I. Doing this will enable you to lock and unlock files across users and machines using the volumne as a share.
  • BabyFett Level 1 Level 1 (5 points)
    Unfortunately that option didn't pop up? Is there another place I can look for the drive permissions?
  • ken340 Level 1 Level 1 (0 points)
    i am using a external HDD too, i solve my problem when i found out that my external HDD is formatted to NTFS.

    Mac OS X does not support NTFS (write by native) so you have to install NTFS-3G and MacFUSE. google it i am sure there are lots of write up about it.

    if this is not your problem then i am sorry to waste your time.
  • ibosie Level 4 Level 4 (1,115 points)
    Hi,

    Unlock:
    Fire up Terminal (/Applications/Utilities) and type:
    sudo chflags -R nouchg now drag in the folder or folders that are locked then press return. You will be prompted to enter your admin account password.

    Lock:
    The opposite command is uchg
    sudo chflags -R uchg
  • Mauricio Pérez Level 1 Level 1 (0 points)
    Hi: select the drive's icon in Finder desktop, type Command+I the "Ignore ownership in this volume" appears in the info box in the "Ownership & premissions" tab. It will only appear if it's a secondary, non-boot volume. I have it in all my 4 external and internal secondary drives.
  • BabyFett Level 1 Level 1 (5 points)
    No dice. Should I switch it back now? Never used the terminal before.
  • ibosie Level 4 Level 4 (1,115 points)
    When you ran the command in Terminal, was there any feedback? It's not necessary to undo the unlock command unless you want to lock those files of course.
  • BabyFett Level 1 Level 1 (5 points)
    No feedback. I tried it a couple of times. I also posted on MacLife.com and some said it's because the folders were called "My Documents" and "My Music" and "My Photos" and for some reason Apple locks them on the external drive. But the files inside the folders aren't locked, just the folders themselves that contain them. It's just annoying to have those folders in existence. But thanks for trying. I'm open to other suggestions though.
  • ibosie Level 4 Level 4 (1,115 points)
    Could you post the results of command:
    ls -lO now drag in the parent of the directory containing the locked folder and press return.

    This will list in long format and include file flags. Edit out anything personal.
  • Jeffrey Lee Level 4 Level 4 (2,500 points)
    You should also be able to log in as Root, assuming you've enabled that, select the drive icon, and change the permissions...
  • BabyFett Level 1 Level 1 (5 points)
    How do I do that? -- Sorry, Mac noob here.
  • Jeffrey Lee Level 4 Level 4 (2,500 points)
    in the finder, under Help... type Enable Root, and follow the instructions.

    Be very careful... the root user can change anything and can hose your system if you are not careful. You'll have access to documents and directories that you normally can't see.

    You'll need to log out of your standard user, and log back in as root with whatever password you supply.

    Once you have done that, you can go to your external drive, highlight the icon, and make permission changes so you can access the files.

    Just be sure to log OUT of root when your done.

    No need to be afraid, just be careful.
  • kabuoguang Level 1 Level 1 (10 points)
    I've been experiencing the same problem on all my FAT32-formatted external drives, and have figured out a way to fix it. First you need a Windows machine (or virtual machine, which is what i used -- i have Windows XP running in a Parallels vm) to connect the drive to. Once connected, go to the Start Menu, Accessories, bring up a Command Prompt, and go to the parent directory of the locked folder. In my case, the locked folder was "My Documents", so we'll use that as our example.

    Type the following at the command prompt:

    1. attrib "My Documents" (notice it shows an 'R' for read-only)
    2. attrib -r "My Documents" (this will remove the read-only attribute)

    Now if you reconnect the drive to your Mac, you'll see the folder is no longer locked.

    I tried everything I could to remedy the problem using Mac utilities, but even root user couldn't touch the folder. This solution worked perfectly for me, though -- hope it does the same for you. Good luck!
Previous 1 2 Next