6 Replies Latest reply: Jul 15, 2008 7:54 PM by brian.g
jrollans Level 1 Level 1 (0 points)
so a couple weeks ago I decided to try the yahoo contact sync feature in iTunes. Yeah it works, but it takes forever! Like 10 minutes. Where before a sync without yahoo took 10 seconds... So, I dont really use yahoo so turned it off. Guess what? Even though it is now turned off in iTunes, it still syncs to yahoo! I tried deleting all the plist files that I thought might the culprit.. Such as iSync plist and com.apple.yahoo.sync something. The latter however reapears the moment I try to sync...

Any one with any suggestions?

Various, Mac OS X (10.4.10)
  • Randy Weber Level 1 Level 1 (95 points)
    I'm having the same problem. I can't turn off the Yahoo sync feature, even though the preference in itunes for the iPhone shows it disabled. There has got to be a plist file somewhere we can blow away to fix this. I tried restoring the iPhone software, which didn't help.
  • jrollans Level 1 Level 1 (0 points)
    I finally got it to stop doing this.. I cant quite remember what i did to fix it.. it was either in iSync, under preferences, Reset Sync History. or was a plist that i trashed... ill look around and see if i can remember what plist it was if any.
  • Michael Yue Level 1 Level 1 (0 points)
    I've tried a few things already, it's still trying to sync with Yahoo, it would be good if you can remember what you did.

    thanks,

    Mike
  • TimRansom Level 1 Level 1 (0 points)
    Did anyone ever figure this out? It is driving me NUTS! It tries to sync every rime I plug in my iPhone. Plus I think it actually is bringing down some info from the Yahoo Address Book even though I have it turned off. Very frustrating!

    I'm prepping to delete my Yahoo acct. all together as Google does a better job and supports IMAP on more than just the iPhone. Yahoo has been getting worse for a long time now. Tired of it!
  • brian.g Level 1 Level 1 (0 points)
    Bumping this old thread to see if anyone has a solution for making Yahoo sync stop.

    I'm having the exact same problem described here... every time iSync runs for my new MobileMe setup it wants to also sync my contacts with Yahoo, even though I have unchecked the box in Address Book preferences.
  • brian.g Level 1 Level 1 (0 points)
    Just in case someone else has this issue I was able to fix it using the instructions here. The second resolution involving the Terminal command is what did it for me.

    Resolution

    Reset the SyncServices folder with these steps in Mac OS X 10.5:

    1. Open iSync.
    2. Choose Preferences from the iSync menu.
    3. Click Reset Sync History.

    If this does not resolve your issue, or if you are unable to open iSync, follow these steps:

    1. In the Finder, choose Utilities from the Go menu.
    2. Open Terminal.
    3. In the Terminal window that opens, type or paste the following command on a single line:

    /System/Library/Frameworks/SyncServices.framework/Versions/A/Resources/resetsync .pl full

    4. Press Return.
    5. When the operation is complete, quit Terminal.