9 Replies Latest reply: Feb 6, 2008 8:16 AM by A.Fairhead
A.Fairhead Level 1 (0 points)
My iPhone picks up on both of my household networks, both: DHCP and WEP protected.

If I pick the slower one, it says it connects, and appears to be on wifi for a few seconds, then "isn't" anymore.

The second, asks for a password, rather than a WEP key. I've tried putting all sorts into these fields, but connection fails each time. Can I change these networks to ask for WEP? I'm well and truly lost as to how I'm going to get Wifi on my iPhone.

All comments and replies welcome!

Mac Pro 2.66Ghz 5GB RAM, Mac OS X (10.5)
  • jtjacques Level 1 (25 points)
    I had the exact same issue. My iPhone pretended to connect to my WEP WiFi but when checking the IP address in settings it was self issuing one in the 169.x.x.x range.

    The solution is to type in your WEP key as a hexadecimal string.

    This site lets you convert an ASCII key: http://ei4web.yz.yamagata-u.ac.jp/~kinouchi/cgi-bin/ASCIItoHEX.html

    Simply type in the resulting hex key (no spaces) and your WiFi should connect correctly.

    Hope this helps,

    Jason Jacques.
  • Lawrence Finch Level 7 (34,030 points)
    Do you really have 2 wireless routers? DHCP and WEP are not different protection methods; they have nothing to do with each other. DHCP assigns IP addresses, and WEP encrypts data. You can have either, neither, or both enabled. If you don't have two routers one of the ones you are seeing is a neighbor's. It may have other forms of protection, such as MAC filtering. This would explain why you cannot connect to it. The signal may also be too weak.

    When it asks for a password it wants a WEP key. You should enter your WEP key, which may be either a passphrase or a hexadecimal number (contains 0-9 and a-f only). Normally the iPhone can tell which it is when you enter it. But if it doesn't you can enclose the passphrase in quotes or put a "$" as the first character of the hex key. Note that a passphrase is case sensitive, but a hex number is not.

    Hope this helps.
  • Nathan C Level 5 (6,260 points)

    In addition some devices don't assign IP addresses correctly or handle WEP the same way. Have you installed the latest firmware update for your router?

    Hope this helps,

    Nathan C.
  • Damon M. Level 4 (3,695 points)
    One way to test the iphone is to:

    1. On the iphone, go to settings -> general -> reset and reset network settings.
    2. After the iphone restarts, power off the iphone.
    3. Using the admin page for the router, turn off all security for the wireless router.
    4. Power off the router after turning off all security. Disconnect power completely (same with modem).
    5. Power off the cable or dsl modem. The reason for power cycling the modem is because the router might need to pull a new ip address from the modem.
    6. Turn the modem back on.
    7. After the modem comes up, turn on the wireless router.
    8. After the modem comes up completely, turn the iphone back on.
    9. Try to connect to the network.

    If this is successful, then the issue lies with the security on the wireless router.
    If not successful, check to see if there are any firmware updates for your router from the manufacturers website.

    The security that seems to work the best for the iphone and ipod touch is wep 128 bit with 13 char password or wpa with an 8 char password.

    Hope this helps.
  • A.Fairhead Level 1 (0 points)
    jtjacques: It connected, but same as last time - the tick comes up, but no wifi. I tried Andrew Escobar's OpenDNS data with it too, stil no luck …

    Lawrence Finch: Yup, we have 2 connections in the building. One's a slower one, one's a faster one (we all use the faster one). The WEP key is ASCII too, to my knowledge.

    Nathan C: As far as I'm aware, the router is up to date - I don't handle the router; as the Windows machines are working fine (as was Tiger) with the current set up, admin sees no reason to change anything on his end.

    Damon M.: Asked to turn off the security for a moment while I try, but no luck. Admin said he'd have to redo all the new-then-issued WEP keys on the machines in the household, so not an option … Again, he says that the Windows machines are all fine, so that its "my end" that needs to fit in.

    Any and all comments and replies welcome!
  • Lawrence Finch Level 7 (34,030 points)
    Damon, Thanks for that comprehensive description. FWIW, I have had no problems with a 40 bit WEP key at home (Linksys) and a 17 character WPA key (Cisco) in the office. I know the 40 bits is inadequate, but our property is large enough so no one who isn't trespassing can "see" the network.

    The WPA key is difficult to enter correctly, but once entered it works fine.
  • Nathan C Level 5 (6,260 points)

    The reason I recommend updating is because of situations like what is discussed in this thread:

    In that thread, one of the other discussions users posted that the release notes indicated the update helped resolve an issue with assigning IP addresses to some digital devices.

    Most router manufacturers test with Windows-based PCs, and some with Macs in addition. There can be issues with other devices that fall through the cracks in those situations.

    Hope this helps,

    Nathan C.
  • JamesLomas Level 1 (0 points)
    I have a related question about WEP and iPhones. My university (TU/e - netherlands) uses wep protection on their network, but doesn't require a key (the network allows or blocks you based on mac address and computer name). My iPhone has been entered into their system as an accepted device, but it keeps asking for a password. My TU/e password is not the correct password.
    Is there a way to get the iphone to connect without having to fill in a password or get it to 'fill in' the password that the network shares?
  • A.Fairhead Level 1 (0 points)
    The problem solved itself when we upgraded our router, it seems.