9 Replies Latest reply: Mar 31, 2008 10:26 PM by vwsweeden
LowPi Level 1 Level 1 (0 points)
Hello,

Sorry in advance about the basic nature of this question:

A friend of mine gave me an external hard drive. I followed this handy little guide to format it up to step 8. On attempting to erase and reformat the drive, an error message shows which reads "*Disk Erase failed:* Disk Erase failed with the error: Input/output error."

I'm not exactly tech-savvy. I have no idea what's wrong. The friend who gave it to me is a mac guy, and apparently the drive worked just fine on his machine. Can you please help me?

Thanks,

Lo P.

MacBook, Mac OS X (10.4.8)
  • Charles Minow Level 6 Level 6 (9,190 points)
    Hi--

    Welcome to the Apple Discussions.

    The error message you're getting indicates one of two things. Possibly there's something wrong with the drive. Try erasing again, but choose the "Zero Out Data" option in step 6 from the Ken Stone page. That will take a really long time, but if there are some bad blocks on the drive, it should map them out.

    If that doesn't work, then it's also possible that there's something wrong with the cable between the drive and your Mac. Try replacing the cable, and make sure it's seated firmly both at the computer and the drive.

    charlie
  • The Looby Level 4 Level 4 (1,285 points)
    Try erasing again, but choose the "Zero Out Data" option in step 6 from the Ken Stone page.


    Agreed. Also, I'd suggest unmounting the drive before starting any erase or partition
    operation. Maybe DiskUtility does that automatically, but it doesn't hurt to play safe.

    BTW, a single-pass "Zero Out Data" takes a minimum of *10 seconds per GB* on
    a FW800 drive, and twice that on FW400 (and probably a bit longer on USB).

    BTW2, don't open a 'new' DiskUtility window while an erase is in progress; it
    can cause BadThings™ to happen...

    ...don't ask,

    Looby
  • Skage Level 1 Level 1 (0 points)
    The situation you describe sounds familiar. I have a similar problem with my new 24" iMac and my brand new LaCie 1TB external hard drive. The drive does most of the time not show on the desktop (I use the Firewire 800 cable and have tried restarting and disconnecting and connecting the drive any number of times) but it is generally shown in the Disk Utilities window. I have tried to backup using Time Machine, Silverfish and LaCie backup but only get error messages. When trying to repartition or erase the disk using Disk Utilities, I get error messages like "Resource busy" etc. When I manage to get the control or repair function to be available, I get error messages stating that the disk cannot be controlled or repaired. The end result seems to be that nothing works. The problem existed before I updated to Leopard. I bought the new disk because I had problems getting my old 500G USB drive to be detected by the new iMac and assumed the disk had given up. Before that, I had used it to backup my old 20" G5 iMac using Silverfish without any problems. It is hard to believe there is something wrong with both disks. Unfortunately I have no good ideas at this stage, only the sinking feeling that there is an inherent problem in the new iMac (or in me).
  • RomyChung Level 1 Level 1 (0 points)
    I have something of a similar problem, though I wonder if I brought it on myself!

    I have a triple interface La Cie 1TB drive. It seemed to be working ok, but then I made the mistake of trying to drag its icon to a new folder for my final cut pro application (don't ask me why, I know, I am so ********) and now the computer doesn't know where it is. ANd final cut pro isn't working now. Can someone please tell me how to get my La Cie drive to be recognized again by my computer?
  • Matt Wallace1 Level 1 Level 1 (10 points)
    Hi Skage, just wanted to drop you a quick line to say that it might be an issue with the new iMacs. I just tried formatting an external drive on the iMac and i too received the input/output error. I thought i'd give it a shot on my MacBook Pro and it seems to be totally fine. I've been able to re-format it on the MMP without any issues...so far!

    Matt
  • John566 Level 1 Level 1 (5 points)
    My new (2008 revision) Mac Pro is having issues with the USB and hard drives. I get this IO error when doing an erase with USB. It works fine on the same USB enclosure when I use the Firewire port. Good luck.
  • John566 Level 1 Level 1 (5 points)
    This is also plugged straight into the front USB port without a hub. I also had another drive on USB last night that was working but VERY s l o w l y..
  • JSherman Level 1 Level 1 (0 points)
    LowPi, are you using FireWire or USB to partition/erase the drive? I am asking because I had a very very similar problem. I tried using FireWire 400 and 800 to partition the drive and it failed with the same exact error. I tried USB and it partitioned absolutely fine. To make sure that my FireWire busses (in the drive) weren't just burnt out, I connected the drive via FireWire (after partitioning over USB) and it mounted with no problems. Just to put the final nail in the coffin, I tried partitioning over FireWire and it screwed up the drive and gave me the error again. Tried it over USB, worked fine.

    Final story: seems like DiskUtility on 10.4.11 (and maybe even 10.5.2) doesn't like erasing or partitioning external drives over FireWire. Tell me if that helps you at all--I'm very curious to see how that goes.

    Good luck!
  • vwsweeden Level 1 Level 1 (0 points)
    I'm getting an input/output error message in Disk Utility when trying to format a 1T USB Fantom Drive. The drive arrived unformatted. Fantom tech support directed me to an article re this issue, http://www.ilounge.com/index.php/backstage/comments/mac-os-leopard-cant-form
    at-a-usb-hard-disk-seriously/.

    I tried to boot up using a pre-10.4.6 OS, I had a 10.4.4 disc left over from an old iMac, but my new iMac won't boot from that CD.

    My PowerBook G4 wouldn't boot from the 10.4.4 disc either so I started it up from its original 10.3.7 disc. Again, Disk Utility wouldn't format the drive and returned a cryptic numeric error code.

    I've seen a mention of formatting hard drives from the terminal window but I haven't a clue about doing that.

    This appears to be an ongoing problem since release of 10.4.6.