14 Replies Latest reply: Feb 21, 2008 12:14 PM by Pscholey
stephen.walsh Level 1 Level 1 (0 points)
I have deleted the preferences and tried restoring my calendars from .Mac, but everytime I click on the icon in the dock iCal crashes. Restarted and tried again. Nothing seemed to work.

MacBook, Mac OS X (10.5.1)
  • 1. Re: Leopard iCal Crashes
    i812 Level 1 Level 1 (0 points)
    Same issue, Ical crashes. Tried re-installing from Leopard install disk, still crashes. Nothing special about my install, other than it was an upgrade.
  • 2. Re: Leopard iCal Crashes
    fujilicious Level 1 Level 1 (0 points)
    I have the same issue, too. iCal opens, none of my calendars appear on the left, and then about 15 seconds or so later, it crashes. I think this began after the 10.5.1 update was applied. Any suggestions welcomed. Thanks.
  • 3. Re: Leopard iCal Crashes
    stephen.walsh Level 1 Level 1 (0 points)
    The way that I got it working was to insert my Leopard install disc and install iCal only. No need to upgrade and install or archive and install. There is an option to "customize" the install. At that point just install iCal and uncheck all of the other boxes.
  • 4. Re: Leopard iCal Crashes
    fujilicious Level 1 Level 1 (0 points)
    I gave the re-install a try, but when I got to the Customize menu, there is no sub-menu available where I can just select iCal. There are options for printer drivers, one for languages, and one for X11, but the basic OS menu doesn't provide further submenus.
    BTW, when I login as another user on my system, iCal appears to work fine until you close it out, then you get "The application iCal quit unexpectedly" msg. But until you close it out, it works normally.
  • 5. Re: Leopard iCal Crashes
    stephen.walsh Level 1 Level 1 (0 points)
    Hmmm... I'm not sure why I got that option. I'll take another look when I get a chance. You might try Pacifist (http://www.versiontracker.com/dyn/moreinfo/macosx/12743) for now. But if its working in a different user, then it has something to do with your specific user application.
  • 6. Re: Leopard iCal Crashes
    fujilicious Level 1 Level 1 (0 points)
    Thanks for the info, but would you believe that my fix for this is to go to "Get Info" for iCal and have it set to "Open using Rosetta"? iCal now works perfectly under my admin account, although it takes a while for it start up...

    So, my best guess at this point is that somehow the 10.5.1 upgrade has done something to the code of iCal that doesn't permit it to run "natively" on Intel macs under admind accounts. Apple will need to remedy this in a future patch, but for now I guess I can live with a slow-loading iCal as opposed to no iCal at all.

    Thanks for all the suggestions.
  • 7. Re: Leopard iCal Crashes
    Peter O'Toole Level 1 Level 1 (15 points)
    I am using Tiger 10.4.11 and for the past month of more iCal keeps crashing and all my calendars have gone haywire. what is happening, can anyone answer. I am guessing it's a problem with 10.4.11 but only guessing.

    At first i was puzzled but now i am getting very annoyed as the program is completely unusable.

    Does anyone have any answers?
  • 8. Re: Leopard iCal Crashes
    Stephen Lewis2 Level 1 Level 1 (5 points)
    Same problem here; it happened after I did "Archive and Install" from 10.4.11. Tried moving ~/Library/Calendars and ~/Library/Application Support/iCal and ~/Library/Preferences/com.apple.iCal* all to Desktop...no change.

    I even created a new user account...same problem. So it must be in system files somewhere. I copied the .app over from another machine which I upgraded recently...same problem.

    More frustrating and of immediate concern: Mail crashes after awhile; I believe because it is now looking for "To Do". Just uncoupling Mail from iCal would be useful.

    One possible clue: I had forgotten to get rid of dotMacMenu before the upgrade. This took awhile to root out, but it seems to be gone, and the other symptoms cleared up. But in the crash dump, there is a reference to "...../DotMacLegacy.Framwork/...".

    Thanks to anyone with suggestions.
  • 9. Re: Leopard iCal Crashes
    mabou Level 2 Level 2 (350 points)
    Same story here.... long time fan of iCal, use it daily and constantly. iCal has been great until I upgraded to Leopard. Ever since then, iCal has been close to worthless on all four of my Macs.

    Apple... p.. p.. p.. p ulease fix this thing eh?
  • 10. Re: Leopard iCal Crashes
    Peter O'Toole Level 1 Level 1 (15 points)
    This doesn't have anything to do with Leopard guys just so you know. It must be something about iCal that was updated in both Tiger and Leopard as I use Tiger 10.4.11 and it's gone haywire just like in Leopard.
  • 11. Re: Leopard iCal Crashes
    Journeyguy Level 1 Level 1 (95 points)
    Yep. iCal is hanging and giving me the beach ball of death as well in Leopard. When will Apple sound off? Maybe the next update (10.5.2) will be the fix?
  • 12. Re: Leopard iCal Crashes
    John Bardsley Level 1 Level 1 (5 points)
    Hey Y'all

    I just wanted to jump in and agree with previous poster who said that this problem pre-dates Leopard. It has been happening to my system for months now and it is really bad. If I add anything, I have to do it in under a few seconds. It is like beat the clock! Then, instead of doing anything else, I have to quit the program immediately to get the updates/changes to "take."

    After skimming through the other posts, I haven't seen anything that looks like a fix for this. Are there preferences that can be re-set? It doesn't sound like it...any help would be appreciated.

    For the record, I have been using iCal for years without any problems. I haven't recently updated my OS either...this seems like it came out of the blue.

    cheers
    JB
  • 13. Re: Leopard iCal Crashes
    Lou38 Level 1 Level 1 (0 points)
    I had the same problem since I installed Leopard.
    I found the solution on another forum, it takes 5 seconds and it works!!
    http://buzzdroid.com/apple/mac-os-x/ical-crash-after-leopard-upgrade-my-fix/
  • 14. Re: Leopard iCal Crashes
    Pscholey Level 1 Level 1 (0 points)
    I did see that posting you are speaking of. Why would I not have the com.apple.iCal file in my Library/Cache folder?

    I too am having problems with my ical, just recently. I upgraded to Leopard when it first came out and these problems just started within the past week