10 Replies Latest reply: Jan 16, 2008 6:14 PM by stexdoug
gazo Level 1 Level 1 (25 points)
I am having problems with my iBook. It has the screen of death and the following message comes up

kernel attack syas: panic(cpu 0 caller 0x002E1644) : Unable to find driver for thsi platform: "PowerBook6,5"

When I start up from my OS X disc, when I go to Disk Utility, my Hard drive is there but it is greyed out. I take it that the system is not findiong my hard drive. Can I reformat the drive and re-install OS X, or is the problem something else, like a hardware issue?

iBook 700Mhz, 10.3.9, Mac OS X (10.4.8)
  • 1. Re: kernel panic with iBook
    ali brown Level 7 Level 7 (26,465 points)
    Hello gazo!

    What a OS X Kernel Panic is.

    What size is the Hard Drive, and how much space is available?
    How much RAM is installed, and is it original or added?
    What happened shortly before this issue originated.
    Have you made any changes, like upgrading the system, updated or installed any applications or programs, etc?
    What peripherals do you have connected? A keyboard, mouse, printer, external drive or modem, router, etc?
    Is there any consistency as to when it happens. For example, when you are using certain programs or applications?
    Are there any programs or applications, that are set to load at Startup?

    "Unable to find driver for thsi platform: "PowerBook6,5""
    Did you use PowerBook system discs on the ibook?

    Have there been any unusual occurences, like freezes, crashes, power outages, etc?

    Is the Mac shutdown overnight, or does it run 24/7?
    Have you ever run any routine Maintenance procedures?

    You may find use helpful tips in this document Resolving Kernel Panics, authored by Dr Smoke.

    ali b
  • 2. Re: kernel panic with iBook
    OS9Lover Level 1 Level 1 (40 points)
    Whenever the OSX Installer throws the lines "No Drivers for this platform : Powermac x,x" it is almost for sure that you use an unsupported OSX version on your mac or that the Disk is not intentend for that specific model.( and therefore the harddisk is greyed out )

    For Instance you cannot use a CD that says imac G4 on your PowerBook G4 - even if the OSX on that CD "could technically" run on your Book.

    Maybe you have mistakenly switched CDs from another mac ?

    Which OSX version you are trying to install ? If it is Leopard, make sure that you meet all requirement.
  • 3. Re: kernel panic with iBook
    ali brown Level 7 Level 7 (26,465 points)
    Hello Again gazo!

    Member OS9Lover, has similarly inquired, as I did "Did you use PowerBook system discs on the iBook?", in My Previous Reply.

    Is that your situation?

    ali b
  • 4. Re: kernel panic with iBook
    gazo Level 1 Level 1 (25 points)
    Hi Guys,

    Thanks for the responses.

    I was able to reformatt the drive, and then tried re-installing Mac OS X. The disks are the disks that came with the machine. It took forever to do a clean install (like 2 hours). And it took the machine forever to boot up into Mac OS (30minutes). I then targetted the iBook onto my G5 and tried to run Disk Warrior on the drive. Disk Warrior just freezed every time I tried to do this. When I unmounted the iBook drive and then opened Disk Warrior, it opened up fine. So I take it that the drive is messed.

    I am just wondering though, if the drive was messed, how was it able to install Mac OS X?
  • 5. Re: kernel panic with iBook
    ali brown Level 7 Level 7 (26,465 points)
    You're Welcome gazo!

    "I then targetted the iBook onto my G5 and tried to run Disk Warrior..."
    Why ae you running DiskWarrior directly from the iBook?

    ali b
  • 6. Re: kernel panic with iBook
    gazo Level 1 Level 1 (25 points)
    I am running Disk Warrior from my G5. The iBook is targetted onto my G5 so that I can see the drive. When I open Disk Warrior on the G5, and just hangs and becomes non responsive. I have to restart my whole G5. If I run Disk Warrior on my G5 without the iBook mounted on the machine, it opens when with no hitches. So from this I gather that something is funny with the drive on the iBook. How else can I check or repair the hard drive on the iBook?
  • 7. Re: kernel panic with iBook
    ali brown Level 7 Level 7 (26,465 points)
    gazo,

    Again, I don't understand, why you do not run DiskWarrior, directly on the iBook, without using Firewire Target Disk Mode to the G5.

    ali b
  • 8. Re: kernel panic with iBook
    RuloMontero Level 1 Level 1 (0 points)
    hey gazo, any update on this issue? Im having the same problem with a Powerbook G4... Anyone who can help me please?
  • 9. Re: kernel panic with iBook
    stexdoug Level 1 Level 1 (0 points)
    I am having the same problem with an iBook G4. I loaded the latest security patch which required a reboot. Now I am getting the black screen of death (reminds me of the MS days). I tried using Drive Genius to repair but it said that it could not be repaired. I also tried an archive install from 10.4 CDs but it did not work either.

    Message was edited by: stexdoug
  • 10. Re: kernel panic with iBook
    stexdoug Level 1 Level 1 (0 points)
    Gazo

    I was having the same issue with Disk Warrior - it would hang with my iBook G4 when I was getting this kernel panic. I then used Drive Genius to repair the drive. I then was able to get Disk Warrior to run which found 100s of problems - all of which were not corrected. Still got the kernel panic. I tried archive installing the OS from the CD which failed. Ran DG and DW again. Tried archive OS install. Failed again. Did another round of DG and DW - noticed that they were finding fewer problems - mainly a category mismatch issue. The third time to reload OS worked. I ran DU when I got the machine back up, updated to latest patch, crossed my fingers and toes, and the system rebooted. I suspect my HD is going but am up and running for now - backing up the system daily just in case.

    The patch that I installed before getting this kernel panic was Security Update 2007-009 (PowerPC)" (1.1) BTW.

    Hope this helps......Doug