Skip navigation
This discussion is archived

Unlocking Folders

7726 Views 18 Replies Latest reply: May 17, 2008 9:57 PM by lowendthud RSS
1 2 Previous Next
Vitaminmax Calculating status...
Currently Being Moderated
Nov 19, 2007 8:54 AM
Hey, I just got a Mac, and I am having a slight difficulty trying to figure something out.
I have an external Hard drive with all of my school stuff in it. I just finished writing a paper today, and when I went to save it in the folder it was locked. How do I unlock this folder?
iMac, Mac OS X (10.5.1)
  • mrtotes Level 6 Level 6 (11,810 points)
    Currently Being Moderated
    Nov 19, 2007 9:44 AM (in response to Vitaminmax)
    Hello,

     

    To change the permissions on a folder select the folder in the Finder. Right click and choose +Get Info+.

     

     

    Click the padlock and enter the admin password. Then set the access permissions as you need them.

     

    If you wish you can select "+Apply to all enclosed items+".

     

    The other issue could be if you have the drive formatted in NTFS as Macs are able to read NTFS drives but not write to them.

     

    cheers

     

    mrtotes

     Alu iMac 2.8GHz 2GB 500GB PB G4 Ti 1GHz 1GB 120GB, iMac G4 20" 1.5GB 320GB,, Mac OS X (10.5), Miglia Mini & EyeTV2.5, Samsung CLP500, Nano, Shuffle, Touch, SE W810i
  • mrtotes Level 6 Level 6 (11,810 points)
    Currently Being Moderated
    Nov 19, 2007 2:51 PM (in response to Vitaminmax)
    Have a look at this post by The Looby:

     

    mrtotes

     Alu iMac 2.8GHz 2GB 500GB PB G4 Ti 1GHz 1GB 120GB, iMac G4 20" 1.5GB 320GB,, Mac OS X (10.5), Miglia Mini & EyeTV2.5, Samsung CLP500, Nano, Shuffle, Touch, SE W810i
  • kabuoguang Calculating status...
    Currently Being Moderated
    Dec 27, 2007 3:16 PM (in response to Vitaminmax)
    I've been experiencing the same problem on all my FAT32-formatted external drives, and have figured out a way to fix it. First you need a Windows machine (or virtual machine, which is what i used -- i have Windows XP running in a Parallels vm) to connect the drive to. Once connected, go to the Start Menu, Accessories, bring up a Command Prompt, and go to the parent directory of the locked folder. In my case, the locked folder was "My Documents", so we'll use that as our example.

    Type the following at the command prompt:

    1. attrib "My Documents" (notice it shows an 'R' for read-only)
    2. attrib -r "My Documents" (this will remove the read-only attribute)

    Now if you reconnect the drive to your Mac, you'll see the folder is no longer locked.

    I tried everything I could to remedy the problem using Mac utilities, but even root user couldn't touch the folder. This solution worked perfectly for me, though -- hope it does the same for you. Good luck!
    Macbook Pro, Mac OS X (10.5.1)
  • Larry Hutchinson Calculating status...
    Currently Being Moderated
    Jan 8, 2008 6:45 PM (in response to Vitaminmax)
    Thanks!!!!!

    That did the trick! I was having the same problem. Changing the attrib to -r for the locked folder in DOS worked great, I had tried everything else on both in OSX & Windows and changing the folder attributes by any other means would not work. It's been a long time since I did anything at the command prompt in Windows and my company laptop would not allow me to change directories to the external drive to where the locked folder was but as long as you specify the path correctly which in my case was attrib -r F:\"Folder Name" at the command prompt it worked fine. My company computer is running Windows 2000 by the way and my external drive is a "triple interface" (USB, Firewire 400, Firewire 800) 120GB portable drive not much bigger than an iPod that is formatted FAT32 so it will play nice with the Windows machines. I have had no problems with files going back & forth between multiple OSX & Windows machines except for this permissions thing.

    I have one of those "corporate computers" that is so locked down & restricted, thanks to the company's overzealous interpretation of "SOX", that I keep all my work files on an external hard drive so that I can work on my MAC which I do about 95% of the time. Seems a shame really turns a perfectly good laptop into not much more than a paperweight but then again it means I don't have to deal with Windows very much either!
    MacPro 2x3 GHz Dual-Core Xeon & 1.5GHz PowerPC G4, Mac OS X (10.5.1), MacPro: 4GB 667MHz DDR2 FB-DIMM, 1 250 GB SATA, 2x500 GB SATA, Dual Layer Drive
  • blessedtoes Calculating status...
    Currently Being Moderated
    Jan 12, 2008 10:10 AM (in response to Vitaminmax)
    Hi all-
    This discussion has been very enlightening for me. I have a LaCie external drive with my iTunes Music folder on it (about 1400 folders, 30K files) and suddenly a few weeks ago, around the time I updated to Leopard, this happened to me: a random group of 600 folders are now locked.
    So I tried what the last two posts suggested on my PC, but nothing changed. As I don't know much about the command prompt I think I might be doing it wrong, specifically at the point where you said "*go to the parent directory of the locked folder."* I am entering H: at the prompt, and the code changes from C: drive to H: drive, but when I type the first command (attrib H:\"iTunes Music"), I am not getting a response like you suggested I would, one that tells me R. Also, when I try the unlock command (attrib -r H:\"iTunes Music"), the console does something for a split second but nothing changes. Would someone give me a little clearer steps on the middle part in there please?
    Also, since I am having problems with the subfolders, I am wondering if this process will automatically do all the subfolders and files.
    Thanks, all!
    Matthew
    MacBook Pro, Mac OS X (10.5.1), iPod Touch: iPod Mini: Dell w/ Win XP
  • Larry Hutchinson Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 12, 2008 8:37 PM (in response to blessedtoes)
    Matthew,

    I won't pretend to be an expert on this topic, I can only relate to you what I've experienced. This folder locking issue also occurred at the same time I upgraded to Leopard. All of my drives, I have 4 internal and 3 external, except 1 are formated OSX extended, journaled, for these I have no issues. For my 120GB Portable Triple Interface Drive that I travel with and where I keep all my work files that I use on both Windows and OSX machines I have it formatted FAT32.

    On this drive I have the locked folder issue that you can see very readily in OSX. When at the command prompt I used the "attrib -r" "drive letter":\"folder name" command you do not see anything happen but if you then eject the drive from your PC, mount it on your MAC and look at the folder the lock condition should have disappeared. Now, I've found that this does not automatically unlock all of the subfolders and I'm about to go and do that individually.

    Another thing that I'm not sure about is if the folders will stay unlocked. Interestingly I have unlocked a top level folder, a subfolder is locked and I cannot delete or copy files from this subfolder but yet in one of its subfolders I can execute any file operation I wish.

    So my next step is to unlock all folders and sub-folders using the "attrib -r" command on a PC and see if this fixes all the issues and if in the process of going back & forth between Wondows 2000 and OSX 10.5.1 (Leopard) they stay unlocked!

    I hope this helps a little and I'll post again if I am successful.

    Larry
    MacPro 2x3 GHz Dual-Core Xeon & 1.5GHz PowerPC G4, Mac OS X (10.4.10), MacPro: 4GB 667MHz DDR2 FB-DIMM, 1 250 GB SATA, 2x500 GB SATA, Dual Layer Drive
  • Larry Hutchinson Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 12, 2008 9:51 PM (in response to Larry Hutchinson)
    Matthew,

    I've just gone through the process of unlocking all sub-folders that showed up a locked in OSX using a PC running Windows 2000. This seems to have worked quite nicely using, at the command prompt:

    attrib -r "Drive Letter":\"Folder Name"\"Subfolder Name"

    In the case of the PC I used I cannot change directories using the "CD\"Drive Letter" command as it is locked and I don't have administrator access. On a normal PC you should be able to use the CD\ command to change directories to whatever drive letter and folder you wish so that you don't have to type the entire path every time like I did.

    A couple of notes. This operation doens't seem to like long folder or file names or those containing spaces or non-alphanumeric characters. So for many of my sub-folders I had to change the file name to a shortened, one word file name to use attrib -r and then change the file name back afterward. For me this whole process took about 45 minutes but if your entire iTunes file is locked up down to the file name doing this manually will take forever. I don't know of any way to automate the process. I tried doing this using the folder commands on my PC, de-selecting the "read only" checkbox and then applying to all subfolders but as another post indicated this didn't work.

    Good luck,

    Larry
    MacPro 2x3 GHz Dual-Core Xeon & 1.5GHz PowerPC G4, Mac OS X (10.5.1), MacPro: 4GB 667MHz DDR2 FB-DIMM, 1 250 GB SATA, 2x500 GB SATA, Dual Layer Drive
  • Larry Hutchinson Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 12, 2008 9:59 PM (in response to blessedtoes)
    Matthew.

    In re-reading your post again ... does the iTunes folder itself show up as being locked? If not then when you use "attrib -r H:\iTunes Music" or attrib "H:\iTunes Music" nothing is going to happen. If it is locked the command prompt will return "R" for "read only", if it is not locked then a new command line will just appear at the last directory position. The same will happen with attrib -r if the folder is locked or not locked it will just return a new command line after you hit enter.

    As for 600 locked folders I don't know of any way to use this process to unlock multiple folders, there probably is a way to do it but that is way beyond my MS-DOS knowledge.
    MacPro 2x3 GHz Dual-Core Xeon & 1.5GHz PowerPC G4, Mac OS X (10.4.10), MacPro: 4GB 667MHz DDR2 FB-DIMM, 1 250 GB SATA, 2x500 GB SATA, Dual Layer Drive
  • blessedtoes Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 13, 2008 8:22 AM (in response to Larry Hutchinson)
    Hi Larry (and all)-
    Larry, thanks for all the feedback on this. Even if I can't find a way to automate it, at least it's a solution. I will try this again when I get home today.
    To answer the question, the iTunes folder is not locked; just 600/1400 subfolders. What was throwing me off was I expected (based on my limited past experience using the command console in Windows) a long list of definitions for the folder when I put in 'attrib H:\"iTunes Music",' and got nothing... well, actually I got a response without quotation marks (H:\iTunes Music was the only reply). Based on this I thought I might be doing it wrong.
    If you wouldn't mind checking back on me in a few days here, I'd appreciate it.
    With gratitude and blessings,
    Matthew
    MacBook Pro, Mac OS X (10.5.1), iPod Touch: iPod Mini: Dell w/ Win XP
  • blessedtoes Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 14, 2008 8:14 AM (in response to blessedtoes)
    Hi again all-
    Well I eventually got the process down, and though mind-bogglingly slow, it works. I am in a situation where I have to plug the drive into the MacBook Pro, open every folder (all locked folders also have all subfolders locked, however there are some locked subfolders with unlocked parents!), use Grab to capture an image of the drive's locked ones, eject and move to the PC and go through folder by folder.
    It boggles my mind that there isn't a better solution to this.
    There is one remaining problem - any locked folder from a world music or other artist with any umlats or accents over vowels in the name - DOS command doesn't like those, so how to get them unlocked remains a mystery....
    Thanks again for all your help, Larry.
    Matthew
    MacBook Pro, Mac OS X (10.5.1), iPod Touch: iPod Mini: Dell w/ Win XP
  • Larry Hutchinson Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 14, 2008 3:58 PM (in response to blessedtoes)
    Matthew,

    I didn't have the problem with umlats, accents, or other special characters but did have a similar problem with some file names. To solve this I just re-named the file in Windows Explorer to a simple file name, un-locked it, and then went back and renamed the file to the original or something similar. Now with the special characters you mention this can get a little tedious as you may have to open MS-Word, open a blank document, type the file name and insert the special characters from the insert symbol menu. There are probably keyboard short-cuts for this and it may be easier to re-name them back in OSX but I don't know off the top of my head how to do that.

    Good Luck!
    MacPro 2x3 GHz Dual-Core Xeon & 1.5GHz PowerPC G4, Mac OS X (10.5.1), MacPro: 4GB 667MHz DDR2 FB-DIMM, 1 250 GB SATA, 2x500 GB SATA, Dual Layer Drive
  • paolinocosta Calculating status...
    Currently Being Moderated
    Jan 27, 2008 12:55 AM (in response to blessedtoes)
    I had the same problem an fixed it.
    To do the attrib command for folder AND sublfolders read this, especially about parametres
    http://www.computerhope.com/attribhl.htm
    ciao
    PAOLO
    MacboockPRO 15" 2,2Ghz 120Gb rar, Mac OS X (10.5.1)
  • ray_st_michael Calculating status...
    Currently Being Moderated
    Apr 9, 2008 4:26 AM (in response to Vitaminmax)
    Yah that windows trick works charms. I had the same problem. I couldn't unlock my folders on my External HD (FAT 32).

    Running - Macbook pro - 10.5.2

    I went on my win xp machine went to command prompt did the attrib -r "<folder name>" and it removed the R from infront of the folder name. - attrib "<folder name>" to check. Plugged it back in my mac and the padlocks were gone.
    macbook pro, Mac OS X (10.5.2)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.