13 Replies Latest reply: Jun 7, 2008 12:33 PM by Hot Tamale Baby
Pacheco Level 1 Level 1 (0 points)
I have one ibook G4 it stopped to read dvd/cd does not read nor the CD of the System, the model of superdirve is:
MATSHITA DVD-R UJ-845E:

Firmware Revision: DMP2
Interconnect: ATAPI
Burn Support: Yes (Apple Shipped/Supported)
Cache: 2048 KB
Reads DVD: Yes
CD-Write: -R, -RW
DVD-Write: -R, -RW, +R, +RW
Burn Underrun Protection CD: Yes
Burn Underrun Protection DVD: Yes
Write Strategies: CD-TAO, CD-SAO, DVD-DAO
Media: No

Anybody help me

iBook G4 1.42Ghz 14, Mac OS X (10.4.11), Ibook G4 14.1 1.42Ghz
  • 1. Re: Ibook Superdrive Eject CD & DVD
    S.U. Level 6 Level 6 (8,360 points)
    Welcome to Apple Discussions!

    One thing to do is to go to Disk Utility and verify permissions and repair if necessary. Sometimes the permissions can get messed up and cause problems.

    Good luck!
  • 2. Re: Ibook Superdrive Eject CD & DVD
    Pacheco Level 1 Level 1 (0 points)
    Hi, I repaired the permissons and try too reset PRAM and PMU , but it did not resolv, the problem continues, the superdrive does not spin and ejects any cd or dvd
  • 3. Re: Ibook Superdrive Eject CD & DVD
    S.U. Level 6 Level 6 (8,360 points)
    If repairing permissions did not help, then I'm not sure what to suggest next. It is possible that the drive has failed, but it would be best to hear from some of the more experienced and knowledgeable members of the forum before giving up on it. Perhaps they can tell what is happening from the information that you posted.

    Good luck!
  • 4. Re: Ibook Superdrive Eject CD & DVD
    Susan M Level 2 Level 2 (320 points)
    This may not work, but you can try to start up the system in Safe Mode.

    To do this Shut down, then startup holding down the Shift key. Hold it until you see the spinning gear (this might take some time). When your Desktop appears go to Disk Utility again and Repair Permissions. Then restart normally. Give it a try.
  • 5. Re: Ibook Superdrive Eject CD & DVD
    venturarick Level 1 Level 1 (0 points)
    Did you ever resolve your problem? I have the same problem with the same Matsushita drive. I am about to replace it. It did work once again in the middle of several 10s of tries, but only once. I had this problem once before, several months ago, but restarting solved the problem. I surely hope it isn't a software problem, because replacing the drive will cost me both money and potentially time.
  • 6. Re: Ibook Superdrive Eject CD & DVD
    John C Goodman Level 1 Level 1 (5 points)
    On My iBook holding the "fn"key and F12 worked
  • 7. Re: Ibook Superdrive Eject CD & DVD
    Pat Camporeale Level 1 Level 1 (5 points)
    Hiya ..

    I've been noticing this same problem on two iBooks we have in our shop.

    Any CD/DVD (blank, commercial audio, commercial movie, etc.) spits out.
    I can hear the drive spin up. Then spins down and it ejects.
    Even it's own system disks...

    I sent it to a repair shop once and they found nothing wrong with it. They charged me and gave it back to me. I inserted media and low and behold ... there it was on the Desktop.
    Ok, 'my bad' .

    Released the iBook back to my user and within a week she tells me, "it's spits out any disk I insert". So I sent it back to the Farm.

    Today, another iBook user... same exact errors.

    hhhhhmmmmmmmmm ....... Time released hardware failure?

    So here I am and found a few of you with the same problem.

    In my opinion, aside from owning AppleCare, which I think is the only saviour of this hardware failure. I wouldn't expect anything thing from Apple Formerly Computer except the usual 'Throw it away and buy another Mac' upgrade policy.

    -p
  • 8. Re: Ibook Superdrive Eject CD & DVD
    astramare Level 1 Level 1 (0 points)
    Hi
    I have the same problem
    what about repair permissions ?
    I did start in safe-mode
    and the disk-utility from applikation / utility - folder

    can see the hard-disk and the dvd - entries
    but first-aid and repair permissions is open only to hard-disk
    or is this not the right disk-utility ?

    can I check this in terminal as su in /dev or so ?
    is ther a mount of the optical drive ?
  • 9. Re: Ibook Superdrive Eject CD & DVD
    venturarick Level 1 Level 1 (0 points)
    Just an fyi for anyone having this problem. I was ready to purchase the LaCie external Firewire bus-powered DVD when my internal DVD just started working. It has been working for a few weeks now with no apparent problem. I can't think of anything I did that would have caused the drive to start spinning up. I suppose I could have a connection problem, but it seems unlikely to me now that the motor in the drive has failed.
  • 10. Re: Ibook Superdrive Eject CD & DVD
    Hot Tamale Baby Level 1 Level 1 (10 points)
    I just replaced the CD drive on my iBook with the Matsushita drive and although the drive is recognized in the system profiler, it won't accept any media. Repair permissions had lots of lines re DVD so I will try a restart.
  • 11. Re: Ibook Superdrive Eject CD & DVD
    Hot Tamale Baby Level 1 Level 1 (10 points)
    It was a bad drive. Powerbookmedic sent another one and it works.
  • 12. Re: Ibook Superdrive Eject CD & DVD
    loftmama Level 1 Level 1 (0 points)
    same computer, same software, same drive, same problem, no resolution. just posting to log in the same situation and see how to get resolutiong. looks like buying a new computer or a new drive is the only real solution!
  • 13. Re: Ibook Superdrive Eject CD & DVD
    Hot Tamale Baby Level 1 Level 1 (10 points)
    Replacing the drive is an option if you want to DIY--they are not that expensive. My problem was a defective drive but taking apart the computer is not for the faint of heart and you really need the right tools. Two sites provide detailed instruction--PowerbookMedic and ifixit. I have to go back in because the left speaker wire must have been compromised and I have some static out of that speaker when the replacement DVD went into action (goes away with earphones or earbuds plugged in) so when I go back in it will be to upgrade the hard drive and add ram in addition to fixing the speaker wiring. If you don't want the DIY hassle but love the small footprint you might want to wait to see if any of the rumors about a subnotebook Air or tablet come to be.