Previous 1 2 Next 21 Replies Latest reply: Feb 11, 2008 7:35 AM by Saul123 Go to original post
  • ThiloRoe Level 1 Level 1 (0 points)
    Same problem here on my Macbook.

    What I found is that the administrator only had read rights to ~/Library/Keychains/login.keychain and /Library/Keychains/System.keychain. I changed this to read&write and now the keychain at last is able again to save passwords. Then I ran the Keachain Firts Aid and now everything seems to be fine again!
  • thegrids Level 1 Level 1 (0 points)
    Interesting... how did you discover and verify that you could only read/not write? Did you go to users in systempreferences or something in keychain app?
  • Nashlore Level 1 Level 1 (0 points)
    I have the same problem.

    When I have tried "Reset My Keychain", the problem kinda got worse, since all the internet passwords now is saved as applications keys, which the AirPort obviously can't use.

    Any suggestions?
  • killer bob Level 2 Level 2 (210 points)
    Is there any way to completely uninstall the Keychain app, trash preferences and start all over again?

    I'm becoming so used to entering my password all the time since installing Leopard, I'm beginning to accept it as normal. Maybe there are thousands of new Mac users out there who have the same problem- but don't know it...

    In space no, one can hear you scream.
  • thegrids Level 1 Level 1 (0 points)
    I found the following post and so far is helpful:

    http://discussions.apple.com/thread.jspa?messageID=5844256&#5844256

    After reading the post I found
    1)I did not have a specific user-named keychain in my library. I added a new, user-named keychain, made this new keychain default, copied over all info from "login" keychain via the app keychain access, ran keychain first aid, and changed it's settings so that the keychain does not lock. So far it's solving my issue of a chronic window pop up requesting my password regardless of different apps.

    Is this a band-aid fix or is it done? : )
  • Robert DiIorio Level 1 Level 1 (0 points)
    I opened the keychain access, chose System on the left pane, highlighted and then double clicked on the highlighted certificate which was red, I clicked on Trust in the left side and set "when using this certificate" from use defaults to always trust.
  • Saul123 Level 1 Level 1 (0 points)
    The post above from ThiloRoe solved my problem!! I've been trying for days to get my keychain working again and have been running into all kinds of crazy problems. I was getting the message "An error occurred while creating a new keychain" no matter what I tried. Here's how I fixed it (writing this out the long way for those who aren't so good with this stuff):

    Open up the main disk icon on your desktop.
    Under the heading "Devices," select your hard drive.
    Select "Library."
    Now right click (hold the "ctrl" key and click) the "Keychains" folder, and selcect "Get info".
    Scroll all the way down until you see the little padlock icon in the bottom right hand corner.
    Click the padlock and enter your password.
    Now toggle each of three of the options under the heading "Privilege" to "Read & Write."
    Close that window and go back to the main disk (like in step 1).
    Under the heading "Places," select your user account.
    Select "Library."
    Now do the same thing as before (right click, padlock, etc.) to the "Keychains" folder.
    Now open up that "Keychains" folder, and if there's anything in it (the document will probably be called "login.keychain"), right click it and do the same thing as you did to the "Keychains" folders.

    Now you should be all set! Woo-hoo!
Previous 1 2 Next