7 Replies Latest reply: Jan 25, 2008 8:38 AM by Nicholas Down
josemagalhaes Level 1 Level 1 (0 points)
Hi,

I have a 17-inch iMac (2Ghz cpu) and ever since I updated to 10.4.11 my wireless connection has been very slow. I used to have download speeds between 150 and 200 KB, and now I can’t get past 20 or 30 KB. I have an XP laptop right beside the iMac, using the same wireless router and the connection is a lot faster, achieving the 200 KB I used to have with the iMac.

I also used to transfer files a lot faster than I do now. I connect to a pc through smb and transferring files is really, really slow. It takes ages just to begin the transfer, and a 5MB file can take up to 15 minutes. It never took this long…

The connection is quite stable though, it rarely disconnects, so I’m not sure whether I’m having the same problem other users have been posting in the forums. What I do know is that the update messed with my wireless connection.

I’ve tried running Disk Utility’s repair disk permissions, Applejack’s AUTO repair, trashing plist files that I saw in other posts, nothing works.

Anyone with the same problem? Any ideas?

Thanks,

josemagalhaes

iMac, Mac OS X (10.4.11)
  • BDAqua Level 10 Level 10 (120,360 points)
    You've done all the right things... only thing I could suggest is an Archive & install, then stop at upgrades where it worked... on my part, I'm a bit amused how 10.4.3 just works, and anything beyond has some "issues".

    Welcome to the Discussions btw! "-)
  • stgrht Level 1 Level 1 (0 points)
    I've had all the same problems, and have tried all the same things. I don't know what to do and it's driving me absolutely crazy.

    This really basically began to happen after I installed the update. It's the strangest thing. I really want to avoid reinstalling.

    GRR--
  • stgrht Level 1 Level 1 (0 points)
    I don't know if this helps, but after getting very frustrated, I plugged in the ethernet cable to my router and then to the IMac just to make sure that I could still get good speed on the IMac. Worked fine, and when I unplugged and went back to wireless, it seems to be working just fine now.
  • josemagalhaes Level 1 Level 1 (0 points)
    Since nothing else worked, I tried reinstalling Tiger. A new, clean installation on a formated hard drive. Everything seemed to be working ok running 10.4.7. Wireless was fast again, and internet and SMB connections were at their normal speeds.

    Then I ran Software Update, it downloaded and installed the 10.4.11 combo update. After reboot, wireless is slow again and SMB file transfers don’t work. Activity Monitor shows download speeds around 30KB/sec (but constantly changing). Before the update they were around 400 and 500KB/sec.

    No doubt this is a bug in 10.4.11... hopefully Apple will issue a fix, but judging by what I’ve been reading in the forums, we might as well just keep using 10.4.10 or any other version that still works flawlessly.

    I’ll keep on trying to find a way of getting decent wireless speeds. If I find something useful I’ll post it here.
  • josemagalhaes Level 1 Level 1 (0 points)
    Hi again,

    I think I found a solution for this. It’s not the best solution, more of a workaround, but it’s been working for me.

    Searching other threads, I found this topic about users who had intermittent connection to the internet (http://discussions.apple.com/thread.jspa?threadID=1027382&tstart=0). I tried changing the settings in my wireless router – not Linksys, it’s an Asus WL-520G, but has similar options – and the speeds were up again! SMB file transfers work at good speed, and the internet connection is back to normal.

    I’m not sure what these settings are for, but anyway all I did was change the “Beacon Interval” to 50, “RTS” to 2304 and “Fragmentation” to 2305 (I didn’t change the MTU because that seemed to be a PPPoE setting, not wireless).

    As I said, it’s not really a fix, because nothing changes in OS X, but anyway it may help some users who’ve been having the same problem.
  • peter reg Level 1 Level 1 (0 points)
    I had download speeds of 400-500 but now it has slowed to a measly 10-30. What's going on? This has happened after updating to 10.4.11. Is it possible to undo the update and return to my previous setup ? No one seems sure how to fix it or what is really causing this.
  • Nicholas Down Level 1 Level 1 (45 points)
    I've just come across this forum thread since posting a new question/problem about 10.4.11 on the Tiger connecting/internet forum.
    10.4.11 has been disastrous with my PowerMac G5 duo. Rated speeds on ADSL have dropped to anywhere between 650 kps and 3750 kps on a 6500 rated ADSL line.
    I use Airport wireless network via netgear 834 router and a WEP security protocol. This is despite all the attempted workarounds I've seen elsewhere.
    Using the same network my MacBookPro core duo 2.4 GHz achieves speeds of 6000kps: the MBP is using Tiger 10.4.10!
    Downgrading to 10.4.10 on the Powermac is an option but will consume hours of time... via Archive and Install (see Macfix it tutorial on subject)
    For the time being I suggest staying away from upgrading to 10.4.11 until Apple fix this.
    Or get Leopard?